Go Back   The macosxhints Forums > OS X Help Requests > Applications



Reply
 
Thread Tools Rating: Thread Rating: 3 votes, 5.00 average. Display Modes
Old 02-28-2009, 10:41 AM   #1
vernalbogneris
Prospect
 
Join Date: Dec 2008
Posts: 10
iTunes not grouping some albums

I like to have the shuffle albums feature turned on. However, sometimes albums are not grouped properly, i.e. Track 1 will play then it will shuffle to a different album; or sometimes Tracks 1-3 and then a new album.

I can fix this sometimes by doing a Get Info on the whole album and ensuring the tags are the same for all tracks, eg. there's no Disk Number or Album Artist settings in play. I'll even resave the ID3 info in 3rd party tag editor software. But some albums can't seem to be fixed no matter what I do.

Anyone?
vernalbogneris is offline   Reply With Quote
Old 02-28-2009, 12:00 PM   #2
matthewclower
Triple-A Player
 
Join Date: Feb 2009
Location: Gilroy, Ca
Posts: 138
I've had the same problem before. When I view the albums in the cover view there are sometimes two covers for the same album that aren't grouped together (I've also seen the same for TV Shows) ... I don't know what causes it and would like to know, but I have found that if I just remove the whole album from iTunes and reimport the files, they get grouped together properly.
__________________
Matthew Clower

MacBook Pro 3,1 - 4GB RAM | iPhone 3G MB704LL - 16GB | iPod Touch MB376LL - 32GB

http://twitter.com/matthewclower
http://www.linkedin.com/in/matthewclower
matthewclower is offline   Reply With Quote
Old 03-01-2009, 02:21 AM   #3
tw
Hall of Famer
 
Join Date: Apr 2007
Posts: 4,262
usually this means that one or two mp3s have slight variations in their track data (even something as subtle as a missing track number, or having their genre set to something different). this will cause iTunes to treat them as though they came from different albums. synchronizing the track data will solve the problem.
__________________
Philosophy is a battle against the bewitchment of our intelligence by means of language. -LW-
tw is offline   Reply With Quote
Old 03-01-2009, 08:38 AM   #4
EatsWithFingers
All Star
 
Join Date: Feb 2005
Posts: 726
Quote:
Originally Posted by matthewclower
I've had the same problem before. When I view the albums in the cover view there are sometimes two covers for the same album that aren't grouped together (I've also seen the same for TV Shows) ... I don't know what causes it and would like to know, but I have found that if I just remove the whole album from iTunes and reimport the files, they get grouped together properly.

This can happen if the album contains tracks by different artists, but is not a compilation. For example, if one of the tracks on the album features another artist, e.g. the "Artist" info for one track is <ARTIST1> feat. <ARTIST2>, while all other tracks just have <ARTIST1>.

In this situation, iTunes will group the track with the featured artist separately from the other tracks. To fix this, just enter <ARTIST1> in the "Album Artist" tag.

Quote:
Originally Posted by vernalbogneris
I can fix this sometimes by doing a Get Info on the whole album and ensuring the tags are the same for all tracks, eg. there's no Disk Number or Album Artist settings in play. I'll even resave the ID3 info in 3rd party tag editor software. But some albums can't seem to be fixed no matter what I do.

It seems odd that removing the "Album Artist" info fixes your problem. In my experience, the problem only arises if the "Album Name" and "Artist" tags are different (when the "Album Artist" tag is empty). If the "Album Artist" tag is not empty, then that is used in place of the "Artist" tag to group tracks for a given album name.
__________________
Question everything -- especially that which you already believe to be true.
EatsWithFingers is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.