Go Back   The macosxhints Forums > OS X Help Requests > Networking



Reply
 
Thread Tools Rating: Thread Rating: 11 votes, 4.64 average. Display Modes
Old 11-14-2008, 03:47 PM   #1
king0fpei
Prospect
 
Join Date: Nov 2008
Posts: 3
Question Xbox 360: Open NAT (using Airport Express)

I have been searching through internet forums and troubleshooting for hours trying to solve my problem. My issue is: My Xbox 360 is connected wirelessly to my Airport Express to connet to Xbox Live. However, when you run a Network test on the Xbox 360 the NAT is showing as "Moderate". It can be Strict, Moderate, or Open. In order to play online without issues, it has to be set to Open. There are many forums and guides online explaining how to create an Open NAT using Microsoft compatible routers (DLink, etc.), but I need step-by-step instructions how to accomplish this task with an Airport Express. I have many things including setting Static IPs, Port Mapping, Resetting, etc. but cannot achieve my goal and it is driving me insane!

Please help.
king0fpei is offline   Reply With Quote
Old 11-14-2008, 04:01 PM   #2
trevor
Moderator
 
Join Date: Jun 2003
Location: Boulder, CO USA
Posts: 19,815
You need to put your XBox 360 into the DMZ (de-militarized zone). Directions to do so with the Airport Express are here.

Trevor
trevor is offline   Reply With Quote
Old 11-14-2008, 04:11 PM   #3
king0fpei
Prospect
 
Join Date: Nov 2008
Posts: 3
Hey Trevor,

I've actually followed those steps from that exact page already. They were a little different for the 360 (that page is for the PS2), so I'm not sure if that's where I went wrong... because unfortunately it didn't work. As I've said, I've googled this issue a hundred different ways and looked through every page that seemed even somewhat relevant, and haven't been able to fix this. The worst part is that this kind of thing completely consumes me until I get it right...

My goal in posting to forums is hopefully to find someone who was in a similar situation, but has achieved an Open Nat, and can tell me exactly how they did it.

A few months ago I did have an Open Nat and all was good. But then I did two things: updated the firmware on my Airport Express (to be compatible with the new iTunes) and bought a new 360. This is when my problem started.
king0fpei is offline   Reply With Quote
Old 11-14-2008, 04:22 PM   #4
trevor
Moderator
 
Join Date: Jun 2003
Location: Boulder, CO USA
Posts: 19,815
Sorry, I don't have any Apple-brand router (like the Airport Express), so I can't give you specific directions myself. But the answer, in general, is to put the XBox 360 into the DMZ. That's the way that my XBox 360 is set up with my Belkin N1 Vision router, and it works perfectly.

(Which brings me to another point--you mention "Microsoft compatible routers" in your original post. There's no such thing, or maybe to say it another way, all routers are compatible with all operating systems that handle TCP/IP. So, there's no more a specific Microsoft compatible router than there is a Solaris compatible router, or a Linux compatible router, or a Mac compatible router, or a CP/M compatible router. All routers route TCP/IP, and all computer platforms that are capable of TCP/IP are compatible with them.)

Perhaps someone else with an Airport Express can tell you how to turn on the DMZ for your XBox 360. I realize that the directions I linked to above are for the Playstation 2, but that doesn't matter, they should work just fine. What matters is turning on the DMZ for the IP address of your game console.

Trevor
trevor is offline   Reply With Quote
Old 11-14-2008, 04:43 PM   #5
king0fpei
Prospect
 
Join Date: Nov 2008
Posts: 3
Thanks for the help,

When I said "Microsoft compatible routers" I was vague... was referring to this:

http://support.xbox.com/./support/en...equipment.aspx

This is why I'm assuming nobody seems to know how to get the Airport Express and 360 to work together with an Open Nat.

I do understand the DMZ notion. With the Airport Express it is in the Base Station Settings and is called: "Enable Default Host At"... When checked it gives you space to input an IP address. What I did to the best of my ability was give the Xbox 360 a static IP address and then input that as the Default Host on my Airport. I also attempted to Port Forward the Xbox Live required ports to my 360: UDP 88, UDP 3074, and TCP 3074.

Buut, I'm not entirely confident in how I did it and whether I was using the proper IP addresses in various fields... as you have to input many different IPs into the Xbox 360's network menus (IPs, Gateways, DNSs, etc.) and in the router as well...

It certainly seems that I have mistepped somewhere as I still have the "Moderate" NAT... I just don't know where I went wrong.
king0fpei is offline   Reply With Quote
Old 11-17-2008, 12:47 PM   #6
trevor
Moderator
 
Join Date: Jun 2003
Location: Boulder, CO USA
Posts: 19,815
Quote:
Originally Posted by king0fpei
When I said "Microsoft compatible routers" I was vague... was referring to this:

http://support.xbox.com/./support/en...equipment.aspx

Ah! Maybe Microsoft approved routers, or Microsoft certified routers, or some name like that.

I can assure you that most routers not listed there work, and that I'm using a Belkin Vision N1 (not on Microsoft's list) with my XBox 360 with no problems.

Quote:
Originally Posted by king0fpei
This is why I'm assuming nobody seems to know how to get the Airport Express and 360 to work together with an Open Nat.

I'm sure someone knows, it's just that I don't, as I don't own any Apple brand routers.

Quote:
Originally Posted by king0fpei
I do understand the DMZ notion. With the Airport Express it is in the Base Station Settings and is called: "Enable Default Host At"... When checked it gives you space to input an IP address. What I did to the best of my ability was give the Xbox 360 a static IP address and then input that as the Default Host on my Airport. I also attempted to Port Forward the Xbox Live required ports to my 360: UDP 88, UDP 3074, and TCP 3074.

Buut, I'm not entirely confident in how I did it and whether I was using the proper IP addresses in various fields... as you have to input many different IPs into the Xbox 360's network menus (IPs, Gateways, DNSs, etc.) and in the router as well...

It certainly seems that I have mistepped somewhere as I still have the "Moderate" NAT... I just don't know where I went wrong.

Why don't you tell us exactly what you have in all of the various fields? And tell us explicitly what IP address you have set for the various devices? Maybe we'll see something set incorrectly.

Trevor
trevor is offline   Reply With Quote
Old 11-17-2008, 01:51 PM   #7
Anti
MVP
 
Join Date: Dec 2006
Location: Concord, CA
Posts: 1,530
I wouldn't worry about. I play on Xbox Live all the time with a Moderate NAT as I run my Xbox 360's ethernet cable into my MacBook, who shares the AirPort internet connection to the Xbox 360. I've tried to get it to say "Open", but nothing works.

Don't sweat it unless you are actually having problems with Xbox live.
__________________
Xodium Dot Net.
Anti is offline   Reply With Quote
Old 12-23-2008, 08:41 PM   #8
RMH1960
Prospect
 
Join Date: Dec 2008
Posts: 3
XBOX Live Strict NAT with Airport Express

I too am trying to solve this problem. My XBOX says my NAT is Strict, even after successfully setting up the XBOX to the network, as instructed by this and other forums on the matter.

Here's what I've done, in detail:

First STEP – XBOX Settings:
INFO – I have a Standard XBOX, connected to my wireless network as follows: XBOX Ethernet Port > 5-port Linksys Switch > Airport Express in “join a wireless network” mode > (Second) Airport Express in “Create a Wireless Network” mode > DSL Modem.

In XBOX Dashboard, Navigate to Network Settings – reset to factory defaults, to be sure to clear all previous settings.

Select IP “Enter Manually”
Then Enter:
IP Address: 10.0.1.253
Subnet Mask: 255.255.255.0
Router (Gateway): 10.0.1.1
SAVE

Select DNS “Enter Manually”
Then Enter the DNS Numbers you get from your ISP. Mine is Windstream, and they gave me the info over the phone:
Primary DNS: XXX.XXX.XXX.XXX
Secondary DNS: XXX.XXX.XXX.XXX
SAVE
Shut the XBOX Down

Second STEP - Airport Express Settings:
INFO – My Wireless Network uses WPA/WPA2 Personal Security Setting. My Network is NOT Closed. Also, I am running Mac OS 10.5.6 in an Intel iMac, Airport Utility 5.3.2, and both Airport Expresses have 5.3.2 firmware. Also, I am running the 802.11n (802.11b/g compatible mode, with interference robustness).

On the Mac, Navigate Here:
Airport Utility > Airport Express "Name" > Manual Set Up > Internet Icon> NAT Tab > CHECK “Enable NAT Port Mapping Protocol.”
Click “Configure Port Mappings…” Button
This takes you to:
Airport Utility > Hayes Express > Advanced
You do not need to select anything from the drop down menu “Choose a service”
Click in the plus symbol to add
Enter, as Follows:
Public UDP Port(s): 88
Public TCP Port(s): 3074
Private IP Address: 10.0.1.235
Private UDP Port(s): 88
Private TCP Ports(s): 3074
Click Continue…
Enter a Description ”XBOX Live” leave everything else blank /unchecked
Click Done…
Click Update…

Third Step – Reboot the network:
After the Base Station resets, and confirm Internet access from Mac, unplug base station and DSL/Cable Modem.
Plug in Modem, wait for it to complete boot up.
Plug in Base Station, wait for it to complete boot up.
Start XBOX, go to Network settings, run test for XBOX Live.
XBOX Live Connection is successful – BUT the NAT is still Strict!!!!

So, does anyone have any thoughts or feedback for my effort?

Rocky
RMH1960 is offline   Reply With Quote
Old 12-24-2008, 11:24 AM   #9
trevor
Moderator
 
Join Date: Jun 2003
Location: Boulder, CO USA
Posts: 19,815
Quote:
Originally Posted by RMH1960
Second STEP - Airport Express Settings:
INFO – My Wireless Network uses WPA/WPA2 Personal Security Setting. My Network is NOT Closed. Also, I am running Mac OS 10.5.6 in an Intel iMac, Airport Utility 5.3.2, and both Airport Expresses have 5.3.2 firmware. Also, I am running the 802.11n (802.11b/g compatible mode, with interference robustness).

Only use interference robustness if you've actually found that you're getting problems without it. If you use interference robustness when it is unneeded, it will actually slow down your wireless networking.

Quote:
Originally Posted by RMH1960
On the Mac, Navigate Here:
Airport Utility > Airport Express "Name" > Manual Set Up > Internet Icon> NAT Tab > CHECK “Enable NAT Port Mapping Protocol.”
Click “Configure Port Mappings…” Button
This takes you to:
Airport Utility > Hayes Express > Advanced
You do not need to select anything from the drop down menu “Choose a service”
Click in the plus symbol to add
Enter, as Follows:
Public UDP Port(s): 88
Public TCP Port(s): 3074
Private IP Address: 10.0.1.235
Private UDP Port(s): 88
Private TCP Ports(s): 3074

Setting up the ports to be forwarded should work, but never seemed to when I did it. I never even got to the result of "strict NAT"--I just got failures in the XBox 360's network tests. I can't explain why this is, but my XBox 360 works properly when I just put it into the DMZ. If you are continuing to have problems with your current setup, that is what I would advise you to do--put the XBox's IP address into the DMZ in your router's setup page, and don't worry about port forwarding.

Trevor
trevor is offline   Reply With Quote
Old 12-24-2008, 04:08 PM   #10
RMH1960
Prospect
 
Join Date: Dec 2008
Posts: 3
Thanks Trevor.

I am happy to give up on the Port Forwarding scenario, in favor of the DMZ. However, I have not found any clear instructions on the setting for either the XBOX 360 or an Airport Express (Airport Utility 5.3.2 in Max OS 10.5.6).

Can you help me with that?

Best,
Rocky
RMH1960 is offline   Reply With Quote
Old 12-24-2008, 08:57 PM   #11
tlarkin
League Commissioner
 
Join Date: Mar 2003
Location: Bay Area, CA
Posts: 11,351
I agree with Trevor. For my xbox 360 I have static DHCP running and assigned it a static IP and then put it in DMZ. I have no connection worries at all and all the rest of my systems are still behind NAT.
__________________
sudo make me a sammich

http://www.tlarkin.com

"It just told me what I already knew, that I'm a great and amazing guy, didn't I tell you baby, I'm Zaphod Beeblebrox."
tlarkin is offline   Reply With Quote
Old 12-25-2008, 11:01 AM   #12
RMH1960
Prospect
 
Join Date: Dec 2008
Posts: 3
I guess I've made it obvious that I am learning as I go. But this morning I have successfully configured my home wireless network to fully accommodate XBOX Live in an OPEN NAT environment!

How? By discovering that my modem is also a router, and port mapping a static IP for the XBOX 360 within it. Turns out my Airport Express was never the problem - and should have been set up as a bridge from the beginning!

If it weren't for the exhilaration of my success, I'd feel pretty stupid on this fine Christmas morning! Thanks, everyone for your input with my issue...

Happy Holidays,
Rocky
RMH1960 is offline   Reply With Quote
Old 02-24-2009, 02:12 PM   #13
macdsj1
Registered User
 
Join Date: Feb 2009
Posts: 1
Okay I've tried everything in this, but none of it worked. When I went into my Airport utility, it said that there was a "double NAT" on the router... I THINK that means that the DSL modem the router's plugged into has a NAT or something... If so, a double NAT would probably accout for why Xbox keeps saying my NAT is set to "strict."

Anyway, I tried the port-forwarding thing, didn't help at all. I tried setting the router to bridge mode, but then it stopped distributing IP addresses so NOTHING could connect to the internet. I tried setting it to only use DHCP and not NAT, but I didn't really know what I was doing with that, and while I could get my computers to connect to the router that way, they couldn't get to the internet, so again... didn't work.

I looked in the settings page for the modem, but couldn't find anything in there that looked like it was talking about NAT settings or whatever...

Anyway, I'm completely clueless, and my Xbox BARELY connects to MP games... I can't get any matchmaking games, usually, and when I connect to people I know, my connection sucks.

This was not always the case... before I moved my Xbox upstairs, I always got the "Strict NAT" message, but it never affected gameplay or anything... since moving it upstairs though it sucks. It's not really any farther away from the router than before, just has to go through a floor instead of a wall, and I still have a perfectly fine connection to the router (3/4 bars, same as before), but multiplayer games are really problematic.

Can anyone help me? Preferably either in like, step-by-step instructions, because I don't have a clue how to do anything like putting the Xbox in a DMZ or whatever.
macdsj1 is offline   Reply With Quote
Old 08-08-2009, 10:53 PM   #14
silly panda
Registered User
 
Join Date: Aug 2009
Posts: 1
Hey,

After having this problem seemingly forever, I saw Rocky's post and I got it fixed. Just make sure your Airport is still in bridge mode and go into your modem page. For mine (I have a Motorola from Bellsouth), I found that under "Local Network" the side menu "Advanced" brings up a new side menu with "UPnP" in it. Make sure that its enabled and let your modem reset and it should work. If its not that type of router, just look around I guess.

The weird thing is that when I was using a Linksys I didn't have the problem. This obviously pointed to the Airport, but I guess since the Linksys was an Xbox Certified one, it accounted for the modem being incorrectly set and worked anyway, while the Airport didn't.

So in conclusion, its your modem, not the Airport. Fix it in there.
silly panda is offline   Reply With Quote
Old 01-14-2010, 12:19 PM   #15
TL1969
Guest
 
Posts: n/a
Rmh1960

in regards to your open nat setup for the xbox on the airport it works great, i am posed with another challenge and maybe you can help? Your setup works for directly connecting the xbox with cat5 (wired) to my airport express. However, I am trying to avoid running another 25 feet of cat5 cable across two rooms. My current set up has one more link in the chain. I have the router directly connected to my mac pro tower, osx leopard intel. As you may know this unit has 2 ethernet ports in the back. I am sharing the internet off the first port and the second port and have the xbox network connection plugged into that port which is less than 3 feet from it. However, with this setup I can only get NAT Moderate on the Xbox. I know there is a solution but cant quite put my finger on it and it must have to do with IP address assignment, can you help Thanks TL
  Reply With Quote
Old 05-20-2010, 04:12 PM   #16
dukemeiser
Prospect
 
Join Date: May 2010
Posts: 1
I don't think anyone answered this post very well (RMH1960 found the solution but didn't explain it) so I will try.

These instructions are for Xbox 360 with an Airport Express. Open Airport Utility. Select "Manual Setup". Select "Internet" at the top of the window. On the "Internet Connection" tab go to the "Connection Sharing" menu and select "Off (Bridge Mode)". Your internet modem is now being used as the router instead of the Airport.

Airport Express Open NAT settings.
dukemeiser is offline   Reply With Quote
Old 05-20-2010, 10:12 PM   #17
cjuice
Prospect
 
Join Date: May 2010
Posts: 1
Quote:
Originally Posted by dukemeiser
I don't think anyone answered this post very well (RMH1960 found the solution but didn't explain it) so I will try.

These instructions are for Xbox 360 with an Airport Express. Open Airport Utility. Select "Manual Setup". Select "Internet" at the top of the window. On the "Internet Connection" tab go to the "Connection Sharing" menu and select "Off (Bridge Mode)". Your internet modem is now being used as the router instead of the Airport.

Airport Express Open NAT settings.

Thank you for putting in terms an idiot can understand.

I have followed these steps and although my internet still works on my laptop, the Xbox cannot connect now due to error:

"Can't obtain an IP address from your router or modem"

Anyone know where to go from here or run into a similar problem?

Thanks!
cjuice is offline   Reply With Quote
Old 05-21-2010, 11:56 AM   #18
trevor
Moderator
 
Join Date: Jun 2003
Location: Boulder, CO USA
Posts: 19,815
Quote:
Originally Posted by cjuice
I have followed these steps and although my internet still works on my laptop, the Xbox cannot connect now due to error:

"Can't obtain an IP address from your router or modem"

You can have one (exactly one, not less and not more) DHCP server on your network. Your Airport Base Station can act as a DHCP server, or you may have other devices available that can also act as a DHCP server. DHCP servers hand out IP addresses automatically, so you don't have to set them manually.

OR, you can set your XBox 360 to have a static IP address, that you set manually. Make sure to set it in the same subnet as your computers.

So for example, if your Airport Base Station has IP address 192.168.2.1 and your computer has IP address 192.168.2.2, then you can give your XBox 360 the static IP address of 192.168.2.3. Notice that the first three numbers (known as octets) are the same: 192, 168, and 2. But the last number (octet) varies between the devices: 1 for the Base Station, 2 for the computer, 3 for the XBox. You cannot have any cases where all the numbers are the same on the same network, but you should have cases where only the last number differs, like in the example.

Having only the last number different is (in simple cases like a home network, and with the caveat that this is a simplified explanation) basically the same as all devices being on the same subnet.


Trevor

Last edited by trevor; 05-21-2010 at 12:02 PM.
trevor is offline   Reply With Quote
Old 11-17-2010, 12:42 AM   #19
yeshell70
Guest
 
Posts: n/a
Still doesn't work

So, I set my network to bridge, and now my internet works on my laptop but not my xbox. I cant even connect. Apparently my DNS settings are wrong, but i have them manually set up so that my xbox can connect to the internet through my computer. How can I fix this?
  Reply With Quote
Old 01-15-2011, 05:50 AM   #20
mikeoh
Guest
 
Posts: n/a
NAT Open!

Hey guys !

Registered on this forum just to confirm my solution for this problem. My little brother has been complaining for ages about our wireless Airport Extreme being set to NAT type Strict on his new XBOX 360. Tried every solution at this forum but what simply helped was turning Bridge Mode to Off. What I did was:

Follow the excellent instructions from dukemeiser:

These instructions are for Xbox 360 with an Airport Express. Open Airport Utility. Select "Manual Setup". Select "Internet" at the top of the window. On the "Internet Connection" tab go to the "Connection Sharing" menu and select "Off (Bridge Mode)". Your internet modem is now being used as the router instead of the Airport.

Then:
- Reset to Factory default XBOX Network settings.
- Setup your wireless network connection like normal.

After testing the network connection I achieved an Open NAT type and all our computers at home connected to the Wireless also receive IPs and can connect to the internet, just leave these configurations at default also.

Thanks alot guys! Finally my little brother is off my back about this!
  Reply With Quote
Reply

Tags
360, airport, express, nat, xbox

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.