Go Back   The macosxhints Forums > OS X Help Requests > Networking



Reply
 
Thread Tools Rating: Thread Rating: 4 votes, 5.00 average. Display Modes
Old 06-06-2008, 09:24 AM   #1
pwaring
Prospect
 
Join Date: Jun 2008
Posts: 4
Can't ping additional IP on the same interface

I'm having a very odd problem whereby I've got a network interface on my Intel Mac Mini (running 10.4.11) which has two IP addresses assigned to it - one as the 'main' IP and a second for an additional instance of Apache to bind to. This has worked fine for some time, but after a recent reboot (following a Safari update and swapping around some devices connected by Firewire) I've now found that I can't access the second IP address from the Mac Mini itself, yet I have no problems connecting to it from other machines. The second IP address is definitely bound to the right interface (and if it wasn't setup correctly, external machines wouldn't have much luck reaching it) and was working fine beforehand.

Ping (run on the Mac Mini) gives me:
Code:
ping -c 4 130.88.198.52
PING 130.88.198.52 (130.88.198.52): 56 data bytes
ping: sendto: Host is down
ping: sendto: Host is down
ping: sendto: Host is down
ping: sendto: Host is down
ifconfig en0 produces:
Code:
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        inet6 fe80::216:cbff:fea8:49f8%en0 prefixlen 64 scopeid 0x4 
        inet 130.88.199.74 netmask 0xffff0000 broadcast 130.88.255.255
        inet 130.88.198.52 netmask 0xffff0000 broadcast 130.88.255.255
        inet6 2002:8258:c3b0:9:216:cbff:fea8:49f8 prefixlen 64 autoconf 
        ether 00:16:cb:a8:49:f8 
        media: autoselect (100baseTX <full-duplex>) status: active
        supported media: autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 10baseT/UTP <full-duplex,flow-control> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 100baseTX <full-duplex,flow-control> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control> none
Does anyone have any ideas as to what I could try in order to fix this problem? I can't think why it would stop working after a Safari update/Firewire devices being swapped, or why external machines can connect fine but the Mac Mini effectively can't see the second IP address.

Thanks in advance.
pwaring is offline   Reply With Quote
Old 06-06-2008, 09:36 AM   #2
cwtnospam
League Commissioner
 
Join Date: Jan 2005
Posts: 8,475
Is your firewall on, and if so, is stealth mode enabled? Click on the Advanced button in the Firewall tab of the Sharing Preference pane.
cwtnospam is offline   Reply With Quote
Old 06-06-2008, 09:41 AM   #3
pwaring
Prospect
 
Join Date: Jun 2008
Posts: 4
We have a separate firewall (Flying Buttress) which has rules to allow traffic to that interface (it allows from 'any', which I presume would include local). The rules also haven't changed since well before the Safari update.
pwaring is offline   Reply With Quote
Old 06-06-2008, 10:00 AM   #4
cwtnospam
League Commissioner
 
Join Date: Jan 2005
Posts: 8,475
Try turning it off, and check the built-in firewall too. Does work with them both off?
cwtnospam is offline   Reply With Quote
Old 06-06-2008, 10:21 AM   #5
pwaring
Prospect
 
Join Date: Jun 2008
Posts: 4
Turning off the firewall makes no difference, and the built-in one is off anyway.
pwaring is offline   Reply With Quote
Old 06-06-2008, 01:17 PM   #6
cody121
Prospect
 
Join Date: Sep 2004
Posts: 2
possible netmask

Here is what the ifconfig looks like off of a freebsd server I run. Notice the netmask is 255.255.255.255 for additional IP addresses in the same network. I don't know if that will fix your problem here, but it is worth a try.

em1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=1b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
inet 10.214.42.66 netmask 0xffffff00 broadcast 10.214.42.255
inet 10.214.42.62 netmask 0xffffffff broadcast 10.214.42.62
inet 10.214.42.63 netmask 0xffffffff broadcast 10.214.42.63
inet 10.214.42.35 netmask 0xffffffff broadcast 10.214.42.35
inet 192.168.144.5 netmask 0xffffff00 broadcast 192.168.144.127
inet 192.168.144.30 netmask 0xffffffff broadcast 192.168.144.30
inet 192.168.144.35 netmask 0xffffffff broadcast 192.168.144.35
ether 00:30:48:29:12:13
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active

Also, do a man ifconfig, and read next to alias.
cody121 is offline   Reply With Quote
Old 06-09-2008, 04:51 AM   #7
pwaring
Prospect
 
Join Date: Jun 2008
Posts: 4
Changing the netmask to 0xffffffff worked, thanks for the suggestion. Not sure why it worked before with a netmask of 0xffff0000, but I don't care so long as it's fixed.
pwaring is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.