Go Back   The macosxhints Forums > OS X Help Requests > Applications



Reply
 
Thread Tools Rating: Thread Rating: 23 votes, 5.00 average. Display Modes
Old 11-17-2007, 11:46 AM   #1
Gordon Werner
Prospect
 
Join Date: Mar 2002
Location: Seattle, WA
Posts: 19
How to make Preview the default PDF viewer for Safari?

Good morning.

I am using Leopard and recently installed Adobe CS3 on my Mac.

In the process, it added Adobe Acrobat and now whenever I click on a link to a PDF it tries to load the PDF in Acrobat and not Preview (like it used to).

Can anyone tell me how I can change it so that it uses Preview again?

thanks

Gordon
__________________
G<W
There exists, but you can't get there from here.

Last edited by Gordon Werner; 11-17-2007 at 11:50 AM.
Gordon Werner is offline   Reply With Quote
Old 11-17-2007, 12:36 PM   #2
solipsism
MVP
 
Join Date: Nov 2005
Posts: 1,963
Locate a PDF and from the Finder Menu Bar choose File => Get Info. Then change the Open With info to use Preview and then click the Change All button.
solipsism is offline   Reply With Quote
Old 11-17-2007, 06:59 PM   #3
Gordon Werner
Prospect
 
Join Date: Mar 2002
Location: Seattle, WA
Posts: 19
no ... that is how you force the OS to open PDFs when you click on them ... I am talking about ones online.

The ones on my computer are already set to open in Preview ... but the online ones try opening in Acrobat
__________________
G<W
There exists, but you can't get there from here.
Gordon Werner is offline   Reply With Quote
Old 11-17-2007, 07:08 PM   #4
chabig
Hall of Famer
 
Join Date: Jan 2002
Posts: 3,014
Launch Adobe Reader 8, then open the Preferences. Select the Internet category...the top option is the one you want. Uncheck the box to make sure Adobe doesn't keep making itself the default reader.

You might also need to open /Library/Internet Plug-Ins and delete Adobe's PDF viewer plug-in.

Chris

Last edited by chabig; 11-17-2007 at 07:10 PM.
chabig is offline   Reply With Quote
Old 04-07-2009, 11:41 AM   #5
fazzig
Registered User
 
Join Date: Apr 2009
Posts: 1
Yes, deleting the plug-in works. Thank you!
fazzig is offline   Reply With Quote
Old 01-14-2013, 10:20 AM   #6
robleach
Prospect
 
Join Date: Feb 2003
Posts: 32
The adobe preference is grayed out for me.
robleach is offline   Reply With Quote
Old 01-14-2013, 11:41 AM   #7
benwiggy
League Commissioner
 
Join Date: Aug 2006
Location: London
Posts: 5,768
As ever, the way to stop Adobe from handling PDFs in the browser is to delete the Adobe PDF plug-in in /Library/Internet Plug-ins.

It is called "AdobePDF.plug-in", or something similarly obvious. (I've also deleted it!)

There's generally not much point in using Adobe's Reader in preference to Preview. Possibly it handles forms better, I'm not sure. But Preview is faster, displays PDFs better and is more secure. Adobe's own preference is permanently greyed out, and is claimed to be a bug.

You may also need to type/copy the following command into the Terminal, to set Safari's preference for handling PDFs itself:

defaults write com.apple.Safari WebKitOmitPDFSupport -bool false
benwiggy is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.