Go Back   The macosxhints Forums > OS X Help Requests > OS X Server



Reply
 
Thread Tools Rating: Thread Rating: 6 votes, 5.00 average. Display Modes
Old 02-06-2002, 03:46 AM   #1
Dogcow
Triple-A Player
 
Join Date: Jan 2002
Posts: 131
Sluggish FTP and SSH

FTP and SSH take a while to respond when connecting. FTP takes a long time before responding at all, while ssh takes a long time to process user passwords. What would make this so slow? Any suggestions on speeding them up?

Thanks
Dogcow is offline   Reply With Quote
Old 08-17-2004, 04:26 PM   #2
rudy_venice
Prospect
 
Join Date: Jul 2004
Posts: 4
Quote:
Originally Posted by Dogcow
FTP and SSH take a while to respond when connecting. FTP takes a long time before responding at all, while ssh takes a long time to process user passwords. What would make this so slow? Any suggestions on speeding them up?

Thanks

I had the same problem here with a 733mhz single cpu G4 with 1 gb RAM. I upgraded the processor and added some RAM and it improved a huge amount. We use ours for ftp, webserver and mailserver so it was busy. I'd be interested in what you find is the problem in the end.
__________________
The Digital Lab
Venice California
rudy_venice is offline   Reply With Quote
Old 08-17-2004, 04:35 PM   #3
yellow
Moderator
 
Join Date: Jan 2002
Posts: 10,677
Quote:
Originally Posted by Dogcow
FTP and SSH take a while to respond when connecting.

Outbound or inbound? Mac specs? OS version?
yellow is offline   Reply With Quote
Old 03-01-2005, 01:10 PM   #4
ceph
Prospect
 
Join Date: Mar 2005
Posts: 7
Quote:
Originally Posted by yellow
Outbound or inbound? Mac specs? OS version?

i have the same problem with a 1.8ghz imac, 768 mb ram, brand new machine.
i use a router/firewall, software firewall and NIDS, but have disabled all of it and it hasn't helped.

all inbound to the computer ssh and ftp is running on. ftp is ridiculously slow, half the time the connection dies, and ssh gives me a login prompt quickly, but takes a very long time (a couple of minutes at least) to prompt for the password.

i hope someone can help figure this problem out because it makes remote access to my machine unbearable. =/

-- the only difference is that i'm actually using Mac OS X, not Server.

Last edited by ceph; 03-01-2005 at 01:13 PM.
ceph is offline   Reply With Quote
Old 03-01-2005, 01:33 PM   #5
hayne
Site Admin
 
Join Date: Jan 2002
Location: Montreal
Posts: 32,463
Look for a post on these forums not so long ago about slow ssh connections. If I recall correctly, the solution there was to disable IPV6 since the slowness was caused by failing IPV6 reverse name lookups or something.
hayne is offline   Reply With Quote
Old 03-01-2005, 01:53 PM   #6
ceph
Prospect
 
Join Date: Mar 2005
Posts: 7
ok, i'll try that, thanks.

apologies for the cross post. i was just trying to keep to the topic. =)
ceph is offline   Reply With Quote
Old 03-01-2005, 02:10 PM   #7
ceph
Prospect
 
Join Date: Mar 2005
Posts: 7
well, for one i'm not running bind. i've disabled all IPV6

(ceph@cephnet:~) $ ip6config stop-v6 all
Stopping IPv6 on all interfaces.
ip6: error detaching en0
ip6: error detaching fw0

tried as sudo, still get those last two errors, and nothing changes in regards to ssh and ftp time.

do the en0 and fw0 interfaces need to be inactive for it to work?

thanks.
ceph is offline   Reply With Quote
Old 03-01-2005, 02:52 PM   #8
hayne
Site Admin
 
Join Date: Jan 2002
Location: Montreal
Posts: 32,463
Use the Network preferences GUI for disabling IPv6 - via the "Configure IPv6" button under the TCP/IP pane.
hayne is offline   Reply With Quote
Old 03-02-2005, 08:10 AM   #9
ceph
Prospect
 
Join Date: Mar 2005
Posts: 7
i used the preference panel to turn off IPv6, and it looks like it drastically reduced the time it takes for ftp or ssh to respond. It's not 100% though, as it still takes about 15 seconds for ftp to kick through (could be anything though, likely the router), but it's a whole lot better than it was.

thanks again for the help.
ceph is offline   Reply With Quote
Old 03-02-2005, 10:21 PM   #10
voldenuit
League Commissioner
 
Join Date: Sep 2003
Location: Old Europe
Posts: 5,146
For the 15 seconds issue this recent hint should help:

http://www.macosxhints.com/article.p...18462#comments
voldenuit is offline   Reply With Quote
Old 03-04-2005, 07:52 AM   #11
ceph
Prospect
 
Join Date: Mar 2005
Posts: 7
Quote:
Originally Posted by voldenuit
For the 15 seconds issue this recent hint should help:

http://www.macosxhints.com/article.p...18462#comments

thanks.. i'm just not sure bellsouth cares or will do anything about this. (i get the NXDOMAIN deal, so ssh will still be a little slow unless i can find a way to fix that too.)

i appreciate the help
ceph is offline   Reply With Quote
Old 03-04-2005, 08:29 AM   #12
KRaven0825
Triple-A Player
 
Join Date: Feb 2005
Location: Mass.
Posts: 100
Just something I noticed with my ftp and ssh from outside my network. First if you are trying to ftp or ssh into a machine that is on an airport connection make sure interference robustness is off, it might be coincidence but it cut my wait time in half....I have virtually no delay in ftp, telnet, or ssh, and my laptop is running on a airport express that is boosting my signal from my airport extreme that is across the house.

Another thing if it is your internet provider....try changing the MTU with your ifconfig for en0 or en1(depending if you are using wireless or not)....i know DSL is picky about the MTU being 1492 (i believe) for optimum performance....my MTU is 1500 but I am on T1, so it may vary...also this MTU defaults back to 1500 with a reboot, so if you change it it will change back.
The command is below to change it.

As root:
ifconfig en1 mtu 1492

you can change that number to whatever, but i am no expert, i just read this off of other boards a while back and remembered it.
KRaven0825 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.