Go Back   The macosxhints Forums > OS X Help Requests > Hardware and Peripherals



Reply
 
Thread Tools Rate Thread Display Modes
Old 08-30-2005, 04:23 PM   #1
superstroh
Registered User
 
Join Date: Jul 2005
Posts: 1
Help? keyboard 10-key number keys don't work

Hi All - I hope someone can help me as I've been experimenting with fixes for a while. I'm on X.4 and have been having a problem for many months with 10-key. The only keys that don't work are the number keys on my 10-key area. The =,/,*,-,+,clear and enter all work fine. For a while, holding the alt key down while pressing the numbers worked but that has stopped working. I know all about the num-lock and even when enabled, they still don't work. Using keyboard viewer shows that it's recognizing that the keys are being pressed so I've stopped investigating the keyboard settings. The only other clue is that my almost 2 yr. old boy had a few moments with it and pressed random keys - I thought at first maybe he damaged the keyboard but when I tried a new keyboard, it still didn't register the number keys. Maybe he accidentally changed some setting somehwere? If anyone can help me fix this I will be eternally grateful! Not having 10-key is a real drag! Thanks in advance! : )
superstroh is offline   Reply With Quote
Old 08-30-2005, 04:49 PM   #2
hayne
Site Admin
 
Join Date: Jan 2002
Location: Montreal
Posts: 32,459
1) Check the keyboard preferences

2) Does it work if you log in as a different user?
hayne is online now   Reply With Quote
Old 08-30-2005, 05:00 PM   #3
bramley
MVP
 
Join Date: Apr 2004
Location: Cumbria, UK
Posts: 2,461
Could he have activated the mouse keys?

System Preferences -> Universal Access -> Mouse. Make sure the mouse keys radio button is set to 'Off' and the checkbox 'Press the option key 5 ... blah blah' is unchecked.

You can toggle the mouse keys by pressing Option 5 times - maybe that's what the young-timer did.
bramley is offline   Reply With Quote
Old 08-29-2007, 10:56 AM   #4
janesk
Registered User
 
Join Date: Aug 2007
Posts: 1
Quote:
Originally Posted by superstroh
Hi All - I hope someone can help me as I've been experimenting with fixes for a while. I'm on X.4 and have been having a problem for many months with 10-key. The only keys that don't work are the number keys on my 10-key area. The =,/,*,-,+,clear and enter all work fine. For a while, holding the alt key down while pressing the numbers worked but that has stopped working. I know all about the num-lock and even when enabled, they still don't work. Using keyboard viewer shows that it's recognizing that the keys are being pressed so I've stopped investigating the keyboard settings. The only other clue is that my almost 2 yr. old boy had a few moments with it and pressed random keys - I thought at first maybe he damaged the keyboard but when I tried a new keyboard, it still didn't register the number keys. Maybe he accidentally changed some setting somehwere? If anyone can help me fix this I will be eternally grateful! Not having 10-key is a real drag! Thanks in advance! : )

Were you ever able to resolve this issue? I have run into the same problem and can't seem to figure out the instructions that were given to you.

Thanks.
janesk is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.