Go Back   The macosxhints Forums > OS X Help Requests > Networking



Reply
 
Thread Tools Rating: Thread Rating: 161 votes, 4.98 average. Display Modes
Old 06-07-2004, 03:30 PM   #1
Sundance
Prospect
 
Join Date: May 2004
Posts: 11
Unhappy Airport problem: self assigned IP address?

I'm using DSL, I've had it for about 4 weeks. For the past week or so I've been having a problem connecting to the internet wirelessly through airport after the computer goes to sleep and is rewoken(rewaken?). I get this message when i go to see the network status in the system preferences:

"Airport is connected to the network Sundance. Airport has a self assigned IP address and may not be able to connect to the internet."

For the first three weeks i NEVER had this problem, and now it shows at least once a day. I figure i might have changed something in my network preferences but i don't know what. I don't really know what dhcp or ipv6 or ipv4 is but it is set to "using dhcp" under the tcp/icp menu in the configure ipv4 section and configure ipv6 is off.

sometimes if i turn airport off for a few minutes and then on again the internet will work, sometimes if i don't turn it off it will work after a few minutes...???



any help would be great!!

Sundance is offline   Reply With Quote
Old 06-07-2004, 03:33 PM   #2
yellow
Moderator
 
Join Date: Jan 2002
Posts: 10,677
Did you turn on the firewall on your laptop (whatever is using an airport card)?
Do you have automatic reconnect set up in your Network Prefpane (Airport tab)? ["By default, join: Automatic"]
yellow is offline   Reply With Quote
Old 06-07-2004, 05:37 PM   #3
Sundance
Prospect
 
Join Date: May 2004
Posts: 11
my firewall is on, but its been on for the past 4 weeks. also it is set to join automatic.
Sundance is offline   Reply With Quote
Old 06-07-2004, 05:44 PM   #4
yellow
Moderator
 
Join Date: Jan 2002
Posts: 10,677
Try tuning the firewall off and putting it to sleep and waking it up. Just to see if it still self-assigns the IP.
yellow is offline   Reply With Quote
Old 07-14-2004, 09:05 AM   #5
mikerussell
Prospect
 
Join Date: Jul 2004
Location: London
Posts: 3
firewall?

Quote:
Originally Posted by yellow
Try tuning the firewall off and putting it to sleep and waking it up. Just to see if it still self-assigns the IP.

I'm having the same problem as Sundance - although I can connect at home, I can't connect at work. I'm on a Powerbook 15" that came with built in airport extreme. I can see the signal in my airport toolbar, it says I'm connected but browers can't find any websites.

How do you turn the firewall off?

Mike Russell
mikerussell is offline   Reply With Quote
Old 07-14-2004, 09:23 AM   #6
yellow
Moderator
 
Join Date: Jan 2002
Posts: 10,677
Well, it may be that you are connected, but you cannot get to any websites because you don't have a DNS server responding. Get your airport connection at work and try connection to this address in your web browser:

http://216.109.118.75/

If it works, the problem is DNS.

To make sure the firewall is off, open the Terminal and type this in:

sudo ipfw l

(That is a lowercase L after ipfw) If it returns anything except "65535 allow ip from any to any", then the built-in firewall is running. Turn it off via the Firewall tab in the Sharing prefpane, or by typing into the Terminal:

sudo ipfw -q flush

This does not account for any 3rd party firewalls apps that use 3rd party firewalls, suck as FirewalkX and NetBarrierX. You'll have to look at your documentation to find out how to turn those off, assuming you're running one.
yellow is offline   Reply With Quote
Old 07-14-2004, 09:37 AM   #7
Craig R. Arko
Site Admin
 
Join Date: Dec 2001
Location: Minneapolis, MN
Posts: 3,985
If you get a 'self-assigned' IP address, of the form 169.254.xxx.xxx this means you are not successfully negotiating with the DHCP server to get an address.

This can be for a wide variety of reasons, but the first thing to try is restarting the DHCP server (in this case, the basestation). Another possibility is to check the security settings, and make sure they match exactly.

Also, none of you say what kind of basestation you have. Non-Apple access points can be a little tricky, mostly because of terminology differences and poor configuration interfaces and documentation, often web browser based.
Craig R. Arko is offline   Reply With Quote
Old 07-15-2004, 07:29 AM   #8
mikerussell
Prospect
 
Join Date: Jul 2004
Location: London
Posts: 3
Yes I am getting this 'self assigned' message but in an interesting twist of fate it turns out that the wireless base station here isn't running at present and I'm inadvertently trying to connect to some remote bozo nearby. (It was him popping up in my airport menu that started me off on the wrong track).
There's no WEP password or anything required, but it'd seem a bit cheeky to hunt him down and ask him to restart his basestation :-)
mikerussell is offline   Reply With Quote
Old 09-29-2004, 01:42 AM   #9
everett3
Prospect
 
Join Date: Sep 2004
Posts: 2
Exclamation

i have a similar issue, but it's kinda weird.
I have a g4 powerbook 1.33ghz 256MB RAM 60GBHD, OS 10.3.5
i had the computer for about 2 months before it started losing the connection after going to sleep. at first it was maybe once a week, then it got to like every couple days until it became every single time. I tried instead logging into another account and no problem. but if i sign into my primary account at all, even if i log out of it it will happen 100% of the time. i have no access to any "airport" 802.11 routers but my girlfriend has another g4 (only differences being her processor is clocked at 1.0ghz and she hasn't upgraded to 10.3.5, i think she has 10.2.x or something) and it's never done it in the 10 months she's owned it. it's a real pain in the ass to switch over to my other account when the thing i'm trying to do requires it, knowing i'll need to reboot if i want to use the internet.
everett3 is offline   Reply With Quote
Old 10-01-2004, 08:51 PM   #10
torifile
Prospect
 
Join Date: Jan 2002
Posts: 17
I've got the same problem and I know it's not a firewall issue or a DNS issue. The problem is that my airport basestation (snow version) isn't giving out IP addresses. It happens to all 4 of my computers connected to the ABS. The only way to remedy it is to unplug and replug the BS. Any ideas?
torifile is offline   Reply With Quote
Old 10-01-2004, 09:32 PM   #11
yellow
Moderator
 
Join Date: Jan 2002
Posts: 10,677
ABS hard reset? ABS firmware update?
yellow is offline   Reply With Quote
Old 10-01-2004, 09:41 PM   #12
torifile
Prospect
 
Join Date: Jan 2002
Posts: 17
Quote:
Originally Posted by yellow
ABS hard reset? ABS firmware update?

ABS firmware is 4.0.8 - the latest as far as I know.

The thing is, nothing's changed with my setup in the past few weeks. I've read reports around of others having a similar problem just recently. Odd to say the least....
torifile is offline   Reply With Quote
Old 10-02-2004, 04:35 PM   #13
Nic
Prospect
 
Join Date: Jul 2003
Posts: 18
Posted this over at Apple. Perhaps it will help. Still working for me.

Here's what I had on my 12" PB, and here's how I solved it.

Despite good signal strength, I would find that turning the Airport card off and then on, or sleeping and then waking up, would drop the connection. Upon reconnection, I would be 'connected to the network' but I would have a self-assigned IP. Nothing short of restarting the machine would allow a DHCP lease supplied IP.

How I solved it:

1) Shut down the laptop.
2) Remove battery.
3) Remove airport card.
4) Reinstall battery.
5) Start up the machine.
6) Log in as root. (You could also log in as any admin, but you will have to authenticate.)
7) Delete your com.apple.airport.preferences.plist found in /Library/Preferences/SystemConfiguration/
8) Use Onyx (or similar) to delete all caches, system caches, virtual ram caches etc.
9) Shut down the machine.
10) Remove battery.
11) Reinstall airport card, making sure it is seated properly.
12) Reinstall battery.

I can now toggle the Airport card off and on, or sleep and wake, and the Airport card will renegotiate an IP with the Airport Extreme base station without problems.

Hope this helps.
Nic is offline   Reply With Quote
Old 10-02-2004, 07:27 PM   #14
kfaulhaber
Major Leaguer
 
Join Date: Dec 2002
Posts: 291
Step 7 makes sense. The rest don't. Glad it worked, though.
kfaulhaber is offline   Reply With Quote
Old 10-07-2004, 11:05 AM   #15
mbcurtin
Prospect
 
Join Date: Oct 2004
Posts: 1
self-assigning ip addresses -- same problem?

i have the same problem where i can connect at work, no problem, but at home i can't. i have an iBook 12" and i would like to try step 7, only i can't find the com.apple.wirelesspref. or whatever it's called. i go to the library and preferences menu and there are lots of other com.apple.whatever files, but none about wireless preferences. also, i don't know what onyx and am not sure exactly which caches to clear or how. i would appreciate any input, sorry if i seem really ignorant to all of this but i just started using wireless ...

it would probably be useful to add that it is a shared apt i live in, and i'm using the base station of one of my flatmates. it's NOT mine and i don't know if it's apple ... plus, i'd rather not ask him to restart his basestation every time i want to use the internet ... if there was a another solution, i'd really prefer it.

also, thank you for having this forum; it's helpful just knowing it exists and that there are people who can help. i'm out of the country and don't have access to 800 numbers in the states, so this is the best way to troubleshoot. thanks for making it possible.
mbcurtin is offline   Reply With Quote
Old 10-07-2004, 01:48 PM   #16
dagnew
Prospect
 
Join Date: Sep 2004
Location: Cape Cod
Posts: 2
Thanks, Nic for your suggestion.

I haven't had a chance to try it, but I will (on 25 iBooks!). Reading this thread supports the idea that it's something on the wireless client (I'd been thinking it was the config of my roaming network) because I see many people having the self-assigned IP issue (while connected to a strong wireless signal) with very different network setups.

I've been going nuts with this problem (self-assigned IP) for weeks despite numerous calls to Apple, latest OS, updates, Extreme hdw, reading web articles 'til I'm crosseyed, etc, etc. For the long story, see my post at http://discussions.info.apple.com/we...Cv.0@.689c75c6
dagnew is offline   Reply With Quote
Old 10-12-2004, 09:37 AM   #17
dagnew
Prospect
 
Join Date: Sep 2004
Location: Cape Cod
Posts: 2
Just wondering why Nic felt it necessary to do all the other steps... anyone have any experience with trying step 7 only?

(I did an initial test on 2 identical iBooks which were both self-assigning IPs in presence of AEBS: I trashed /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist on one, then restarted both. Both machines then connected to the AEBS. Inconclusive.)
dagnew is offline   Reply With Quote
Old 10-13-2004, 07:19 AM   #18
Nic
Prospect
 
Join Date: Jul 2003
Posts: 18
Hi

The main reason I opted for the other steps was because merely deleting the preference file alone didn't do anything for me. My reasoning was that flushing the various caches and PRAM with the card removed would force the system to rebuild those caches cleanly, before reinstalling the card. Doing this as root often configures those changes at the base level. (If anyone remembers the constantly reappearing US keyboard layout issue in non-US keyboard systems, setting the options as root made them 'stick'.)

mbcurtin, you must look in the root library prefences (/Library/Preferences/SystemConfiguration/), not your user preferences directory (~/Library/Preferences/) for the file.

For the record, folks, my self-assigning IP issue is better but not completely reliable. Most of the time things work well. Toggling the airport card off and on will not drop the connection. Sleeping the machine and then waking it will usually result in a connection starting up again, but once in a while it will fail. Occasionally upon waking, the IP will be correctly assigned but there will be no transfer to the base station and I will have to restart.

What's the bash command for clearing the DNS cache? I seem to recall that did the trick upon waking. It might be useful to trigger a shell script to flush the DNS on wake.
Nic is offline   Reply With Quote
Old 10-13-2004, 07:32 AM   #19
Nic
Prospect
 
Join Date: Jul 2003
Posts: 18
David, I just read your message on the Apple discussions boards.

R.E. setting the base station channels, I would personally set them manually. As far as I understand it, 'Auto' will seek a channel with the least interference. Attempting this with my three base stations caused problems (intereference between the base stations and disappearing base stations.) I have had no problems with them all set to the same channel.
Nic is offline   Reply With Quote
Old 11-08-2004, 09:21 AM   #20
ekivemark
Prospect
 
Join Date: Nov 2004
Location: Reston, VA
Posts: 17
Self Assigned IP

"For the record, folks, my self-assigning IP issue is better but not completely reliable. Most of the time things work well. Toggling the airport card off and on will not drop the connection. Sleeping the machine and then waking it will usually result in a connection starting up again, but once in a while it will fail. Occasionally upon waking, the IP will be correctly assigned but there will be no transfer to the base station and I will have to restart."

I recently tried the clean up method listed in this thread after this problem had gradually got worse. Since performing the exercise my problem still exists. Almost every time that I wake up my machine. I have even had the situation where the connection comes up and it resets itself and self assigns an IP address. Shutting down airport extreme does nothing to solve the problem.

I am running a 15" PB G4 with Airport Extreme and 10.3.6 (as of this morning), previously 10.3.5. The problem has deteriorated over the course of about 4 weeks. I am using LinkSys 802.11b and 802.11g wireless routers at home and at work.
ekivemark is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.