Go Back   The macosxhints Forums > OS X Help Requests > OS X Server



Reply
 
Thread Tools Rating: Thread Rating: 8 votes, 3.25 average. Display Modes
Old 09-24-2012, 06:58 AM   #1
theloststory
Triple-A Player
 
Join Date: Oct 2005
Posts: 87
MAMP on Mountain Lion

Hello! I am trying to set up MAMP on Mountain Lion for work on some Wordpress themes.


But the servers are not starting. I tried some help from Google search, but it didnt work (resetting Apache ports etc).

I am a non-techie so some help is required. Has anyone found a fix to this? It seems to be a common problem.
theloststory is offline   Reply With Quote
Old 09-24-2012, 09:46 AM   #2
dfass
Prospect
 
Join Date: Aug 2012
Posts: 16
Ok..are you getting any errors?
There are error logs.

I set up MAMP in 10.7 and it still works in 10.8...

Also, are any other Mysqls or Apaches running?
Generally MAMP uses 8888 and 8889..so, that probably isn't an issue, because most standard installations use 80 for apache.
dfass is offline   Reply With Quote
Old 09-25-2012, 12:23 AM   #3
theloststory
Triple-A Player
 
Join Date: Oct 2005
Posts: 87
hi! I wouldnt know how to look for errors in the console etc.
When I launch Mamp, the 'Apache Server' and 'MySql Server' buttons are red. When I click the 'Start Servers' button, I see the dialling progress 'daisy' kinda think but nothing happens. The server buttons are red.

It used to work without a problem for me in 10.7 as well, but I hadnt used it for a long long time.

So I deleted and reinstalled the latest version of Mamp and its still giving me the exact same problem (as mentioned above).

(and yes, my ports are as you mentioned above. I dont understand the port numbers, so I never tinker with them)
theloststory is offline   Reply With Quote
Old 09-25-2012, 04:18 AM   #4
warragul
All Star
 
Join Date: Dec 2002
Location: Melbourne, Australia
Posts: 867
If MAMP isn't playing nice for you maybe XAMPP will do the trick.
XAMPP uses port 80 for http so you'd need OSX's Apache turned off or move XAMPP's http port.
__________________
warragul - The Real World is a Special Case.
warragul is offline   Reply With Quote
Old 09-26-2012, 04:05 AM   #5
theloststory
Triple-A Player
 
Join Date: Oct 2005
Posts: 87
thanks. let me try this.
theloststory is offline   Reply With Quote
Old 09-27-2012, 11:16 AM   #6
theloststory
Triple-A Player
 
Join Date: Oct 2005
Posts: 87
hello! I got myself a new HDD and hence reinstalled everything. MAMP works now. This is 10.8. I hope when I upgrade to 10.8.2, it doesnt break.
theloststory is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.