Go Back   The macosxhints Forums > OS X Help Requests > Applications



Reply
 
Thread Tools Rating: Thread Rating: 3 votes, 5.00 average. Display Modes
Old 07-14-2010, 12:45 PM   #1
Laceys
Prospect
 
Join Date: Jul 2010
Posts: 7
Question Extra quotes appearing when I copy and paste from Numbers '09

I'm having an issue when I copy a cell with text in quotations from Numbers '09 and then paste to online programs such as Google Adwords. When I paste to an online program two extra quotations are added to the front of the word and one extra quotation is added to the end. For example my text will look like this, "example text", in Numbers '09 and then look like this, """example text"", after I've pasted into Google Adwords and other online programs. The only way I have been able to get around this issue is to first paste into the program TextEdit and then copy it again and paste it into Google Adwords. I know this is a Numbers '09 issue since this also happens in an online program I use from Lowermybidprice.com. I hope someone can help with my frustrations...
Laceys is offline   Reply With Quote
Old 07-14-2010, 06:46 PM   #2
macosnoob
MVP
 
Join Date: Jan 2007
Posts: 1,907
I don't use Google Adwords, so I'm guessing based on some other behaviors I've seen.

This is one Numbers cell? If so, try this: In Numbers, select the cell by double-clicking (not single-clicking) it. Then select/highlight the content of the entire cell (Cmd-A), and copy (Cmd-C) it to the clipboard. Then paste into Adwords.
macosnoob is offline   Reply With Quote
Old 07-20-2010, 12:04 PM   #3
Laceys
Prospect
 
Join Date: Jul 2010
Posts: 7
I've tried that...

I copy multiple cells at a time.

Your suggestion does work to copy one cell at a time but not multiple cells. Do you know a way to select all (command A) for the text in multiple cells?
Laceys is offline   Reply With Quote
Old 07-20-2010, 03:52 PM   #4
macosnoob
MVP
 
Join Date: Jan 2007
Posts: 1,907
No, I don't see how to copy multiple cells and avoid the extra quotation marks on a site like Google Adwords. Perhaps someone who uses Numbers more often than I do will have a suggestion.
macosnoob is offline   Reply With Quote
Old 07-20-2010, 05:02 PM   #5
Laceys
Prospect
 
Join Date: Jul 2010
Posts: 7
Question

Thanks for getting me this far I appreciate your help.

Is there anyone else out there familiar with Numbers '09 that could possible help with this issue????
Laceys is offline   Reply With Quote
Old 07-20-2010, 05:11 PM   #6
NaOH
Hall of Famer
 
Join Date: Dec 2007
Posts: 3,840
I'm not in a position to test this at the moment, but if you're using Safari, try the Edit > Paste And Match Style command (Shift-Command-Option-V).

Last edited by NaOH; 07-20-2010 at 05:14 PM.
NaOH is offline   Reply With Quote
Old 07-20-2010, 05:15 PM   #7
Laceys
Prospect
 
Join Date: Jul 2010
Posts: 7
Nope that didn't work either. It still pastes extra quotes around the words.
Laceys is offline   Reply With Quote
Old 07-20-2010, 05:22 PM   #8
NaOH
Hall of Famer
 
Join Date: Dec 2007
Posts: 3,840
Have you tried a different browser? I presume you're using Safari, so maybe one that isn't based on WebKit, like Firefox.
NaOH is offline   Reply With Quote
Old 07-20-2010, 05:33 PM   #9
Laceys
Prospect
 
Join Date: Jul 2010
Posts: 7
I've tried Safari, Chrome, and firefox. I don't know what Webkit is. I'm guessing it's just a platform that Safari uses?
Laceys is offline   Reply With Quote
Old 07-20-2010, 05:36 PM   #10
NaOH
Hall of Famer
 
Join Date: Dec 2007
Posts: 3,840
That's basically correct about WebKit. It's used by a number of browsers (Safari and Chrome, for example), but not all, so I figured it was worth a shot, in case it tied in somehow with your issue.
NaOH is offline   Reply With Quote
Old 07-20-2010, 05:43 PM   #11
Laceys
Prospect
 
Join Date: Jul 2010
Posts: 7
Good idea I thought it could be that at first too but I really think it's a Numbers flaw.
Laceys is offline   Reply With Quote
Old 07-20-2010, 09:15 PM   #12
ganbustein
MVP
 
Join Date: Apr 2008
Location: Berkeley CA USA
Posts: 1,194
A kludgy workaround is to paste into a new TextEdit document (producing a table of the copied cells), then select-all, copy, and paste where you wanted to paste.

At least, that works when I paste into this reply field. (I'm composing this reply in Safari 5.0 on OS X 10.6.4.) Without the detour through TextEdit, I get the extra quotes as described. Finder->Edit->Show Clipboard shows that Numbers is placing Rich Text on the clipboard, as is TextEdit, but apparently not the same RTF.
ganbustein is offline   Reply With Quote
Old 07-20-2010, 09:50 PM   #13
NaOH
Hall of Famer
 
Join Date: Dec 2007
Posts: 3,840
I'd also suggest letting Apple know about this: www.bugreporter.apple.com
NaOH is offline   Reply With Quote
Old 07-21-2010, 05:36 AM   #14
blubbernaut
MVP
 
Join Date: Sep 2003
Posts: 1,863
Hey! I've had this exact same problem, but to narrow it down a bit, it was pasting from Numbers into Indesign!

Except I was getting quotation marks where there wasn't any at all before. It seemed to only happen when copying and pasting multiple cells at the same time.

I don't have a fix, but that narrows it down to Numbers doesn't it?
blubbernaut is offline   Reply With Quote
Old 07-22-2010, 05:24 PM   #15
Laceys
Prospect
 
Join Date: Jul 2010
Posts: 7
blubbernaut- Yes, that does help narrow it down to being a numbers '09 issue.

ganbustein- Yes, I found that trick with TextEdit too but as I'm sure you can imagine that adds a ton of time onto a project with repetitive copy and pasting.

NaOH- Thanks I'll report to apple too.
Laceys is offline   Reply With Quote
Old 07-22-2010, 06:00 PM   #16
ganbustein
MVP
 
Join Date: Apr 2008
Location: Berkeley CA USA
Posts: 1,194
Another kludgy workaround is to turn on "Smart quotes" in Numbers'09. Smart quotes don't trigger the problem. (Naturally, this is useless to you if the place you're pasting to requires that quotes be dumb.)
ganbustein is offline   Reply With Quote
Old 07-22-2010, 06:02 PM   #17
NaOH
Hall of Famer
 
Join Date: Dec 2007
Posts: 3,840
My experiences don't match ganbustein's, both with InDesign CS4 and with smart quotes in Numbers '09. This is on a 10.6.4 system.
NaOH is offline   Reply With Quote
Old 07-23-2010, 04:43 PM   #18
ganbustein
MVP
 
Join Date: Apr 2008
Location: Berkeley CA USA
Posts: 1,194
You turn on "Use smart quotes" in Numbers->Preferences->Auto Correction before you enter the text. Any quotes you type will be converted on the fly to "smart" (curly) quotes (“...” or ‘...’). This applies only to newly-typed data; "dumb" (straight) quotes that you've already entered or that you paste in won't be affected, and still won't be copied correctly.

Here's what I get if I copy and paste four cells with the indicated content.

“Some text in smart double-quotes”
‘Some text in smart single-quotes’
"""Some text in dumb double-quotes""
'Some text in dumb single-quotes'
ganbustein is offline   Reply With Quote
Old 03-10-2011, 02:38 PM   #19
abyrd
Guest
 
Posts: n/a
My fix to work around this Numbers bug

I was having the same problem, regardless of what program I pasted into (TextEdit, InDesign, etc). All the problem text in Numbers.app came in as a paste from another program (Safari, in this case), by the way.

In my case, all the extra quotes were in cells that did have one quote present (e.g. Hoagie Rolls, White, Unsliced, 7").

What I did to fix it was to do a find and replace in numbers to replace all of the quote marks with new quote marks. I just copied and pasted one of the bad quote marks into the "find" and typed a fresh one in the "replace". Now when pasting from Numbers to InDesign no extra quotemarks appear.

I hope that helps someone!
  Reply With Quote
Old 11-24-2011, 09:04 AM   #20
kathytri
Guest
 
Posts: n/a
Thank you abyrd, that was a great solution! I was having the same problem as described by others above, and had resigned myself to having to copy and paste into Pages to "clean up" the extra quotes before being able to paste the text into its final destination. This would have meant a lot of extra time and hassle!

I tried your solution and it worked perfectly! I was indeed in the situation where my Numbers document contained quotation marks pasted from other applications. Doing the "find & replace" as you described completely fixed that strange duplication of quotation marks.

Thanks again for this helpful insight!
  Reply With Quote
Reply

Tags
copy and paste, numbers '09

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.