Go Back   The macosxhints Forums > OS X Help Requests > OS X Server



Reply
 
Thread Tools Rate Thread Display Modes
Old 01-17-2003, 09:22 PM   #1
shurakai
Prospect
 
Join Date: Oct 2002
Location: Santa Barbara
Posts: 8
Question Installing Movable Type

has anyone had experience installing movable type on their server? I've run into some difficulty, and would appreciate some help:

I've installed all the files successfully (I think) but cgi-bin/mt-check.cgi is saying that HTML::Template and several other Modules are not present (even though they are)

I have direct access to the Server (I'm sitting here now working on it) so I can tweak it easily, I would just appreciate a second opinion.

Thanks,
Kai

Stats:
10.2.3 Server
Blue and White G3
__________________
always exploring
shurakai is offline   Reply With Quote
Old 01-17-2003, 09:34 PM   #2
justinp
Triple-A Player
 
Join Date: Mar 2002
Posts: 126
Perhaps you uploaded them using the wrong mode?
justinp is offline   Reply With Quote
Old 01-17-2003, 09:56 PM   #3
nosaj56
Triple-A Player
 
Join Date: Jul 2002
Location: Louisiana
Posts: 208
permissions???
nosaj56 is offline   Reply With Quote
Old 01-17-2003, 10:19 PM   #4
vertigo
Triple-A Player
 
Join Date: Jan 2002
Posts: 62
I was successful installing MT on my Mac running 10.2.3, but it took a lot of trial and error.

Where did you locate your site? Under '/Library/WebServer/' or under '~/Sites/'? To make it work on my setup I installed all the cgi stuff into /Library/WebServer/CGI-Executables/ and then the rest in /Library/WebServer/Documents/. I then needed to create a symlink through the terminal for CGI-Executables in my Documents folder (I called the link cgi-bin).

Then I edited the mt.cfg so that it enabled the following:

CGIPath http://www.your.domain.com/cgi-bin/

DataSource /Library/WebServer/CGI-Executables/db/

StaticWebPath /

I then edited the blog configuration (when you run mt.cgi on localhost) to read as follows -

Local Site Path: /Library/WebServer/Documents

Site URL: http://www.your.domain.com/

Local Archive Path: /Library/WebServer/Documents/archives

Archive URL: http://www.your.domain.com/archives/

Hopefully that will help you troubleshoot a little.
__________________
~vert
vertigo is offline   Reply With Quote
Old 01-17-2003, 11:21 PM   #5
shurakai
Prospect
 
Join Date: Oct 2002
Location: Santa Barbara
Posts: 8
moving forward

My permissions were fine and it was in the correct format. I got it to work following the directions from this site:

http://www.movabletype.org/cgi-bin/i...14&t=12762&st=

which I'll repaste here:


uucee
Group: Members
Posts: 15
Joined: Dec. 2002
Posted: Jan. 12 2003,16:10

"Installation is fairly painless, especially if you do use the "full libs" version and don't want to hassle with CPAN module downloads.

"One-two-thirteen "quickie" instructions for a set-up that worked for me.

"For editing the config files, you can use "vi", "emacs", whatever, or use "TextEdit.app":

/Applications/TextEdit.app/Contents/MacOS/TextEdit <FILE> &

0. Enable Root User with /Applications/Utilities/NetInfo Manager.app .

1. Bring up Terminal.app, "su root".

2 Unpack all the MT files under /Library/WebServer/MovableType
2.1 cd /Library/WebServer/
2.2 zcat <DL directory>/MT-2.51-full-lib.tar.gz | tar xvf -
2.3 mv MT-2.51-full-lib MovableType

3. Edit mt.cfg in the MovableType directory
3.1 At least: change 'CGIPath' from 'http://WWW.YOUR-SITE.COM/PATH/TO/MT/' to 'http://<YOURHOSTNAME>/mt/' . YOURHOSTNAME could be localhost.
3.2 If you want to store the data somewhere else than /Library/WebServer/MovableType/db, change the 'DataSource' entry.

4. Create the 'db' directory and set permissions
4.1 mkdir /Library/WebServer/MovableType/db
4.2 chown www /Library/WebServer/MovableType/db

5. Configure Apache for the MovableType directory
5.1 Edit /etc/httpd/httpd.conf, add the following (perhaps before the last "Include" line):

Alias /mt/ "/Library/WebServer/MovableType/"

<Directory "/Library/WebServer/MovableType/">
AddHandler cgi-script .cgi
Options ExecCGI
Order Allow,Deny
Allow from all
</Directory>

<Location /mt/db/>
Order Deny,Allow
Deny from all
</Location>

6. Start / restart the web server from System Preferences / Sharing under the "Personal Web Sharing" entry.

7. Point Safari to http://localhost/mt/ ; you should see the docs
7.0 Safari seems to have issues with "localhost" href's; use 127.0.0.1 if you get a URI such as http://mt/docs/mtinstall.html w/o the host name.

8. Run the Perl module check
8.1 http://127.0.0.1/mt/mt-check.cgi

9. Bootstrap the data store
9.1 http://127.0.0.1/mt/mt-load.cgi

10. Remove mt-load.cgi from the system
10.1 rm /Library/WebServer/MovableType/mt-load.cgi

11. Log in as user "Melody", password "Nelson"
11.1 http://127.0.0.1/mt/mt.cgi

12. Follow the steps in the install docs
12.1 http://127.0.0.1/mt/docs/mtinstall.h...movable%20type

13. Blog.


If you'd rather have all of MT reside under your home directory, just change /Library/WebServer/MovableType/ to /Users/<USERNAME>/Library/MovableType/ or such where appropriate.

(edit: added <Location /mt/db/> protection.) "

but it's not running under mysql, which was kind of the point of the whole process for me... I'm working on it more to get it to use mysql.

any tips?

note: I'm following the directions supplied with the installer... they just don't seem to work well

peace,
Kai
__________________
always exploring

Last edited by shurakai; 01-18-2003 at 02:04 PM.
shurakai is offline   Reply With Quote
Old 01-18-2003, 06:43 AM   #6
vertigo
Triple-A Player
 
Join Date: Jan 2002
Posts: 62
I was never able to get MySQL to work. I just downloaded CompleteMySQL-3.23.54a.dmg to see if that might be a solution.

I'll let you know how it goes.
__________________
~vert
vertigo is offline   Reply With Quote
Old 01-30-2003, 04:22 PM   #7
vertigo
Triple-A Player
 
Join Date: Jan 2002
Posts: 62
OK..., here's my followup.

I was finally able to get MySQL to work with MT but I don't know if it is done right, or if it is even very secure.

As I stated before, I ended up installing CompleteMySQL and installation was a snap. I followed up the install with the tips from O'Reilly's Macdevcenter.com and was able to get the test.cgi working no problem. The nice thing about the CompleteMySQL install is that it puts in a preference panel so that you can start and stop MySQL just like starting and stoping Apache. It also allows you to initialize with one click.

Then I attempted to create a database for MT and set it up in the mt.cfg file. I couldn't make it work for the life of me. You have to get into the terminal to create databases and I can not find a good tutorial on how to do that (in a non-geek format). Man pages are pratically useless to me, as they just don't tell you what you are supposed to "do". I pretty much gave up at that point.

Then I stumbled across a few programs that put a nice GUI on the whole MySQL thing. CocoaMySQL and also YourSQL. They both look really slick and are probably great at what they do, but I could never get them to connect to my Server. I blame this on me not knowing really what I am doing, not the effectiveness of these programs.

So without a way to create or manage a database, I gave up again. But no! I thought. There has to be a way to do this. I am so close I can taste it! My search for an answer continued...

Then I found a great utility called Webmin, which works under OS X. Using this I was able to create a new database for MT! All is going great, me thinks. So back to the mt.cfg to put in my particulars and get this baby moving. Specifically there is a line in the mt.cfg for setting up a MySQL database as opposed to the Berkeley DB:
Code:
# DataSource /Library/WebServer/CGI-Executables/db/

ObjectDriver DBI::mysql
Database mtdatabase
DBUser root
The '# Data Source...' line excludes the Berkeley DB and the rest enables using MySQL. The part you change are 'Database' and 'DBUser'. At first I tried to use the DBUser 'mysql' that every MySQL install seems to say you should use. I think they say that because that way Apache can have access to the database..., la la la..., the instructions start to get overly geeky, and I lose focus pretty quick. Suffice it to say I could not successfully set up 'mysql' as a user in Webmin or anything else. So, on a whim, I tried using the user 'root' and voilą! it worked.

This is where I think I may have made it work, but not in a good way. I don't think it is copacetic to have 'root' as the user and exposed to my Apache website. Sounds like a clever lad or lass could get in and do bad thingies. I just don't know. And until I do, I'm not using it like that.

So, if anyone knows of a good normal english dumbed down tutorial on using MySQL for Mac OS X, please point me in the right direction.

Thank you, and good night.
__________________
~vert
vertigo is offline   Reply With Quote
Old 02-04-2003, 12:52 AM   #8
shurakai
Prospect
 
Join Date: Oct 2002
Location: Santa Barbara
Posts: 8
Still having Trouble

well, almost there folks, except I'm still not getting mysql working with MT... the message is:

DBD::mysql...
Your server does not have DBD::mysql installed. DBI and
DBD::mysql are required if you want to use the MySQL database
backend. Please consult the installation instructions for help
in installing DBD::mysql.

of course it helps not at all, since the installation instructions don't really tell anything except to install it

any other hints?
Kai
__________________
always exploring
shurakai is offline   Reply With Quote
Old 02-04-2003, 02:00 AM   #9
Dr.Evil
Triple-A Player
 
Join Date: Mar 2002
Location: Denver, CO
Posts: 63
Lightbulb Re: Still having Trouble

Quote:
Originally posted by shurakai
well, almost there folks, except I'm still not getting mysql working with MT... the message is:

DBD::mysql...
Your server does not have DBD::mysql installed. DBI and DBD::mysql are required if you want to use the MySQL database backend. Please consult the installation instructions for help in installing DBD::mysql.

I have a working installation of MT, but I was content with BerkeleyDB. DBD::mysql has to be compiled for each platform. A Mac OS X installer for DBD::mysql (and Bundle::DBI, on which it depends) can be downloaded from here.

Hope that helps...
Dr.Evil is offline   Reply With Quote
Old 02-04-2003, 02:47 AM   #10
shurakai
Prospect
 
Join Date: Oct 2002
Location: Santa Barbara
Posts: 8
Success!

That did it! movabletype is now running under mysql! Thanks everyone for all your help!

for the convenience of others, below are the corrected steps for getting Movabletype to work with MySQL on OS X Server:

0. Enable Root User with /Applications/Utilities/NetInfo Manager.app .

1. Bring up Terminal.app, "su root".

2 Unpack all the MT files under /Library/WebServer/MovableType
2.1 cd /Library/WebServer/
2.2 zcat <DL directory>/MT-2.51-full-lib.tar.gz | tar xvf -
2.3 mv MT-2.51-full-lib MovableType

3. Edit mt.cfg in the MovableType directory
3.1 At least: change 'CGIPath' from 'http://WWW.YOUR-SITE.COM/PATH/TO/MT/' to 'http://<YOURHOSTNAME>/mt/' . YOURHOSTNAME could be localhost.

4.Comment the Datasource line and setup MySQL
4.1 place a # sign before the Datasource line so it looks like this "# DataSource ./db"
4.2 insert the following lines for mysql:
ObjectDriver DBI::mysql
Database 'database_name'
DBUser 'user'

5. Configure Apache for the MovableType directory
5.1 Edit /etc/httpd/httpd.conf, add the following (perhaps before the last "Include" line):

Alias /mt/ "/Library/WebServer/MovableType/"

<Directory "/Library/WebServer/MovableType/">
AddHandler cgi-script .cgi
Options ExecCGI
Order Allow,Deny
Allow from all
</Directory>

<Location /mt/db/>
Order Deny,Allow
Deny from all
</Location>

6. Download the DBI Bundle from here

7. Open the package and make sure to select DBI::mysql package in the installation options

8. Change mt-db-pass.cgi to hold your password for MySQL
8.1 Open mt-db-pass.cgi with your text editor and simply replace "database_password" with the password of your MySQL user (see step 4.2)

9. Start / restart the web server from System Preferences / Sharing under the "Personal Web Sharing" entry.

10. Point your browser to http://localhost/mt/ ; you should see the docs
10.0 Safari seems to have issues with "localhost" href's; use 127.0.0.1 if you get a URI such as http://mt/docs/mtinstall.html w/o the host name.

11. Run the Perl module check
11.1 http://127.0.0.1/mt/mt-check.cgi

12. Bootstrap the data store
12.1 http://127.0.0.1/mt/mt-load.cgi

13. Remove mt-load.cgi from the system
13.1 rm /Library/WebServer/MovableType/mt-load.cgi

14. Log in as user "Melody", password "Nelson"
14.1 http://127.0.0.1/mt/mt.cgi

15. Follow the steps in the install docs
15.1 http://127.0.0.1/mt/docs/mtinstall....0movable%20type

16. Blog.

I've had no other problems, but I'll keep you updated if I find them.

Peace,
Kai
__________________
always exploring

Last edited by shurakai; 02-04-2003 at 02:51 AM.
shurakai is offline   Reply With Quote
Old 06-10-2003, 05:31 AM   #11
aiBoek
Prospect
 
Join Date: Jan 2002
Location: The Netherlands
Posts: 16
Step 6 doesn't work for me... heavyhosting.net seems to be down. Anywhere else where I could find this?
aiBoek is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.