Go Back   The macosxhints Forums > OS X Help Requests > Networking



Reply
 
Thread Tools Rate Thread Display Modes
Old 04-14-2012, 10:32 PM   #1
dickguertin
Prospect
 
Join Date: Jul 2008
Posts: 13
SFTP Broken Pipe

I'm running Mac OSX 10.5.8 (Leopard) and I've always been successful uploading files with "sftp" to a Debian system, until April 2012 when that system was upgraded to Ubantu. ssh -V show the following:

Source: OpenSSH_5.1p1 MacOSX, OpenSSL 0.9.7l 28 Sep 2006
Target: OpenSSH_5.8p1 Debian-7ubuntu1, OpenSSL 1.0.0e 6 Sep 2011

My Mac is the Source, and the Target is the upgraded Debian system. Now, every time I attempt to transmit a 58Mb file from Source to Target, it gets about 50% completed, and ends with "Broken pipe". I'm sending over a DSL line that averages 40KB/s. I can successfully send small files (10Mb or less).

I've tried "rsync", and it also fails. I've tried changing the buffer size on the Mac side (-B 4096), and that fails. I claim the problem is with the Ubuntu upgrade since "sftp" for large files over DSL worked BEFORE the upgrade.

I've tried "scp", and that seems to work, but I'm limited to sending a single file. With "sftp" I could do something like: put -p *.c
I've tried sending to other Macs, and that works (as always). I've also sent large files to another Mac via DSL, but that Mac is connected to the Ubuntu Target by a high speed network link (500KB/s or better). I can remote-login to the other Mac and successfully "sftp" the file. Therefore, I'm guessing it is an elapsed time issue: <xmit-time> = <xmit size> / <xmit rate>

I'm wondering if anyone has had the same experience, or has suggestions on how to solve this problem with "sftp".
dickguertin is offline   Reply With Quote
Old 04-15-2012, 12:20 AM   #2
fracai
MVP
 
Join Date: May 2004
Posts: 2,089
Try rsync with '-P' (for partial transfers and progress display) or just '--partial'. If the connection fails, it will resume when you try again.

It's odd that scp is fine, but rsync fails. They should both (along with sftp) be using essentially the same process to transfer the files.

You might also try adding verbosity (-v) to see if there's a consistent error before the failure.
fracai is offline   Reply With Quote
Old 04-16-2012, 11:46 AM   #3
trevor
Moderator
 
Join Date: Jun 2003
Location: Boulder, CO USA
Posts: 19,829
Quote:
I'm sending over a DSL line that averages 40KB/s. I can successfully send small files (10Mb or less).

Problems with large files but not small files over DSL are sometimes because of an incorrect MTU setting. DSL providers are notorious for having systems that don't work with the default 1500 setting of MTU, but not really properly notifying customers of this.

In Snow Leopard (which is what I'm using right now), you set MTU at System Preferences > Network > select your interface, such as Airport or Ethernet > click Advanced button > Ethernet tab > Configure: Manually > MTU. It's also possible or likely, if you are using a router, that you'll need to set MTU on the router, not on your computer.

Some common DSL values for MTU are 1492, 1450, and 1400. You can check with your DSL provider, or else just try the above numbers until the problem goes away.

Trevor
trevor is offline   Reply With Quote
Reply

Tags
sftp, ssh

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.