Go Back   The macosxhints Forums > OS X Help Requests > Networking



Reply
 
Thread Tools Rate Thread Display Modes
Old 02-28-2012, 04:23 PM   #1
eduo
Prospect
 
Join Date: Jan 2002
Posts: 2
Have you been able to run Samba newer than 3.2.15 in Lion?

Hi, All.

I have made a tool (called SMBUp) that is supposed to be a front-end for Samba for Lion. I made it mainly because a bunch of friends of mine have mediacenters or old devices that can only communicate through SMB1 and Lion's SMB implementation doesn't work for them.

For this I have made an installer for Samba and its dependencies (my program allows the user to download and install it) but it's from the latest version supported by MacPorts (which is 3.2.15), a somewhat old one.

This version has some issues with user group resolution so I've been trying to get a newer version to work, but I haven't had any luck. Newer versions either don't compile or crash on startup.

So, my question is twofold. Either/or:

1.-Have you been able to run MacPorts Samba version (3.2.15) in authentication mode? (guest mode works OK) If so, how did you manage to do so?

2.-Have you been able to compile/run a newer version of Samba in Lion where authentication (not only guest access) works? If so, how did you do it, did you modify MacPorts or Homebrew for it?
eduo is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.