Go Back   The macosxhints Forums > OS X Help Requests > Networking



Reply
 
Thread Tools Rating: Thread Rating: 164 votes, 4.98 average. Display Modes
Old 01-29-2011, 05:58 AM   #121
colin6272
Guest
 
Posts: n/a
I have just cracked the "self assigned IP" nightmare by going into my router configuration page and changing the encryption from WEP to WPA-PSK. Apparently Mac products do not like using WEP anymore. Having changed it I've now gone back into network settings, put in the password and all works fine. Hurrah!
  Reply With Quote
Old 01-30-2011, 05:02 PM   #122
hypno
Guest
 
Posts: n/a
Question

Hi guys,

I'm new to the forum and this is my first post.

I have similar problems with DHCP,
every time I connect to the network it will do the following sequence:
- connect and authenticate to the network if needed
- attempt to get an IP address via DHCP
- fail to get and address and configure a self-assigned address 169.x.x.x
- after 10 seconds eventually self heal and get a correct ip address

I collected a sniffer trace and I found why this is happening:
as soon as I connect to a network, the DHCP client will send a DHCP request using the last ip address leased to the interface.
The DHCP server will deny the request and the DHCP client will eventually get a self assigned ip address.

The solution to this is really simple: clear the DHCP lease whenever you connect to the network.
Can anyone point me to a way to run a script everytime I connect the network?
  Reply With Quote
Old 02-10-2011, 11:13 AM   #123
talrove
Guest
 
Posts: n/a
Hey all,
I've been having issues with my airport having a self-assigned IP and I just somewhat accidentally FIXED IT!

I should mention that although my computer (MPB 15") and myself are from the US, I am currently living in Israel.

The issue arose when I tried to wake my computer up from sleep and it wouldn't come to. I had to force it to shut down and restart, and at this point it stopped being able to connect to the router (Rotal 1025). I would get the self-assigned IP message, 169.xxx etc. Other computers in the house, both Mac and Windows were still able to connect wirelessly, and I was able to connect directly with ethernet, but I could not get the wireless to work. I tried everything I read in this discussion and still nothing.

I have Boot Camp on my computer, so I tried booting up in Windows to see if I would be able to use the wireless there, and it worked fine. Then when I restarted back into OS X (10.6.6), the airport worked fine like nothing had ever happened! It immediately was assigned an IP and is now back to normal.

I hope this helps someone else out there...
  Reply With Quote
Old 03-22-2011, 02:16 PM   #124
Nikkiru
Guest
 
Posts: n/a
Wow, this old thread isn't obsolete yet, and there still doesn't seem to be a definitive fix to the self-assigned IP bug.

I struggled with this for two days, trying everything that was suggested in this thread short of resetting the router - because it's not my router. I had to take a PC laptop as well as my PowerBook G4, just so I could read this thread while trying to fix the problem. I honestly couldn't say what finally worked, but I know something did.

Sorry if this post is more whine than solution. But since I'm new to Macs, I really have to wonder why people out up with such an inherently buggy machine, created by a manufacturer whose support site doesn't even offer a search function.
  Reply With Quote
Old 04-02-2011, 12:01 PM   #125
gregynels
Prospect
 
Join Date: Apr 2011
Posts: 1
Connection Sharing

I had the same problem. My Airport Extreme suddenly, for no apparent reason, wouldn't assign me a valid IP. I am running 3 Macbooks through an Airport Extreme Router.

The problem was fixed by adjust the settings in my Airport Utility.

1) I opened the Airport Utility
2) I clicked "Manual Setup"
3) I clicked on the grey "Internet" globe at the top
4) I changed the "Connection Sharing" option from Off (Bridge Mode) to >> Share a public IP address.

This fixed it. Hope it works for others.
gregynels is offline   Reply With Quote
Old 04-16-2011, 03:40 AM   #126
chrisfromhilltop
Guest
 
Posts: n/a
Wow still occurring 7 years on...

I'm a PC guy just like the TV ad and my wife is the cool Mac chick - until you get a problem such as this one. Then the PC guy is the coolest guy as he fixed the 'My Mac never has a problem' chicks Mac.

Anyway.....

I'm pretty technical and noted with interest the prior guy who used a network sniffer to decode the DHCP request/response between the Mac and the router and how it seemed the MAC was ignoring the DHCP allocation as it was not the address the MAC expected.

It appears that the broadcomm airport chipset gets its self tangled. Unfortunately upgrading airport drivers, all the deleting of files/removing keychain entries and creating new locations, firewall checks etc didn't resolve the issue on Macbook OS 10.5.8 for me.

I could perform the following workarounds;
1/ Manually set the IP address (remember to set the DNS and default gateway as well for those who tried this approach and said it didn't work)

2/ Use DHCP with manual IP address option and manually enter in an IP address from the LAN segment out of the DHCP range. This had the advantage of loading the DNS and default router gateway etc from DCHP.

However for my situation to actually solve it, It was similar to the Sniffer guys comment of clearing the old DHCP entry on the MAC. I didn't find how to do this manually on the MAC but the following did clear the old cached entry and rectified the problem for me so may help others who encounter a wife's wail of 'Oh no Honey my Mac can't access the internet! Can you fix it Pleaseeeeee?'

Log onto the router and manually go into the DHCP settings and create a static IP address and MAC address entry for the interface MAC address of the Apple MAC. The MAC address is under the network configuration for the airport advanced section -> Ethernet tab.
Then stop/start the airport and hopefully DHCP should assign this static address mapping on the router. This then clears the old troublesome DHCP entry on the MAC.
You can then leave this as is or you can delete the static DHCP entry on the router and the Mac should then work as before.

Obviously you need access to the router for this to work. You could try to delete the com.apple.network.identification.plist file as that XML file seems to hold the historical DHCP and MAC address bindings. As I got it working I didn't check this though - so make a copy first.

Best of luck!
  Reply With Quote
Old 07-02-2011, 12:21 AM   #127
s0methingrare
Guest
 
Posts: n/a
Alternative fix

Hi all,
My wife and I have been going through this same issue for two days. She called her tech support guy and he said:

1. Turn off the airport
2. Hold down the power button to power down the machine
3. Turn on the machine
4. Turn on the airport

And it worked! He explained, get this, that the machines sometimes carry too much static electricity and that interferes with the airport connectivity. Turning off airport and forcefully powering down the machine by holding in the power button discharges that electricity.

So if your firewalls are all disabled, and you are still getting this problem on your macbook, give this a shot.
  Reply With Quote
Old 07-05-2011, 03:35 PM   #128
zedd45
Guest
 
Posts: n/a
Macbook Pro 5.1 Airport / Ethernet both get "Self Assigned" IP address

I read several posts on this and other forums regarding this issue. The first thing I did of course was restart the computer, bounce the router (power cycle), and renew the DHCP lease in system pref. -> network -> advanced -> TCP/IP -> renew DHCP lease.

I also tried resetting PRAM, NVRAM and even the SMC. None of these techniques worked for me.

I tried both Airport & using a good ole ethernet cable.

The computer would connect to the router, but would always get this "self assigned IP," Which the Mac even told me might have limited access or something like that.

Finally, I read some post in here about the firewall, and I noticed that it was set to allow "only essential services." I would expect that DHCP is an "essential" service, but I disabled the firewall, and airport, and then reenabled air port.

It works fine after that. Even if I re-enable the firewall.

Thought this experience might help someone else.
  Reply With Quote
Old 07-19-2011, 11:23 PM   #129
GanjaManja
Prospect
 
Join Date: Jun 2009
Posts: 10
Thumbs up success! removed airport prefs

I did as others suggested - trashed (well, moved to desktop) the com.apple.airport.preferences.plist file from <root Drive>/Library/Preferences/SystemConfiguration and the "self-assigned IP address" problem was solved!!! Wasn't my Belkin router after all!

btw I had to turn off Airport on the computer (iBook G4), remove the file, then restart and turn on Airport for it to work. Attempts to do it faster ways didn't work.

Thanks folks!
GanjaManja is offline   Reply With Quote
Old 09-25-2011, 03:57 AM   #130
Noodle
Guest
 
Posts: n/a
Smile Problem fixed!

I have been experiencing similar problems but it was immediately fixed after completing this suggested by bmacir:

"I have been struggling with this problem for a couple of days and it was driving me crazy. I have tried all of the solutions above-mentioned with no success.

The problem came across after trying to find a solution to another problem I had with my Time capsule: an IP conflict which made me drop the connection every 10-15 seconds. After I solved it (it turned out to be because of the router configured wong - my dsl company (tele2) gave me the wrong parameters by phone, I checked on their web site and got the right ones!!!!!)

This is what worked for me: after deleting the plist file, restting pram deleting the keychain with no success, I chose to do a assisted configuration of the interet (system pref - network - assist me... - assistant...). I previously had location set to automatic and created a new one with the "assist me..." feature and this solved it immediately, I finally got a correct IP address assigned again!!!

I hope that this helps someone else - this is my first post, I thought that it was about time I could help someone else after getting so much from this site!"

thanks bmacir

it may sound simple but i suggest anyone with a similar problem try this as it may work for them. That and deleting from the keychain.
  Reply With Quote
Old 12-21-2011, 05:53 PM   #131
ccbkh
Guest
 
Posts: n/a
Also self assigned ip using Airpor Extreme?

I am also having issues with an Airport Extreme and DHCP, I think.
I have a MacBook Pro that is running 10.6.8 and it connects to the Extreme and get a correct IP. I also have a PC connected to one of the port on the back of the Extreme and it to has internet access.
When I try to connect an iMac 2.66GHz running 10.6.8 it gets a Self Assigned IP message? It does connect to the Extreme.
Same with an iPad and iPhone, no network connection. iPad gets a 169#.
I take the devices including the iMac to another network site in a different building all work fine.
Would appreciate any ideas?
  Reply With Quote
Old 12-29-2011, 09:12 PM   #132
Mackie
Guest
 
Posts: n/a
Thank you!! This worked!

Quote:
Finally, I read some post in here about the firewall, and I noticed that it was set to allow "only essential services." I would expect that DHCP is an "essential" service, but I disabled the firewall, and airport, and then reenabled air port.

It works fine after that. Even if I re-enable the firewall.

Thought this experience might help someone else.

zedd45 you sure did help me! I had spent hours with my ISP tech support, replaced my router and spent even more hours with router support; even the Genius bar didn't help. Nothing worked UNTIL I tried your solution.
  Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.