View Single Post
Old 08-31-2009, 08:04 PM  
NoSalt
Triple-A Player
 
Join Date: Oct 2002
Location: Earth
Posts: 58
Ok ... I've figured it out. My image files were "quarantined". I figured that there must be some kind of permission issue so I did a long listing and got many files that looked like this:

Code:
-rw-r--r--@ 1 user  admin    79K Aug 30 20:51 filename.jpg
So I did some research and found out that the '@' sign at the end meant that the file has additional "Apple" attributes. The article suggested that I run:

Code:
xattr -l <filename>
to see what the extra permissions were. I did and came up with a listing that looked like this:

Code:
filename.jpg: com.apple.quarantine: 0000;4a9b1e40;Safari;|com.apple.Safari
So, I did some more research on "com.apple.quarantine" and found out that it relates to the annoying Apple message that says:

"<name>" is an application which was downloaded from the internet. Are you sure you want to open it?

The article said to fix the file attributes I should run the following:

Code:
sudo xattr -d com.apple.quarantine filename.jpg
I did this and now all my images open up just fine. Very frustrating indeed. So now this problem of mine is solved. Thank you very much to all who read and replied. Now I have a different question. Does anybody know how to disable this annoying feature on Snow Leopard???

Have a good one
__________________
A nod's as good as a wink to a blind bat
NoSalt is offline   Reply With Quote