The macosxhints Forums

The macosxhints Forums (http://hintsforums.macworld.com/index.php)
-   Networking (http://hintsforums.macworld.com/forumdisplay.php?f=14)
-   -   Mixed network USB printing problem (http://hintsforums.macworld.com/showthread.php?t=168436)

walchan99 01-04-2013 12:45 AM

Mixed network USB printing problem
 
Mixed network problem again. Bought a Netgear DGN2200v3 router. Good performance. In-built traffic meter. USB disk option. Made it my primary server (Gateway, DHCP). My Time Capsule (connected via ethernet) is now in Bridge mode in the basement, and provides wireless connectivity there. My (non-network printer HP Laserjet 1022) is connected via USB to the Time Capsule.

For 'Extend a Wireless Network' reasons, want to interchange the physical locations of the TC and the Netgear. So the Netgear goes to the basement, but remains the Gateway & DHCP, and the TC comes up and creates a network which can be extended on demand via Airport Express.

Since my printer (housed in the basement) can't be served by the Netgear, I thought of using an old (Flying Saucer) Airport Extreme I have lying around. So ethernet connection from Netgear to Airport Extreme. USB connection from Airport Extreme to printer. All well, printer shows up in the Printers tab in Airport Utility.

But no luck with the printing. Am mystified, since the Airport Extreme was till recently connecting the same printer to the wireless network. The printer shows up fine in the System Preferences list, green light and all. I fire the print and it cannot connect. The alert says 'Unable to find printer'. Tried from my iMac running 10.8 and MBP running 10.6. Followed another tip in this forum and 'reset the printer'. Still no luck.

My reasoning is that since all connectivity from router to printer is wired, nothing should get in the way. Any guidance?

gsahli 01-05-2013 10:45 AM

I'm _guessing_ the Extreme's bonjour software can't figure out this network.
I have an alternative for you based on the fact that the Extreme supports the industry-standard HP Jetdirect protocol (raw port 9100 printing).
After reading here:
http://www.openprinting.org/printer/HP/HP-LaserJet_1022
I find you need Foomatic and Ghostscript (download/install) from here:
http://www.linuxfoundation.org/colla...acosx/foomatic
and foo2zjs from here:
http://foo2zjs.rkkda.com/
(sorry this is complicated)

What you end up with is a driver for the 1022 that is capable of standard network printing - to an IP address, via HP Jetdirect protocol.

And by the way - you've checked that the Extreme's IP address is within the subnet range that the Netgear creates, right?

walchan99 01-12-2013 10:10 AM

Gosh, thanks gsahli. Will certainly try that sequence. For now, though, I realised that I had messed up the networking somewhere, because when I switched a few patch cords around, the MBP started printing through the Extreme. Unfortunately, by then I had already reset the printer on the iMac, so that isn't printing now. But it shouldn't take long to reinstall. Thanks again.


All times are GMT -5. The time now is 05:48 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site design © IDG Consumer & SMB; individuals retain copyright of their postings
but consent to the possible use of their material in other areas of IDG Consumer & SMB.