PDA

View Full Version : iBook G4 stuck in 1024x768 & 256 colors


number9
10-28-2008, 01:17 PM
A friend of mine has asked me to take a look at her iBook G4, which she (unfortunately) spilled water on it -- presumably when it was running.

When I got it, it would boot up Tiger to a blank blue screen; you'd never see the login window appear. I re-installed Tiger but, from the entire Tiger installer to when the OS is fully loaded (and beyond), it's like the display is stuck in a high-contrast grayscale mode.

Specifically, when I go into System Preferences, the only resolution I have to choose is 1024x768 and the only color mode I have to choose is 256 colors. This can't be normal -- at least not the color depth setting!

Curiously, when I managed to update the machine to 10.4.11, it boots to a blue screen but I'm back to the original problem -- the login window never displays and the machine just hangs forever, although the cursor does move when you tell it to.

Has anyone seen this before? I was using the Archive & Install option to go from 10.4 to 10.4.11, I guess I could try simply formatting the drive and starting from scratch. But I get the feeling that isn't going to help...

trevor
10-28-2008, 02:12 PM
Usually, clean water isn't terribly damaging to circuit boards. Populated circuit boards are actually commonly washed in deionized or distilled water. So impurities in water can leave some minor deposits behind, but this is usually not terribly critical. What is damaging to electronics are colas, wines, and the like, which are both acidic and sugary.

After spilling clean water on a computer, the only secret is to make very very sure that it's completely dried out before turning it on. Otherwise, you risk shorting things out, as water (well, water with any impurities at all) conducts electricity rather well.

Is this an iBook G4 12" or 14"? What is it's processor speed?

All iBook G4s do indeed have a native screen resolution of 1024 x 768, but they should be capable of millions of colors at that resolution.

Have you tried connecting an external display?

Have you tried zapping the PRAM and resetting Open Firmware? (directions (http://forums.osxfaq.com/viewtopic.php?t=7269))

Have you run the Apple Hardware Test on this iBook? AHT should be on one of the discs that came with the computer.

Trevor

number9
10-28-2008, 02:16 PM
Thanks for the reply, Trevor!

I'm not sure of CPU speed (I think 1GHz?) but it's definitely a 12". I can't connect an external display because I don't have the right pigtail to connect a DVI or D-sub cable to :( I've reset PRAM but not OpenFirmware, I'll give that a try.

I haven't run AHT. I don't have the CD/DVD that came with this Mac, but I have numerous others. Can I use AHT from another PowerPC Mac or even from an Intel Mac? Or are the hardware tests very platform-specific? Oh, I've reset the PMU too.

By far the most puzzling thing is that, after upgrading to 10.4.11, the screen is blue -- so it seems like it really can display colors...

trevor
10-28-2008, 03:19 PM
No, you can't use the version of AHT from another type of Mac, unfortunately. You need the original disc, or possibly you could purchase a used one off of ebay, as long as it was for the identical iBook G4.

Let us know if an Open Firmware reset fixes the issue.

Otherwise, I'd use FireWire Target Disk Mode (http://support.apple.com/kb/HT1661), a FireWire cable, and another Mac to retrieve and back up all of the important information off of this iBook's hard drive, then try an Erase and Install of OS X.

Trevor

number9
10-29-2008, 10:37 AM
Hmm, this is strange. If I try to enter Open Firmware (by pressing Apple-Option-O-F) as the machine is immediately powered on, the machine never boots -- the screen stays black and I can't hear any hard disk activity.

If I wait until the screen turns white (when the Apple logo is displayed) and then press Apple-Option-O-F, the machine boots as normal and doesn't let me into Open Firmware at all...

trevor
10-29-2008, 12:00 PM
To enter Open Firmware, you hold down Command-Option-O-F and keep it held down from the time you hit the power button until you're actually booted into OF. You can recognize the Open Firmware screen by it's dark colored letters on a light colored background. An example image of the OF screen look is below.

http://digital.hmx.net/img/comp2/ppc/mac_mini/mac_mini_linux_02.jpg

Waiting to hold keys down until the screen turns light gray with an Apple logo is far too late, and won't do anything useful.

If you follow the correct procedure above and just get a dark screen instead of the OF screen, I wonder if the problem is related to the grayscale screen that you're reporting when booted into OS X. Perhaps after following the procedure you are actually in OF, but can't see that because of whatever screen issues you're having. Try doing that, then typing the OF commands blind, hitting Return at the end of each command line.

Trevor

number9
10-29-2008, 12:07 PM
I've actually used OF before, so I now what to look like when it appears -- but it never does. :( When the screen was blank, I reset-all command which I would expect would reboot the machine, but it didn't.

I tried an erase & install with genuine Apple 10.4 media, that got me to the same problem -- grayscale in 10.4.0 and the a Software Update to 10.4.11 hosed the machine. I can't seem to boot off a Leopard DVD to install that, either :(

I think this machine might be dead!