PDA

View Full Version : Mac Mini sees neighbors wireless not mine


PDACPA
09-09-2008, 08:56 AM
I just purchased a Mac Mini to play with (PC user) and I have a DGL-4300 D link wireless router. When I set up the Mac it sees my neighbors wireless network with no issue and connects. It sees my network (SSID) but refuses to connect. I have gone in to the network settings and set the DHCP manually (basically tried every option available). I also set the DMZ for the Mini's MAC address to allow it and it still will not connect.

I also made sure that the MAC address was not blocked on the router.

Does anyone have any idea on what else to try?

Thanks

cwtnospam
09-09-2008, 09:32 AM
Change the channel for your router. Most routers use 6 by default. You should download a wireless network utility (http://www.macupdate.com/search.php?keywords=istumbler&os=macosx&starget=google) to help you choose a channel that's available.

PDACPA
09-09-2008, 09:42 AM
I can try that, but I am not sure the channel is the issue. My Vista and XP laptops see the router and connect with no issue whatsoever. I was surprised the MacMini jumped on my neighbors network hassle free and I have been unable to get on mine. It sees it, but says "there was an error connecting to XXXX."

I have read through everything on the dlink website (it is an approved router for Mac's and I have the correct firmware) as I felt the router was giving me the issue.

Jasen
09-09-2008, 12:13 PM
Can you see what channel the neighbor uses?
Try out either 1 or 12, if the neighbor is set on the default of 6, that would stop you from overlapping signals.
Also, are there any security settings turned on? WEP, WPA, etc? If they are and the client is not configured for that, you'd also be unable to connect.

PDACPA
09-09-2008, 12:48 PM
I do not think my problem stems from the channel (though I could be wrong). His network is just listed as an available network. I know his WEP and I can connect to his wireless network and surf with no issue. When I go to switch to my wireless network, I get the error.

I think it has to do with a setting possibly on the router or in the MAc Mini settings. I tried using the automatic, and all the manual options and it still says it has an error connecting to my network.

regulus6633
09-09-2008, 12:58 PM
Once you connect wirelessly to someone it gets set as a "known" connection, and will continue to connect to that known connection. Also there's an order to those connections. So you need to go into the network preferences, click on your airport connection in the left column, then go to the advanced settings. It's in there... the list of "known" routers. You can delete your neighbors router from that list, or change the order of them such that your router is higher in the list. There's also other settings you can set, such as to ask what to do when a known router is not available.