PDA

View Full Version : Mail problem with Gmail after accidentally removing POP mailbox


februarystars82
04-20-2008, 11:42 AM
Hello everyone,

I am having an issue with Mail that I was hoping for some help with. I set up a POP account to retrieve my Gmail emails. It downloaded all the emails from my Gmail inbox which was great, but I accidentally removed the POP account from the Mail program. I went back in and added the account again, but this time it only downloaded new emails. I'm guessing something is telling it that I already have the old ones but I'm not seeing them in my Mail inbox. If anyone could give me any advice on how to re-retrieve all my old emails so that they appear in Mail, that'd be wonderful. Thanks in Advance!

februarystars82

Photek
04-20-2008, 01:46 PM
when you login to gmail via your web browser are ALL you email still on there?

februarystars82
04-20-2008, 01:53 PM
Yes, every email is still there when I log in on the Gmail site

mclbruce
04-20-2008, 08:12 PM
Go into settings on your Gmail account on the web.
Click on Forwarding and POP/IMAP
Next to POP download, click on Enable POP for all mail

februarystars82
04-20-2008, 09:26 PM
It worked! Thank you very much! ... one more issue, though: the email I had at college is about to expire and to avoid losing all the email from that account, I synced it up with the Gmail account. All the college emails arrived in my Gmail inbox with the correct date stamps which was great. The problem is, Mail is importing the college emails with date stamps that correspond to the day I synced up Gmail with my College email account. So, for example, emails that arrived in my college inbox in 2004 are showing up as arriving a couple of days ago (the day I synced up the accounts). Is there any way of correcting this? Thanks again for all your help!

februarystars82
04-20-2008, 10:23 PM
not sure if the last message i sent went through... i had a further question: i recently synced my gmail account with my college email account. all the date stamps for the college emails are correct in gmail but not in mail. for example, emails i received in 2004 in my college inbox show up as being received in 2004 in gmail, but the same emails show up as being received only a couple of days ago in mail (the day i synced the accounts). is there any way of fixing this?