PDA

View Full Version : SMB permissions broken in 10.5, fine in 10.4?


waked1
03-25-2008, 05:34 AM
I'm trying to set up a G5 running 10.5.2 to access shares on a Windows Server 2003 (R2, SP2) server. I can see the shares, mount them and browse them but am having trouble with the write permissions. I tried copying some files to a particular folder which the user has full access to, some worked but some others said I didn't have the necessary permissions. On clicking OK the file disappreared from the target folder. Before clicking OK, I checked the folder on the server and could see the file, with the corresponsing . file. The . one had the correct permsisions but the 'real' one had mucked up permissions with unresolvable users having access (by unresolvable, I mean they had S_123456789 etc as the username, rather than waked1).
I've even bound the machine to AD successfully, but copying still didn't work.
Checked on my other half's MacBook running 10.4.10 and it worked perfectly.
Does anyone know if there are problems with 10.5.x's SMB implementation, and if so is there a fix?
TIA,
Dunc