PDA

View Full Version : Help! My Powerbook G4 Wont Boot!


dave_blakesley
02-12-2008, 11:53 AM
I recently got given a 17 inch 1.67ghz powerbook G4 by a friend, and after a while using i noticed that every 10 minutes or so it would ,'bluescreen' to use the windows term. After this had become predictably irritating i then proceeded to try and repair the tiger installation using the install disks.
After a few attempts the cd booted and immediately declared that there was an error in the tiger installation and that it couldnt repair it. It then proceeded to turn off and i had to open up the firmware to eject the cd. All being good, i tried booting again to see if the cd had broken anything. This time, however, nothing at all happened, it made a few beeps which i must take to be the 'im not working you idiot' beeps before powering off. I did some googling and found lots of references to resetting the PMU which i have done, still to no avail. Before i take it to see an expert can anyone identify the problem for me! I need to get this laptop fixed because i need to use it in school!

dave_blakesley :(

Anti
02-12-2008, 12:14 PM
Funny thing, when I was in High School someone brought their 15'' PB G4 to me which exhibited this same behavior. However, it didn't do it in the morning due to what I assume was the components inside being really cold. Turns out it was a hard drive failure (or failing, I guess). Swapped it out, problem solved.

What I'd suggest doing is trying to grab yourself a FireWire hard drive if available and try booting Tiger off of it. If it boots with no problems, you have your problem: Replace the HDD.

dave_blakesley
02-12-2008, 01:07 PM
cool, thanks a lot, ill try it and see what i get :o