PDA

View Full Version : Leopard SMB sharing shows "Macintosh HD" and user files


lmeurs
12-05-2007, 03:16 PM
Hi there!

I'am fairly new to Mac OS X and am trying to connect my iMac to my pc (Windows XP) through a wireless network. Everything seems to work, but for one thing:

When I log with my PC onto my iMac ('File sharing' enabled, SMB enabled and main and only account selected), all shared folders appear, but 'Macintosh HD' and the user files are accesible aswell!

When logging onto my iMac from an iBook using AFP, only the shared folders are shared.

When I change the userrights on 'Macintosh HD' for 'everybody' from 'Read only' to 'No access', the iMac will not restart properly, I have to run 'Disk utility > Repair permissions' and the changes are unfortunately made undone.

My question: (how) can I disable sharing more than the shared folders?

Any help would be appreciated a lot!

warragul
12-05-2007, 05:45 PM
Take a look here : www.hornware.com/sharepoints/
Sharepoints enables you to select what folders you want to share.

lmeurs
12-05-2007, 06:33 PM
Thanks for the quick reply!

I just visited the SharePoint website and the tool looks great and will probably solve my problem, but most of the functions SharePoint offers are built in in Leopard.

Is it a wellknown fact that AFP reacts differently than SMB? Is the usage of tools like SharePoint a common solution for problems like these?

melon
12-05-2007, 07:03 PM
Sharepoints doesn't work under Leopard although the developer is working on a compatible update: http://www.hornware.com/faq/index.php?qid=23&frommostrecent=yes

lmeurs, you'll have to manually edit the smb.conf file (found in the /private/etc/ folder and /private/var/run/) as that's what Sharepoints does anyway.

Edit: Have a read through this thread: http://discussions.apple.com/thread.jspa?threadID=1247712&tstart=0