View Full Version : Cannot Load User Interface...Please help!

11-29-2002, 11:42 PM
Hi guys,

Ifrst off I think it's proper for me to introduce myself. My name is tim and I am just an Enthusiast. I do audio as a hoby -- music production mainly. I live in New York city but native Eastern European.

Well, I have a major problem. I simply don't know who else to turn to. Well this is my situation:

My Mac won't load the Jaguar. It goes past the boot pannel right before loading the desktop and everything it just dies and remains on the same old blue screen. Well, it all happened last night as I was updating the trial version of FirewalkX. Well, I also have Macupdate (the little menu addon that let's you check their updates on their site) installed, so I just clicked to got heir website sinceit didn't update and when opening Netscape I got the message that My mac needs to be restarted in a few languages. I say it happened during the Firewalkx because the Mac was working perfectly fine before that. I have System OptimizerX loaded also unsanity's WindowShadeX if htat helps...

My set up is:

G4 Duahl 1Ghz (Quicksilver)
1.5Gb Ram
80Gb ATA Drive
18Gb 15k rpm/s scsi 160 with Adaptec PowerDomain38160
OsX 10.2.2 All Automatic Updates

12-02-2002, 12:16 AM
This is from memory so YMMV...;)

Boot to single user mode (hold down the "command" + "s" keys before the boot chime and keep holding them till you boot to a cursor).

(Below is the CLI command to run the built in filesystem check on OS X. )

Type "fsck -y"
hit enter.
Let it run.

Run it again, and again until it reports no errors.

reboot. ( I think you type "exit" or "quit"...it's been a while ;))

(Below are the open firmware commands to reset the machine to it's default settings.)

Next Boot into open firmware (hold down the "command" + "option" + "O" + "F" keys before the boot chime and keep holding them till you boot to a cursor).

type "reset-nvram"
hit enter
type "reset-all"
hit enter

You should reboot at this point.

Let us know what happens. :)

(the OF commands are case and "space" sensitive. type them as above in lower case with no spaces between the "-" and the characters.)

12-02-2002, 12:19 PM
Hi Milhouse,

First off: THank you very much for the reply. I am defiantely archiving these commands and instructions.

Well, I desperately needed the Jag running so I went around the whole thing a different way:

I have no experience with UNIX (some scripting but a long time ago and have forgotten everything ) so what I did was thins. I booted from the Jag CD and reset the passwords for all accounts on the machine (two at the time), which killed the autolog option for the original account on the machine. Then logged in as root and created a new administrative account. After that I booted into the new account and it worked fine. After that was just a matter of moving preferences from old account to the new one. I tried to go back into my original accoutn and still no luck same scenario so I just deleted the user account. Well, if it has happened once it will probably happen again so I am very thankfull for your reply since I might have to actually refer to it :).

Best Rgrds,