PDA

View Full Version : iTunes - gaps between tracks with crossfading set to zero


paulio
01-21-2002, 12:56 PM
This is a contunuation of this topic from from Mac OSX Hints:
Enable continuous music playback in iTunes2 (http://www.macosxhints.com/article.php?story=20020116002112531).

The problem is that Setting crossfading to zero leaves a very short gap between tracks. To set this, select Preferences -> Effects -> Crossfade Playback, and move the slider to "0" or turn it off completely.

You will probably never notice this problem unless you listen to certain types of music: techno, house, ambient, or dance music. If you listen only to rock, then you will almost never hear this problem. This is because techno has a specific requirement that other music does not have. Techno requires that tracks play contunuously without a break in between, so that the transition from one track to the next is completely inaudable.

Turning on crossfading would be the obvious solution but crossfading on is NOT an option with techno. Crossfading only masks the gaps by making tracks overlap in time. This causes a problem with techno. Techno has a second requirement that other music does not have. Techno tracks must not only play without a break in between, but they must also sync up exactly so that the beat of the first song continues unterrupted into the next.

I can't find any solution to this problem using iTunes. Audion has the same problem of gaps between songs, only worse. Does anybody know of an MP3 player that is able to play MP3s continuously without using crossfading?

Thanks.

If you don't listen to techno, it might be helpful to get an example of a rock CD that allows you to hear the gaps. Get Pink Floyd's Dark Side of the Moon or Wish You Were Here. Listen to the CD on a regular CD player. Note that the tracks run together such that you do not notice the end of one track and the beginning of the next.

Create MP3s from the entire CD. An individual MP3 will be created for each track. Play the tracks in their original order using iTunes. Be sure that crossfading in turned OFF under iTunes | Preferences | Effects. You will be able to hear the gaps between tracks as long as the gaps occur with music that is not too quiet.

I'm sorry, but can't think of an example on a rock CD that would let you hear the beats skip when crossfading is turned on. You will have to listen to a house or techno compilation, or just trust me on this one.

Benad
01-21-2002, 03:58 PM
Or you can always use QuickTime Pro and do several copy-paste in a single AIFF file... The file will be BIG, but it should work! :)

- Benad

zs
01-21-2002, 04:10 PM
I remember seeing something online about the gaps between tracks. I think it has something to do with a limitation of the MP3 format, not the players.

If I can find any links, I'll post.

lerkfish
01-21-2002, 08:14 PM
...I discovered accidentally when making a CD of my toddler's favorite bedtime songs from a cassette via spindoctor and external input into my G4.
If you do not pause the recording, the entire cassette side will record as one track, complete with the factory fades or gaps.
If you have a techno CD that has such tight requirements, you might try recording to Cassette first, or running directly from your home stereo CD through spindoctor to make the entire CD one track, thus preserving the proper gaps.

kungfumath
05-28-2005, 09:07 PM
While I don't want to completely contradict zs (could be correct), I believe the issue is with the players. When crossfading is enabled the player must open the next song while the current song is playing so that it can fade out the current song while fading in the next song. Without crossfading on, the software simply closes one file, then opens the next, leaving a small gap in sound on even the fastest computers.

Being a modest programmer myself, I would recognize that a crossfading time of zero would be the same as turning of the feature and would have programmed that into the software. Ordinarily, my suggestion would be to set the crossing time to a small fraction of a second. The trouble is that iTunes will only allow integer increments in the crossfade (which seems ludicrous to me).

I like to listen to movie score and other symphonic and operatic music as well as techno and rock, so I understand the frustration. Unfortunately, I don't believe our esteemed iTunes-crossfader programmer does, and so he wouldn't think of a way to solve the problem. I have to just put up with it. Perhaps you could send some product feedback Apple's way about our problem. I'll do what I can.

MBHockey
05-28-2005, 09:31 PM
...I discovered accidentally when making a CD of my toddler's favorite bedtime songs from a cassette via spindoctor and external input into my G4.
If you do not pause the recording, the entire cassette side will record as one track, complete with the factory fades or gaps.
If you have a techno CD that has such tight requirements, you might try recording to Cassette first, or running directly from your home stereo CD through spindoctor to make the entire CD one track, thus preserving the proper gaps.

Wouldn't this be equivalent to ripping as the 'Join Tracks' option (assuming you join all tracks) in iTunes, but a lot less hassle?