PDA

View Full Version : Loss of AFP Access to Network Disk (LaCie Ethernet disk)


EatsWithFingers
01-13-2006, 06:16 AM
Apologies for the long post... :o

I recently bought an ethernet disk (LaCie Ethernet Disk Mini 250GB) to use for storing my music in uncompressed AIFF format. The plan was to connect it to the ethernet port of my Airport Express, and access the files over the wireless network with my laptop, and have iTunes send the audio to my Hi-Fi via AirTunes. I don't have any internet access at the moment, so this arrangement suffices.

This setup works now, but it took me a while to get it working. Because of this, most of my music was transferred to the disk via its USB connection. Additionally, I made the mistake of deleting all the files beginning with "._" -- which I now know are the resource forks of their respective files (The disk is formatted as a FAT32 drive so that it can be used by PCs and Macs).

The downside to the FAT32 formatting is the file name length restriction (27 or 31 chars max - I forget which it is). However, I never had any problems putting files with longer names on it via USB, or via AFP for that matter (which I'm still kinda puzzled by...)

The problem is that, for some reason, I am no longer able to connect to the disk using the AFP protocol (http, ftp, and smb all work fine). The disk now appears to have AFP access disabled by default, although even when I turn it on, I still cannot access the drive via AFP.

For now, I use the smb protocol, but there is still a serious problem with AFP access:

If I try to connect to the disk via AFP (using the Finder's 'Conenct to Server...'), the username/password dialog appears, but upon entering my details and hitting 'connect', the Finder hangs indefinitely. The only way to regain control of the Finder is to restart the ethernet disk, at which point the 'Choose share to mount...' dialog appears with no shares present (this dialog should appear straight after the user authentication, and contain one share corresponding to the disk).

The logs of the disk appear to show that a successful connection has been made to it, although the Finder does not seem to realise this.


The AFP access problem occurred when I was converting an Apple Lossless audio file to AIFF with both files on the ethernet disk. By this point, I had already converted ALL my AIFF files to AAC (where the AAC files are on my laptop), so I don't think that file names are to blame. Additionally, using smb access, converting Apple Lossless to AIFF still causes the disk's OS to crash occasionally.

The obvious course of action - to wipe the disk and start again - is not something I want to do, as I cannot copy its contents to another location (due to lack of space), and it took me the best part of a weekend to put all my music on it.

I wanted to know if the problems that I am experiencing (the loss of AFP access, the Finder hanging, the occasional crashes) are likely to be caused by the LaCie disk, the Finder, iTunes, or something else.

Any help would be greatly appreciated.

giskard22
01-13-2006, 05:13 PM
Have you restarted the computer you're using? You could also try creating a fresh user and connecting. There shouldn't be anything in your home folder that's causing a problem, but you never know.

If the device itself keeps crashing, I think you should be talking with LaCie about a replacement.

EatsWithFingers
01-16-2006, 07:58 AM
Yeah, I've restarted everything - my computer, the Airport Express, the LaCie hard drive - but still no progress...

Also tried with a completely new user, but this didn't work either.

I've contacted LaCie, but have yet to get a response - not that I was expecting one this soon.

Carthag
05-14-2006, 08:04 PM
I have the exact same problem. Did you ever find a solution?

muserna
10-25-2006, 09:32 PM
I'm also in the middle of figuring out all this Lacie, Fat32, AFP, SMB stuff these days...

.. One thing I know for sure, if you want to check the status of your AFP access, you should goto the administration panel on the Lacie drive via HTTP. There you can check to see if the AFP service is ENABLED. Check that out and let us know what you find. It maybe be as simple as that.:cool:

Carthag
11-07-2006, 02:31 PM
I found this on LaCie's website:

http://www.lacie.com/support/faq/faq.htm?faqid=10299

So it appears we have to update our firmware. Mine'll have to wait though as I have nowhere to put the stuff currently on the HD. :P

kloodge
11-28-2006, 11:47 AM
I had the same problem and resolved it by deleting and recreating the share.

You can do this from the Lacie web interface or directly on the system.

You can attach a monitor/keyboard/mouse to the Lacie or use the Windows Remote Desktop client to get access to the system directly.

Once connected use Ctrl-Alt-Del (Ctrl-Alt-End in Remote Desktop) to bring up the Task Manager. Click on the User tab and then File > Run... then type compmgmt.msc. This will bring up the computer managment console to allow you to directly access shares.

You can also run explorer.exe to directly access the share folders to copy files from one share to the other if you need to.

drowlflood
01-11-2007, 03:45 AM
I also experienced this problem, but don't have the option of rebuilding the share as I need to extract the information from the drive first.

When I connect to the share via SMB over ethernet (because the USB doesn't want to connect either..) and copy the files to my HD, it looks like the data/resource forks either aren't copied or aren't being correctly re-associated with my files, making some of them un-launchable. :mad:

Given the limitations of my setup, is there a way to copy the "raw" data - including the ".AppleDouble" and "._" files created for FAT32 compatibility - to my HD?

And once I have the raw data, is there a program or set of commands I can run to correctly re-join/rewrite the forks and files in HFS+ format?

scotts
11-12-2007, 05:37 PM
I too got bitten by this. I inadvertently pulled the plug rather than shut it down. The next time I tried to connect via AFP, it would just sit there and the volume would never show up. :mad:

I too could not figure anyway to recover any of the files that had resource forks. Those files where lost.

What kills me is that I bought this as a reliable back up device and now have lost files forever.

I have since reformated the machine and upgrade the firmware to the 2.0 version. It seems to be working correctly now but what I think I will do is the following. Whenver I upload a file, I will compress it using Stuffit X format which will save the file as a binary on the machine. This way, if AFP ever fails again, I will still be able to extract the file and then decompress it.

vincifr
01-07-2010, 10:57 AM
I have found a solution, i am going to test it, here:
http://www.burchwords.com/archives/99

vincifr
01-07-2010, 11:21 AM
i hade the same annoying problem with lacie and AFP not working anymore;
after trying a lot, no luck, i found directions:

1- Stop the Apple server (AFP):
Connect to the EDmini’s administration web page and go to the “Status” tab. From there, “disable” the “Apple Server” (i.e. AFP protocol)
2- Start the FTP client
3- Connect the FTP client to the EDmini
4- Once, you have connected to the ftp share you will be in the directory of “/”. You will need to changed directory to a hidden folder called “share“. (The LaCie Support tech did NOT provide this information).Once you are in the share directory you will need to Go to the ‘.AppleDB‘ folder which is also hidden.
Command will look like this:
“cd share/.AppleDB”
5 – Delete all the content of the ‘.AppleDB’ folder.
6 – Restart the Apple server (AFP):
Connect to the EDmini’s administration web page and go to the “Status” tab. From there, “enable” the Apple Server (i.e. AFP)
:)

Where i found these instructions, they also said:
One more phase before you are complete ready to go. Now you need to reset the NAS server back to factory settings. You will NOT lose your data. This has been tested.
:confused:
i didn't do this, but my afp connection was working flawlessy again :D

sorry for my poor english! i hope i have helped, bye!

kestudi
11-06-2010, 04:29 PM
5 – Delete all the content of the ‘.AppleDB’ folder.


I had a similar problem. I was messing with AFP/SMB, added deleted some user accounts, changed the TimeMachine backup location... In short, I'm not sure exactly what I did to mess it up :), but my Lacie NetworkSpace2 drive in Finder's "shared" section refused to connect.

Deleted the AppleDB contents on all shares, and now Finder connects flawlessly! Thanks for posting a solution!