PDA

View Full Version : problem with Xcode 2.2 and g77


jbmelby
12-14-2005, 02:30 PM
I am running OS 10.4.3 and g77 with fink (package manager version 0.24.10, distribution version 0.8.0.rsync). When I have Xcode 2.1 installed, the command

g77 pass1.f -o song

results in a correct compilation of the Fortran program pass1.f.

However, if I install Xcode 2.2 and issue that command, I get

/usr/bin/ld: can't open: /usr/lib/gcc/powerpc-apple-darwin8/4.0.0/libgcc.a (No such file or directory, errno = 2)
collect2: ld returned 1 exit status

Does anyone have any idea why this does not work with Xcode 2.2? I haven't found any information that explains it, and I'd be very grateful if someone can shed some insight on this.

dmacks
12-14-2005, 02:50 PM
You don't say what version of fink's g77 package you are using. There was a bug like you describe in previous versions, but it was reported to be fixed in 3.4.3-12.

jbmelby
12-14-2005, 03:05 PM
It's g77 3.4.3-2 (not 3.4.3-12), which fink says is the current version.

dmacks
12-14-2005, 03:34 PM
It is perhaps the most recent version your fink can see, but it is not the most recent version.Here is the official word on all currently-available versions of g77 (http://pdb.finkproject.org/pdb/package.php/g77)

You are probably running the binary-only or stable trees. You'd need to enable the unstable tree and then selfupdate to get the latest package descriptions.

jbmelby
12-14-2005, 03:59 PM
Thanks. I'm updating everything now, and I'll see if it works.

jbmelby
12-14-2005, 06:31 PM
Thanks. I did what you suggested and it solved the problem.

sportillo
05-10-2006, 08:15 AM
Hi everybody,

I'm very very new to all this but I need to compile some Fortran code for a scientific work at university while I alway encounter the same Problem as mentioned above. Unfortunately I don't even know what the following means:
You'd need to enable the unstable tree and then selfupdate to get the latest package descriptions.

How can I enable the unstable tree and selfupdate with the finkcommander?:o

It would be great if somebody could help me out!

Thanx al lot in advance,

Regards,

Sebastian

hayne
05-10-2006, 11:17 AM
How can I enable the unstable tree and selfupdate with the finkcommander?
I'm not sure whether you can do this with Fink Commander.
You may need to do it via the Fink textual commands in a Terminal window. Read the Fink FAQ.

wgscott
05-11-2006, 03:13 PM
How can I enable the unstable tree and selfupdate with the finkcommander?


To enable the unstable tree, issue the following command:


sudo perl -pi -e 's| local/bootstrap | local/bootstrap unstable/main unstable/crypto |g' /sw/etc/fink.conf


Then do a selfupdate:


fink selfupdate