PDA

View Full Version : Salvaging a misbehaving iPod


eridium
08-03-2005, 10:12 PM
I have a 3G iPod that's been getting a folder with exclamation mark. It's out of warranty and, having a Mini, I don't care to spend money to have it repaired. But I would like to try what's possible to revive it. The obvious solutions have been tried. Namely iPod restore and update.

Something strange about it: the partition appears in Disk Utility as a 5.97GB Firewire drive. But it's in fact a 15GB iPod. It can't be partitioned normally as it gets a "Invalid argument" error. Partitioning using Unix file system gets a "Partition failed with the error: Unknown error: -5349". Strangely, partitioning as MS-DOS works, it mounts, but then iPod Restore doesn't work:
"The iPod disk does not have the correct structure."

It will mount:
Mount Point : /Volumes/HPND Capacity : 6.0 GB (6,410,232,320 Bytes)
Format : MS-DOS File System (FAT32) Available : 5.8 GB (6,263,386,112 Bytes)
Owners Enabled : No Used : 276.0 KB (282,624 Bytes)
Number of Folders : 0 Number of Files : 0

At the command line (in this case renamed "lucia"):
Trinity:~ eridium$ mount
/dev/disk0s10 on / (local, journaled)
devfs on /dev (local)
fdesc on /dev (union)
<volfs> on /.vol
automount -nsl [151] on /Network (automounted)
automount -fstab [180] on /automount/Servers (automounted)
automount -static [180] on /automount/static (automounted)
/dev/disk1s1 on /Volumes/Lucia (local, nodev, nosuid)

Trinity:~ eridium$ sudo dd if=/dev/zero of=/dev/disk1s1
dd: /dev/disk1s1: Resource busy

Anything I try at the command line gets a Resource busy:

Trinity:~ eridium$ pdisk /dev/disk1s1 -dump
pdisk: can't open file '/dev/disk1s1' (Resource busy)
Top level command (? for help): e /dev/disk1s1
pdisk: can't open file '/dev/disk1s1' (Resource busy)

Is there some other life-saving defibrillator shock I can perform on this iPod? I don't mind if it's risky as there's nothing to lose. Thanks

Caius
08-03-2005, 10:56 PM
See my (rather comprehensive) post here (http://forums.macosxhints.com/showpost.php?p=225035&postcount=7) (from this topic (http://forums.macosxhints.com/showthread.php?t=41192))

Hope that helps!

[Edit] Woa, I just re-read your post and realised you've tried what I said in my other post already.

Pull the iPod out (thats right, without ejecting it) or shut the mac down then d/c it.

Force reset the iPod by holding menu and select. Then force the iPod into disk mode by either going to the diagnostics screen (hold previous track and select) or by holding select and play when the apple logo appears after resetting.

Once you have it in disk mode, plug it in and run dd on it like you were trying to before.