PDA

View Full Version : 10.4 Server - no home directories


troutstudio
07-02-2005, 12:13 AM
I did a clean install of 10.4 on a new xServe. I created a new shared folder (AFP), set it to host home directories and also to have a Network Mount Point. When I create a new user and set his home to the new share and hit create home now and Save - nothing happens. I have run Disk First Aid (repair perms) did a restart, run fsck etc. Nothing. I tried createhomedir - terminal shows me the home folder is created - but it isn't. Using the Records Inspector shows me that the share has no records - in fact, even the default shares have no records. The server has a mount record. The DNS files are hosted elsewhere and I get a good reverse look up. I have done this many times in 10.3 on an older machine. I can BIND to the server, but of course get the 'Home Folder Not In Usual Place etc' error- of course, since their isn't one. I tried 3 installs with the same result. FQDN seems fine - when I log in to WGM as the IP address I see the FQDN in the name of the server. I am totally confused by this. I was sent media with a bad serial and I am wondering about - well - everything. I'd love some clues please. Thank you.

mac_man_luke
07-02-2005, 08:51 AM
Are you definatly adding the users to the directory not the local machine?

troutstudio
07-02-2005, 12:04 PM
I am authenticated as root to /LDAPv3/127.0.0.1. Also in the Sharing section of WGM, that isn't really a feature (although I guess you can show local records with the Records Inspector?) As I said, even the default shares (Users, Public, Shared) have no records. Something I didn't mention is that the server won't boot from the DVD installer, but does boot from the CD - which I have been told is sometimes a symptom of bad ram. I should say too that I've set up 10.3 with more than 300 users before - just never ab xServe or Tiger . . .

giskard22
07-02-2005, 09:21 PM
You said you did a clean install. Have you run available updates? 10.4.1 is out, though I don't know if it has anything to do with this issue.

troutstudio
07-06-2005, 02:44 AM
Thanks for your reply. It appears that any time this happens (apart from when you use a tool to import users) - that problems of this kind are always DNS related. And so it was with this one. The original issue was clouded by bad serial numbers; corrupt DVD's and some fairly apalling support from Apple Australia; but the crux of the issue is that after I re-installed 10.4 as a standalone server; then ran DNS and OD; everything worked. The zone files I was using for lookup records (supplied by another server) work with 10.3; and appear not to in 10.4. As these files are supplied to many schools in NSW Australia, this is a problem. But I need to do more research before I can say where the problem lies exactly. Thanks for your interest.