PDA

View Full Version : Excel: Unable to read file


besttb
05-24-2005, 12:36 PM
OSX 10.3.8
G4 15"
Excel For MAC

I have been using a spreadsheet file for a couple years that is 980KB that will no longer open. I tried updating to 10.3.9 which did not alleviate the issue.

I tried to open on a PC and the error directed me to Microsofts web site KB article Q213879. It says its an Unexpected file Lock. Is there a way for me to get into this file and unlock it? Perhaps through vi or something? Anyone else have this problem?

This is the only file that has ever been corrupted on my system - it there something wrong with my system? A defrag maybe? I looked at apple's site and they did not advise defrags.

Thanks for your help!

T

Raven
05-24-2005, 01:02 PM
Do you most of the time simply use the command+s option to save ? or just that ? What happens in those cases is that only the changes to the file get saved... and thats not the most reliable thing... Best ist o do a "Save As" every 4-5 time you need to save, and always end a session with the Save As
Thats for the explanation on the possible reason why this happened... Now to help find a solution, it would be best if you posted the exact error message you are getting, both on the Mac and on the PC (error number too !)

besttb
05-24-2005, 01:22 PM
The error message is an Excel error and reads:

Unable to read file.

<button>'OK' </button> <button>'Web Info'</button>

The web info button takes me to this link:
http://support.microsoft.com/kb/q213879/

I will have to send the MAC error later but it is the same thing without the web info button. Once I press ok, the file does not open and excel opens without a problem.

The MS article is where it looks like the file has been locked somehow...

thanks for your help!

hayne
05-24-2005, 01:25 PM
When was the last time you could open this file?
Do you have a backup copy? It's quite possible that the problem is merely that the file has become corrupted somehow.

besttb
05-24-2005, 02:35 PM
I agree and am dreading that it is simply corrupted :( - it has a lot of historical data that is irreplacable. My backup is old so if I can somehow recover it I'd like to give it a try :confused: ...

T

Raven
05-24-2005, 02:44 PM
Thats why I'm asking for the error mesages... It may help...
Otherwise your alternative may have to be: http://officerecovery.com/ [*PC Only though*]

besttb
05-24-2005, 03:10 PM
I thought I did send error messages. As I look through the thread something must have happened when I posted it... Anyway I tried the demo of office recovery and it worked, now I need to buy it. Do you know if anyone makes such a thing for OSX?

pc Error messages:

Unable to read file.
'OK' 'Web Info'

Under web info it takes me to this link:
http://support.microsoft.com/kb/q213879/

Its the same thing on my MAC without the 'Web Info' button.

Thanks!
T

Raven
05-24-2005, 03:13 PM
I've personally never seen a Mac equivalent... even though I always have hoped for it...

hayne
05-24-2005, 03:58 PM
You could try some of the 3rd-party utilities that can read Excel files and convert them into other formats. E.g. the utilities for getting Excel docs onto your Palm, Open Office, etc.

bilbo--baggins
10-23-2005, 03:52 PM
I have a file that I've been working on since April, and last week suddenly I got the message "Unable to read file" after entering my password.

I tried various things, repair permissions, disk utility (Apple's), and in the end I had to resort to a backup from DVD that was a couple of weeks old.

So, after a bit of time going through updating the file getting things back to how they should be (how they were in the latest version) everything was ok. The file opened fine, and saved fine.

Now, a week later I'm getting exactly the same problem. Unable to read file. The odd thing - same as last week - none of my backups work either, including the backup that Excel creates.

I have no idea what's causing it. Nothing else on my system is giving me problems at the moment. I don't have any antivirus software (as I don't trust them not to screw up my files). I have Deja Vu set to do automatic backups to my second hard drive every night.

Please help!

I'm currently downloading Openoffice as I found a suggestion elsewhere that this might be able to open the file!

I'm using the latest version of Microsoft Office for Mac OS X. (11.2?)

bilbo--baggins
10-23-2005, 04:28 PM
One more thing: I cannot open the file in OpenOffice or ThinkFree Office (it says it's because it's password encrypted) and Powerpoint won't open it either.

Why would this happen twice to the same file. I don't get it.

bilbo--baggins
10-25-2005, 04:58 PM
It seems this issue is with Excel files containing Pivot Tables becoming corrupt. Excel 2003 for Windows has the option of 'Open and Repair' (with Excel 2004 for Mac doesn't have) which repairs the file successfully and gives a report of the problem with the pivot tables.

If only Microsoft would provide the repair facility in the Mac version.

I have downloaded the Office 2003 demo into Virtual PC and can open the file with that, but unfortunately it doesn't allow you to save the repaired file (because its a demo). However I presume I will be able to copy and paste the data into Mac Excel.

bilbo--baggins
11-01-2005, 01:51 AM
I still haven't got this fixed. Excel 2003 for Windows has the repair function, but apart from trying it in the demo version in Virtual PC, I haven't found anyone with Excel 2003 for Windows who can repair the file for me.

Oddly, when I go into Excel, and choose Help:Send feedback on Excel, it takes me to Microsofts web site but doesn't provide any means of sending feedback (apart from a Postal address and a premium rate telephone number).

Unfortunately the file contains all of my confidential financial information, so it's also awkward emailing the file to someone else to repair it.

It's a real shame microsofts software is so buggy, and an even bigger shame that there isn't a viable alternative (I've tried AppleWorks and it doesn't have many of the spreadsheet features that I use).

cwtnospam
11-01-2005, 06:32 AM
You could try copy & paste. First repair the file in the demo, then select the whole sheet and copy. Next, switch to Mac Excel and paste. Then save the file under two different names so you have a backup.

bilbo--baggins
11-01-2005, 04:52 PM
You could try copy & paste. First repair the file in the demo, then select the whole sheet and copy. Next, switch to Mac Excel and paste. Then save the file under two different names so you have a backup.

Yes, that's probably going to be my only option. I'll also have to work out the simplest way of transferring the Macros and setting up buttons for them etc, so it's not going to be a simple task unfortunately.

Bloody microsoft...

bilbo--baggins
04-09-2006, 11:43 AM
Just found that my main financial records for the previous year have done the same thing.

Give me another spreadsheet and I will willing bin Excel and pay for a rival. Simple as that. I just cannot trust excel any more.

Last time I had to install Virtual PC, install a demo of Excel for Windows, and use it's built in repair facility.

Microsoft drives me nuts. Worst software on the planet.

I'm sure the Inland Revenue will love it when I say, sorry, I don't have any financial records because Excel ****ed them up.

tamnospam
04-17-2006, 11:50 AM
I have an annoying little issue with excel, altho not as serious as above. Every time I open Excel I get a message thats says "filename.doc: file format is not valid." I hit OK, and it goes away. But I have to OK through about 5-6 of these before I can start anything in excel. The file is a word doc I recently saved. It's not preventing me from using the program, just an annoying thing I'd like to go away. Anyone have any ideas? Thanks

tbsingleton73
04-17-2006, 11:58 AM
Sorry, why are you trying to open a Word document in Excel? Why are you not using Work to open a Word document?
Try opening filename.doc in Word.

tamnospam
04-17-2006, 12:14 PM
I am not tryin to open a word doc in excel, excel THINKS I am. All I want to do is open excel, and get going, but it keeps giving me those message windows. I don't know how to make those messages stop.

tbsingleton73
04-17-2006, 12:19 PM
Are you trying to open excel with the App shortcut or by opening an Excel file?

If by file, use command+I to "get info" on the excel file and see if the "open with" has Word selected, if so change to Excel and click the "change all" button.

tamnospam
04-17-2006, 12:25 PM
I am opening excel with the dock icon. I did commnand I on those files that I get the messages about, and each says it will open with word. Each one of those IS a word doc, and I wan them to remain word docs. For some reason excel thinks it has to try and open them.

tamnospam
04-17-2006, 12:42 PM
I am using the excel icon in the dock. Even if start excel by clicking on any excel file, it still shows all those invalid file format message windows when the excel starts up. command I has "open with word" for those files in question...which it should do since they ARE word files. For some reason excel wants to open them upon start up.

tbsingleton73
04-17-2006, 12:44 PM
Does starting Word and opening a .doc file from Word make any difference?

Have you tried rebooting?
Create new user? Does issue continue there too?

tamnospam
04-17-2006, 01:24 PM
First apologies for posting twice- still learning the forum...
Word works just fine. Rebooting makes no diff either. New user, haven't tried that yet. It's only a few specific word docs that excel tries to open, not all of them. Must be some common denominator with THOSE particular files.

tbsingleton73
04-17-2006, 01:51 PM
If these files do not contain private info you could post them here to see if we have issues opening them.

tamnospam
04-17-2006, 01:56 PM
eeeggh...unfortunately everyone of them does have confidential info. Any other ideas??

tbsingleton73
04-17-2006, 02:10 PM
Create a new user account and try opening the file there to see what happens.

tamnospam
04-17-2006, 02:23 PM
Doesn't happen with new user. Seems OK with a fresh start.

cwtnospam
04-17-2006, 03:17 PM
You might have a Macro virus. Look for the normal.dot file and see if it was modified recently.

tamnospam
04-18-2006, 03:09 AM
I cannot fiind normal.dot . I searched using command f. IUs there another way to find it? What is a macro virus anyway? Thanks

cwtnospam
04-18-2006, 06:59 AM
Look in the Templates folder inside the Microsoft Office folder for a file called "Normal.dot"

It's a long shot, since you say that it isn't happening with a new user, but it's still possible that you have a macro virus. Macros are scripts that run in Microsoft Office applications. Since the macros can run on any platform that runs Office, macro viruses are platform independent, to a degree. Virus writers have taken advantage of Office in the past, but not so much any more since Microsoft got around to turning off Macros by default.

hayne
04-18-2006, 09:45 AM
Doesn't happen with new user. Seems OK with a fresh start.

Please clarify your current situation. Does your "seems ok" indicate that there is no longer a problem?

tamnospam
04-18-2006, 10:12 AM
The problem (invalid file format message windows upon opening excel) still exists with MY account, it does not occur with a new user account. I found the normal file, and it appears it was modified recently. What do you suggest I do next? This little problem doesn't prevent me from using excel, it's just an annoting little thing I'd like to get rid of. Of course, I'd like to understand WHY it's occuring. Always like learning new stuff about how my computer works. Thanks

cwtnospam
04-18-2006, 12:43 PM
Since that file isn't normally modified unless by a macro, there is a good chance you've got a macro virus. I suggest that you download ClamXav, update the virus definitions, then scan all Microsoft Office files on your system. That includes everything in the Microsoft Office folder as well as all your documents.

http://www.macupdate.com/info.php/id/15850

Edit: That you're getting the error makes sense in a way. If you do have a macro virus, it's probably trying to do something that would work in Windows, but for some reason doesn't on the Mac.

tamnospam
04-18-2006, 12:53 PM
No viruses found with ClamXav. Hmph.

cwtnospam
04-18-2006, 12:59 PM
It could be a legitimate macro that's got a bug. Try removing the normal.dot file. You can just drop it on your desktop if you don't want to delete it. A new one will be recreated when you open Office.

tamnospam
04-18-2006, 01:08 PM
I dragged the normal.dot file to the desktop. Opened excel and the same message windows pop up ( same 4 files every time)

cwtnospam
04-18-2006, 01:28 PM
After you open the file, if you go to Tools:Macro:Macros... in Excel, do any macros show up in the resulting window?

hayne
04-18-2006, 05:01 PM
Since this problem is so specific, you should be able to track down what is causing it. But in case you get desperate, I give you my generic procedure for solving user-specific problems.
-----------------------------------------

You have determined that the problem is only with the one user account.
The problem thus is almost certainly due to something under your home folder.
And it likely is something under ~/Library
( ~ = your home folder)
The most likely thing is a bad preference file under ~/Library/Preferences
You could start by removing the preference files for the apps you are having trouble with.
If the problem persists, you need to narrow the problem down - you could start by moving (via drag & drop) the whole "Preferences" folder that is under ~/Library to the Desktop, then log out and log in again. A default copy of the Preferences folder will have been recreated. Does that improve things? If so, you could use a divide & conquer approach to figure out which of the preference files is causing the problem - move half of the preference files back into the Preferences folder, log out & in again, etc.

If the problem persists, try the same thing with the other sub-folders of ~/Library. E.g. with ~/Library/Caches, ~/Library/InputManagers, ~/Library/Fonts, ~/Library/PreferencePanes, ~/Library/Application Support, ~/Library/Application Enhancers, contents of ~/Desktop, etc.
Also remove any files owned by your user in /Library/Caches (the Library folder at the top-level of the drive)

tamnospam
04-19-2006, 11:56 AM
I trashed the file named "excel setttings" in library/preferences/excel, and that did the trick. Thank you!