PDA

View Full Version : Userdir for AD users.


donlaur
04-27-2005, 03:08 PM
Hello,
I have many local users that were created before I set my OS X Server (10.3.8) to bind to the Active Directory.

The local user accounts, created in Workgroup Manager, for example billsmith, was created before I bound the AD. The user can login using AFP and it goes to their home directory. The website at http://www.website.com/~billsmith/ works fine.

However, now we have AD users they can login via AFP using their campus network ID. But they have no home directory. For example the user bsmith is a campus network user and has an AD account. So I copy the user template over and create their directory and set the permissions on the folder. Everything is fine until they want a website. then http://www.website.com/~bsmith doesn't work.

Looking at the Apache log for this website I get the following.
To make them both show up I try to go to a fake html page of testy.php.

The local user requests this...
[27/Apr/2005:14:47:58 -0500] "GET /~billsmith/testy.php HTTP/1.1" 404 -

and the error for the local user is this ...
[Wed Apr 27 14:47:58 2005] [error] File does not exist: /Volumes/xraid1/Users/billsmith/Sites/testy.php
----------------------------------------------------------------------------
While the AD user requests this...
[27/Apr/2005:14:48:57 -0500] "GET /~dlaur/testy.php HTTP/1.1" 404 -

and the error for the AD user is this ...
[Wed Apr 27 14:48:57 2005] [error] File does not exist: /Sites/testy.php

So, it appears that the AD user is trying to access the /Sites folder while the local user is accessing the /Volumes/xraid1/Users/username/Sites folder.

I have been told that the userdir mod should work fine for this. The Users share is on a different directory, on the XRAID drive.

What would be the best way to correct this?

Thanks.

My goal is to get rid of the local users and let the campus mess with usernames and passwords.

Please email at donlaur@mac.com if you want.