PDA

View Full Version : Repairing System Folders from OSx to OS9(target disc mode)


dae_woo
03-09-2005, 07:08 PM
Not an entirely OSx system problem, but hoping someone may be able to help me nonetheless.

I've been using a PowerMac G4. OS 9.2.1 which has just come up with, what it seems is an all to common problem... the flashing question mark on boot.

I hooked it up to my i-book G3 in target disc mode and could not access the hard drive at first. Used diskGuardian to do some repairs, and then gained access to the hard drive. All well and good. Can now see all the files.

It still won't boot up.

I've tried the P-RAM zapping; holding command on boot, selecting the volume etc, but to no avail.

I have tried booting from the software restore CDs, but they only offer me the option of erasing the volume and starting again. Which I can't do, as I haven't got enough space on the I-book to back up the G4s files. I'm wondering if there is a way of reinstalling/ or replacing the system files through target disc mode as I have no way of accessing the G4s HD from the G4 itself.

Thought there might have been a way, using my i-books restore CDs to reinstall OS 9 system drivers, unfortunately i am in france and I have left the CDs in england. Ooops.

Any ideas anyone.

Thanks in advance.

p.s. addition to first post. sorry didn't mention this earlier either. Don't know if this is nescessarily a system folder problem.
That is just what I seem to have learnt about the situation from other help pages. All I can really say is that
1) with Cmd held down on boot, I can see the HD image with a smiling OS9 icon. If i select it and click the 'next' arrow I just return to the flashing '?' over the floppy disc.
2)I can see all the intact files through target disc mode.

voldenuit
03-09-2005, 07:47 PM
If you have a known good System folder recent enough to boot the G4, you can just copy it over and give it another try.

dae_woo
03-09-2005, 08:39 PM
Just tried that, no result. Zapped the PRAM after just in case it's looking somewhere else. No beans.

Used System from my G3, which is 9.2 version though i think. Have also tried with System from restore CD.... nothing.

Cheers anyway for the tip. Will welcome any more.

Forgot to mention earlier, don't know if it's important. My i-books english, G4 is french. Will that cause problems?