PDA

View Full Version : Constant app crashes > KERN_INVALID_ADDRESS


bluehz
06-17-2002, 10:51 PM
Starting about 2 days ago a large majority of my applications are crashing. Not always the same one, and sometimes they don't "Unexepectedly Quit" until you actually QUIT them anyway. Perusing the crash logs - every one of them has this as the crash msg:

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0x2d480000

This is getting to be a major problem! I posted on the Apple boards and no one has responded. Saw other posts regarding this issue - but no one has a solution and the closest thing to a suggestion for a fix is to clear out the font cache - which I did. I have also run a complete Disk Warrior on the drive and it is still occuring.

Can anyone offer any suggestion of any kind what might be causing this issue? This is the first real problem I have had with OS X in a year, and it really stink - very OS 9 deja vu!

Mac G4/400 (AGP)
1.2G RAM
OS X 10.1.5

bassi
06-18-2002, 03:22 AM
Apps like Omniweb, Mozilla and Carracho have also crashed with the similar log you've displayed, I've searched around for the last two weeks and found no answer. Good luck!

vonleigh
06-18-2002, 05:22 AM
Hello,

I don't know what a KERN_INVALID_ADDRESS is, but from what I gathered on the web, it shows up when a memory address is invalid.

So one posibility is that you have bad ram if it happens continually. Do you have techtool or some utility that tests ram? (I'm assuming techtool tests ram).

Do you have another partition with OS X that you can boot from? That would rule out software. I keep a small 5GB vanilla partition just in case; if I need anything stock I can just copy it over.


Vonleigh

bluehz
06-18-2002, 08:34 AM
Everyone is suggesting RAM...I have not installed or moved any RAM on over a year and this week is the first sign of a problem. I doubt RAM would "go bad" but I may be wrong.

Bassi - have you installed any new RAM recently or moved RAM, etc?

theRegent
06-20-2002, 02:03 PM
You're right, it's not very likely for RAM to just turn sour, but even if you haven't moved the machine, it's certainly not impossible for it to become unseated. Temperature changes, air pressure shifts, etc. etc. etc. (The realm of the unexplainable is infinite.)

Anyhoo, you might just save yourself some sanity by unplugging and opening up your box, grounding off any static electricity, and removing and reinserting your memory card(s).

It's not the most likely culprit by a long shot, but it is one that might not show up to any software tool, even one designed to check memory.

bassi
06-21-2002, 12:33 PM
it's the info.plist for the apps.

I trashed them for the problem apps and the problem dissolved away. I think it's only advisable if you think it's safe, although I was fed up and just did it. Maverick? Me?

"I'd ride you're tail anytime"

bluehz
06-21-2002, 02:45 PM
Which info plist? Are you saying to delete every info plist for evry app thats crashing? Thats a lot of plist's!


it's the info.plist for the apps.

bluehz
06-21-2002, 02:55 PM
Are you guys that are experiencing these same symptoms running anything modifying the keyboard?

Just curious as I remember reading about PowerDelete casuing problems related to keyboards. I don't use PowerDelete, but I am using TypeIt4Me - which also messes with the keyboard.

Wondering if this is a common thread we could track?

bassi
06-21-2002, 04:30 PM
I had three apps causing my major problems, so I just deleted three.

bluehz
06-21-2002, 04:35 PM
Wish I could narrow it down to three apps. There is no noticeable pattern on my machine. Not always the same apps...

logo
06-24-2002, 12:17 PM
Well I'm using Key Xing and LiteSwitch!

Same problem occuring, yet not that frequently...

Peter

Cobalt
06-25-2002, 04:22 PM
Just to chime in, I've been having similar problems over the last week or so. I've mostly noticed it Illustrator 10. Today it happened repeatedly in Eudora 5.1.1, and since I haven't been using AI 10 too much lately, I at first thought it was a Eudora bug, but now I'm having second thoughts.

Most of my crash logs have a line like this:
Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000015

For Eudora, the KERN thing was almost always "at 0x00000000" which seems like an odd place -- it's not in the middle of the memory, it's right at the very beginning (isn't it?).

For AI 10, the crashes happen after at least 15 minutes of use, sometimes a half hour or more of (straight) use (but if I leave AI in the background all day long, that doesn't affect it).

Does anyone have any ideas about what might be causing this? It just started happening within the last week or so, at about the same time I upgraded to 10.1.5. :( (Actually, I just went through the crash log, and every entry has been for OS version 10.1.5.) I may try deleting the info.plist files for the affected apps, but I'd rather not, especially since it seems to be related to 10.1.5....

bluehz
06-28-2002, 03:29 PM
I am REALLY started to get ticked off on this issue. Listen to us - talking about extensions, etc.......sounds just like pre-OS X days.

Cobalt
06-28-2002, 04:07 PM
Yeah, so much crashing is pretty annoying. :( I've been getting paranoid about saving stuff every 2 minutes when using Illustrator. Oddly, that seems to keep the crashes away. I guess it sort of makes sense, since the error messages seem to indicate a problem at a memory location; maybe whatever is causing the crash only happens when some between-saves-buffer gets too full... (or maybe I'm blowing smoke out my rear orifice, given how much I actually know about these things).

Does anyone have any clue as to whether there's going to be a 10.1.6 or some such "fix" to these problems coming out, or will Apple just come out with Jaguar (ie. 10.2 or 10.5, whatever they call it)?

Cobalt

logo
07-02-2002, 03:17 AM
Hi!

Not to keep people away from this thread ;) , but yet as a cross reference:
Apple Discussions: Applications Unexpectedly Quitting (http://discussions.info.apple.com/WebX?13@162.HyNFaMkncgC^7@.3bb7e23d/2)

and

Apple Discussions: makequeues bug in 10.1.5 ??? (http://discussions.info.apple.com/WebX?7@162.HyNFaMkncgC^13@.2cd8ac62/1)

HTH

Peter

jbmelby
07-05-2002, 10:10 AM
My crashes are occurring in Toast Titanium 5.1.4. Version 5.1.3 works with no problem. Here's my crash log:

Date/Time: 2002-07-05 08:03:20 -0500
OS Version: 10.1.5 (Build 5S66)
Host: localhost

Command: Toast Titanium
PID: 633

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0xc1f5ede8

Thread 0 Crashed:
#0 0x706bab78 in objc_msgSend
#1 0x70162ed4 in CFRelease
#2 0x006e44ac in 0x6e44ac
#3 0x006e4548 in 0x6e4548
#4 0x006e185c in 0x6e185c
#5 0x00671b84 in 0x671b84
#6 0x00671be8 in 0x671be8
#7 0x0066cef8 in 0x66cef8
#8 0x005d99d0 in 0x5d99d0
#9 0x006091f0 in 0x6091f0

Thread 1:
#0 0x70000978 in mach_msg_overwrite_trap
#1 0x70005a04 in mach_msg
#2 0x70026a2c in _pthread_become_available
#3 0x70026724 in pthread_exit
#4 0x70020550 in _pthread_body
#5 0x9421ffa0 in 0x9421ffa0

Thread 2:
#0 0x7003f4c8 in semaphore_wait_signal_trap
#1 0x7003f2c8 in _pthread_cond_wait
#2 0x006cc14c in 0x6cc14c
#3 0x006c6328 in 0x6c6328
#4 0x006c5c24 in 0x6c5c24
#5 0x006c5524 in 0x6c5524
#6 0x006c8cfc in 0x6c8cfc
#7 0x006c6c00 in 0x6c6c00
#8 0x006c6ab8 in 0x6c6ab8
#9 0x006c712c in 0x6c712c
#10 0x006c95dc in 0x6c95dc
#11 0x006c5fc4 in 0x6c5fc4
#12 0x7002054c in _pthread_body

Thread 3:
#0 0x70000978 in mach_msg_overwrite_trap
#1 0x70005a04 in mach_msg
#2 0x7017bf84 in __CFRunLoopRun
#3 0x701b70ec in CFRunLoopRunSpecific
#4 0x7017b8cc in CFRunLoopRunInMode
#5 0x7061be08 in XIOAudioDeviceManager::NotificationThread(XIOAudioDeviceManager *)
#6 0x706141c0 in CAPThread::Entry(CAPThread *)
#7 0x7002054c in _pthread_body

Thread 4:
#0 0x70000978 in mach_msg_overwrite_trap
#1 0x70005a04 in mach_msg
#2 0x7017bf84 in __CFRunLoopRun
#3 0x701b70ec in CFRunLoopRunSpecific
#4 0x7017b878 in CFRunLoopRun
#5 0x02937760 in -[MyCameraCentral wiringThread:]
#6 0x70842358 in forkThreadForFunction
#7 0x7002054c in _pthread_body

PPC Thread State:
srr0: 0x706bab78 srr1: 0x0200d030 vrsave: 0x00000000
xer: 0x00000018 lr: 0x70162ed4 ctr: 0x706bab4c mq: 0x00000000
r0: 0xc1b46ce0 r1: 0xbffff150 r2: 0x7018e3f8 r3: 0x0280c4a0
r4: 0x706d1b38 r5: 0x00000024 r6: 0x0000002c r7: 0x00000e03
r8: 0x80162e24 r9: 0x00418108 r10: 0x0000357b r11: 0xffffffff
r12: 0x706d1b38 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
r16: 0x00000001 r17: 0x00000007 r18: 0x008d4e90 r19: 0x008db380
r20: 0x008db2c0 r21: 0x008d4bc0 r22: 0x008b2350 r23: 0x008af6bc
r24: 0x008af6c0 r25: 0x028095a0 r26: 0x00000000 r27: 0x00000000
r28: 0x706bab4c r29: 0x0280c4a0 r30: 0x801608b4 r31: 0x70162e24

**********

Any ideas?

bluehz
07-05-2002, 02:51 PM
I can pretty much guarantee after I wake my machine - a dialog will be onscreen "Application XXX has unexpectdly quit" Not always the same one - seems completely random.

Maximac
07-29-2002, 11:58 AM
Could I wake-up this thread ?
Herafter My situation :
1) ORIGINAL FACTS
June 14th : Migrate to 10.1.5 and Install Office X and update coming with it;
Immediately quits of EXCEL and ENTOURAGE.
Nothing apparently with Word and Powerpoint ( no programing yet)
In the mean time Impossibility to quit EXCEL or POWERPOINT....infinite beachball loop ..obliged to force quitting...with also
Explorer quits (never before), finder hangup and all computer failed(One impossibility of shutdown) plus a lot of query on severs domains with failure......(fsck -y at resart OK!)

2) Install "Consol log" auto
Note an exception as following just after every startup :
----------------------------------------------------------------------------------------------------------------------------------------
2002-07-28 09:03:28.459 SystemUIServer[364] NSRulebook: Exception raised while retrieving a rulebook (FontSpecific^*^LucidaGrande-Bold)
2002-07-28 09:03:46.179 SystemUIServer[364] Thread 0x800013b8: tossing reply message sequence 10
----------------------------------------------------------------------------------------------------------------------------------------
Desinstall 2/3 times OFFICE X with deinstaller without putting the font Office reserv, each time with new prefs.
always quiting.

Going to Apple and MS forums confirm Font issue but Old ? sometimes link to 0SX 10.1.5 ?

Put all the fonts folder of my OS 9 partition on the desk
Reinstall the original set of fonts in root/system and root/library/font; remove user/library/font

3) In first time seems to work,during a few days, but after 3 weeks now, the quits of EXCEL and EXPLORER are continuing BUT AT A MUCH LOWER FREQUENCY !! 2-3/week instead 2-3/day.....
The message on LUCIDA GRANDE is still in Console Log and always a reference to Rulebookserver as foll' before crashing....Font issue again
----------------------------------------------------------------------------------
2002-07-23 09:49:09.713 loginwindow[311] Can't connect to pbs object "RulebookServer"
2002-07-23 09:49:09.714 loginwindow[311] Can't connect to pbs object "RulebookServer"
Jul 23 09:49:09 localhost /usr/libexec/CrashReporter: Succeeded writing crash report: /Users/alainqua/Library/Logs/Microsoft Excel.crash.log
----------------------------------------------------------------------------------
----------------------------------------------------------------------------------

Crash office notifications at startup

DOCK: CFMessagePortSendRequest returned -4
DOCK: CFMessagePortSendRequest returned -4
DOCK: CFMessagePortSendRequest returned -4
DOCK: CFMessagePortSendRequest returned -4
DOCK: CFMessagePortSendRequest returned -4
2002-06-19 15:05:46.162 loginwindow[307] Can't connect to pbs object "RulebookServer"
2002-06-19 15:05:46.163 loginwindow[307] Can't connect to pbs object "RulebookServer"
Jun 19 15:05:46 localhost /usr/libexec/CrashReporter: Succeeded writing crash report: /Users/alainqua/Library/Logs/Microsoft Office Notifications.crash.log
----------------------------------------------------------------------------------



4) STRANGELY THE INFINITE BEACHBALL LOOP of memory default management is still there 80% time on EXCEL and Powerpoint (never on WORD and Entourage) sometimes on IE 5.1
WORD ALWAYS QUIT CORRECTLY
When I want to quit EXCEL and if I got the infinite loop Consol log says....
----------------------------------------------------------------------------------------------------------
Jul 8 21:09:30 localhost WindowServer[2961]: CGSOrderWindow: Invalid other window
Jul 8 21:11:00 localhost /Applications/Microsoft Office X/Microsoft Excel: objc: cannot unmap an image containing ObjC data
----------------------------------------------------------------------------------------------------------
without macro in Excel and even if I try to create a new EXCEL X document COPYING THE DATA OF OLDER OFFICE EXCEL 2001 file
or a new Excel X file
I have again new trouble with printing (solved with 10.1.4 and new HP drivers) !! especially under Explorer !!

Any comments or help to solve totally unexpected quits and infinite loops wille be highly appreciated !! The 2 pbs seems linked
Is it possible to remove Lucide Grande Font (used by System !?) or how to replace in root/system/Library/fonts with original CD ?
Thanks in advance

gkkk4
07-31-2002, 12:58 PM
Here's a me-too reply - same issues, and btw, thanks to those who showed how to turn on Console crash logging. No one else has mentioned Dreamweaver MX as one of the crashers, which it is for me; also Eudora 5.1.1, IE 5.2.1, Netscape 6.2.3... can't remember the others, but there have been more.

Here's a twist - beginning a few days ago, the computer (G4 dual processor, 500Mhz, 712 MB RAM, 40 GB hd) started making random noises, at least, a specific random noise, that sounds like a groan (sort of) and is NOT an alert sound I've chosen (I only have the default sounds installed, no custom ones). This noise doesn't seem to be trying to call my attention to anything, no apps giving messages, and it's not at the same time as or before a crash. I've run Virex 7 and no viruses/trojans/etc are found. Related?? Maybe, maybe not... but I kid you not!

Hope someone comes up with an answer.
Thanks,
Gurukarm
:confused:

gkkk4
07-31-2002, 02:49 PM
Crash log as follows:

Date/Time: 2002-07-31 15:40:10 -0400
OS Version: 10.1.5 (Build 5S60b)

Command: Dreamweaver MX
PID: 509

Exception: EXC_BAD_INSTRUCTION (0x0002)
Code[0]: 0x00000002
Code[1]: 0x73146994

Thread 0:
#0 0x73146994 in GetCurrentWindowContext__Fv
#1 0x731b87b0 in GetWindowFromPlatformWindow
#2 0x731ae020 in FindPlatformWindow
#3 0x731cac04 in FindWindowCommon__FG5PointPP15OpaqueWindowPtrPs
#4 0x731becac in FindWindowOfClass
#5 0x731dacf8 in FindWindow
#6 0x00d6cef8 in 0xd6cef8
#7 0x00d6d0b8 in 0xd6d0b8
#8 0x00d6c020 in 0xd6c020
#9 0x00d6beec in 0xd6beec
#10 0x00d6be24 in 0xd6be24
#11 0x00d6f924 in 0xd6f924
#12 0x00d6f750 in 0xd6f750

Thread 1:
#0 0x70000978 in mach_msg_overwrite_trap
#1 0x70005a04 in mach_msg
#2 0x70026a2c in _pthread_become_available
#3 0x70026724 in pthread_exit
#4 0x70020550 in _pthread_body
#5 0x90010008 in 0x90010008

Thread 2:
#0 0x70000978 in mach_msg_overwrite_trap
#1 0x7024a0e8 in SwitchContexts
#2 0x702c9eec in YieldToThread
#3 0x70244b48 in SetThreadState
#4 0x702bbbe4 in SetThreadStateEndCritical
#5 0x00d2dc28 in 0xd2dc28
#6 0x00d2c8e4 in 0xd2c8e4
#7 0x00d2c7e0 in 0xd2c7e0
#8 0x00d2cbcc in 0xd2cbcc
#9 0x00d2df64 in 0xd2df64
#10 0x7027ae50 in CooperativeThread
#11 0x7002054c in _pthread_body

Thread 3:
#0 0x7000497c in syscall
#1 0x70557600 in BSD_waitevent
#2 0x70554b80 in CarbonSelectThreadFunc
#3 0x7002054c in _pthread_body

Thread 4:
#0 0x7003f4c8 in semaphore_wait_signal_trap
#1 0x7003f2c8 in _pthread_cond_wait
#2 0x705593ec in CarbonOperationThreadFunc
#3 0x7002054c in _pthread_body


PPC Thread State:
srr0: 0x73146994 srr1: 0x0008f030 vrsave: 0x00000000
xer: 0x00000014 lr: 0x731b87b0 ctr: 0x70000970 mq: 0x00000000
r0: 0x731ae020 r1: 0xbffff230 r2: 0x731dd734 r3: 0x00000008
r4: 0x00000003 r5: 0x00000034 r6: 0x0000003c r7: 0x00000e03
r8: 0x43300000 r9: 0x800000f7 r10: 0x00000008 r11: 0x77355310
r12: 0x70000970 r13: 0x00000000 r14: 0x00000013 r15: 0xbfffee58
r16: 0x000853d0 r17: 0x00000001 r18: 0x00607958 r19: 0x00002c03
r20: 0x00000000 r21: 0x0000001c r22: 0x70004234 r23: 0x700042c8
r24: 0x00000004 r25: 0x000006eb r26: 0x8081ab5c r27: 0x0005a730
r28: 0x00000000 r29: 0xbfffef00 r30: 0x8081d1cc r31: 0x00000001

**********

which is probably WAY more information than anyone's interested in... BUT, one thing that's interesting is that the Exception is EXC_BAD_INSTRUCTION(0x0002)
and the Codes are
Code[0]: 0x00000002
Code[1]: 0x73146994

rather than kernal information as others have posted. I know nothing about Unix; does this make sense to anyone? What does it mean? :confused:

Thanks,
Gurukarm

AKcrab
07-31-2002, 03:52 PM
I've been getting these since 10.1.5. Various apps, allways the same message.

gkkk4
07-31-2002, 04:08 PM
Since I just upgraded to OS X, 10.1.5 is what I've jumped in with... wonder if you can downgrade to 10.1.3? and is it worth it??? I've just had Dreamweaver crash twice on me this afternoon, and Photoshop 7 too - arrgghhhhhh!

Steaming,
Gurukarm

vickishome
07-31-2002, 05:12 PM
Being new to OS X, I had no idea the crashes I've experienced are abnormal for OS X. But upon checking my logs, sure enough, almost every crash log has a similar entry.

I've attempted to put the logs in a table form (I did this for me, but thought it might be of interest to others). What's interesting is that I see two different KERN codes: KERN_INVALID_ADDRESS and KERN_PROTECTION_FAILURE. I have no idea what any of this means.

One thing I can say for certain is that this had nothing to do with putting the Mac to sleep because my Mac has never been put to sleep (unless Apple did it before shipping it to me). My Mac runs 24/7/365 - no sleep and the HDs spin all night long. I only shut down for lightning storms.

Here's what my logs are showing me. I hope this formats okay on here.

(I've removed the table and placed it in a separate post below because of the way it causes the post to scroll to the right.)

Some of those crashes I very specifically remember. Perhaps this can add some pieces to the puzzle for those who understand all of these error messages.

The two crashes for the Adobe Illustrator Upgrade occured because I had already installed the upgrade on my hard drive back when I was running OS 9.2.2. I didn't know anything about OS X so I had installed it in the OS 9 App folder. I was trying to reinstall the upgrade in the OS X App folder without deleting my other install. When the upgrade installation crashed twice, I removed all of the Illustrator files from my hard drive and tried again with success.

I cannot explain the 5 crashes for A Better Finder Rename. I installed it as usual. I ran it one time with success. But every time I attempted to run it again, it crashed immediately. After 5 crashes, I trashed the app from my HD, thinking it was just a buggy app.

The other crashes were just random crashes that I cannot remember, but I will be watching now to see if I can figure out any kind of pattern.

vickishome
07-31-2002, 05:13 PM
Here's the table I mentioned in my post above ^^^


Date/Time ................... Command ........................ PID ... Exception ................. Codes
_____________________________ ________________________________ _______ ___________________________ ______________________________________________
2002-07-11 16:48:25 -0500 ... Finder ......................... 272 ... EXC_BAD_ACCESS (0x0001) ... KERN_PROTECTION_FAILURE (0x0002) at 0x00000069
2002-07-14 09:48:40 -0500 ... Finder ......................... 230 ... EXC_BAD_ACCESS (0x0001) ... KERN_PROTECTION_FAILURE (0x0002) at 0x00000fe5
2002-07-14 23:11:23 -0500 ... QuickTime Player ............... 346 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0x043dad70
2002-07-17 14:04:19 -0500 ... QuickTime Player ............... 330 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0x02c4de60
2002-07-19 15:36:27 -0500 ... Upgrade Adobe Illustrator 10 ... 708 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0xffffffff
2002-07-19 15:38:02 -0500 ... Upgrade Adobe Illustrator 10 ... 725 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0xffffffff
2002-07-19 15:58:42 -0500 ... Acrobat Reader 5.0 ............. 766 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0xffffffff
2002-07-19 22:20:36 -0500 ... WindowServer ................... 802 ... EXC_BAD_ACCESS (0x0001) ... KERN_PROTECTION_FAILURE (0x0002) at 0x00000000
2002-07-20 10:55:15 -0500 ... A Better Finder Rename ......... 356 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0xc000000e
2002-07-20 10:55:37 -0500 ... A Better Finder Rename ......... 361 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0xc000000e
2002-07-20 10:56:07 -0500 ... A Better Finder Rename ......... 366 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0xc000000e
2002-07-20 10:57:04 -0500 ... A Better Finder Rename ......... 371 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0xc000000e
2002-07-20 10:58:50 -0500 ... A Better Finder Rename ......... 376 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0xc000000e
2002-07-23 11:27:28 -0500 ... MacSOUP ........................ 557 ... EXC_BAD_ACCESS (0x0001) ... KERN_PROTECTION_FAILURE (0x0002) at 0x00000000
2002-07-26 00:26:43 -0500 ... Finder ......................... 272 ... EXC_BAD_ACCESS (0x0001) ... KERN_INVALID_ADDRESS (0x0001) at 0x01ead008
2002-07-29 22:08:33 -0500 ... Internet Explorer .............. 597 ... EXC_BAD_ACCESS (0x0001) ... KERN_PROTECTION_FAILURE (0x0002) at 0x00000000
2002-07-30 15:12:58 -0500 ... ContentIndexing ................ 726 ... EXC_BAD_ACCESS (0x0001) ... KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

mervTormel
07-31-2002, 05:33 PM
my interpretation is sloppy programming...

http://www.gnu.org/software/hurd/gnumach-doc/mach_5.html

your interpretation may vary.

vickishome
07-31-2002, 06:18 PM
Sloppy code in OS X 10.1.5? It can't be the apps because too many people ran the same apps in previous versions without the crashes. If it is a problem with the current version of 0S X itself, then we should hope for a fix at some point.

It's all my fault. I finally started using OS X, and all heck breaks loose. :D

mervTormel
07-31-2002, 06:24 PM
not everyone exercises the same code paths under the same circumstances and configurations. millions of lines of code, with many conditional branch instructions.

just running an app does not certify it is crash free, right?

and then there are sunspots.

--
A debugged program is one for which you have not yet found the conditions that make it fail. -- Jerry Ogdin

vickishome
07-31-2002, 06:30 PM
just running an app does not certify it is crash free, right?

True. But if a number of people have been running certain apps crash free for a long period of time, and then they suddenly began experiencing crashes, you have to ask what changed? If the crashes began shortly after upgrading their OS, then that's what I would suspect first.

Or maybe just sunspots. :D

AKcrab
07-31-2002, 10:29 PM
:cool: Sunspots :cool:

logo
08-01-2002, 03:14 AM
I want to speek strongly against the bad programming of the related apps:

1) I am not experiencing the crashes at the same spot with always the same app, yet occasionally in different apps

2) Yes it occured for shure after MacOS X 10.1.5

3) the number of apps that are mentioned is increasing steadily.

Do you say that so many OS X apps are sloppy programmed?

AKcrab
08-01-2002, 03:18 AM
I thought the consensus was that OS X had some sloppy coding in 10.1.5... My apps haven't changed, my OS has. (For the most part..) It seems to me the problem is too random, and too widespread over a large number of apps to be not and OS issue.
Maybe we should stick with the sunspot theory...

mervTormel
08-01-2002, 03:53 AM
i never stipulated whether the OS or the apps were at fault.

an OS and sw written for it have to play nice. there is a protocol that has to be strictly followed. there are many API's and sometimes the docs warn app developers that the interface may change in the future and not to "run renegade" in this code path and to prepare for the spec change.

either an API changed and the developers didn't reflect change in their code, or the OS has a bug. either the app or the OS is out of spec, effectively breaking it in future OS releases.

who knows? i just said sloppy programming somewhere.

the only reason i mentioned the app crash is that the only way to test API's is to write an app that uses it. where's the QA failure? i don't know. but it is specious and naive to say it isn't the app because it worked in a prior version of the OS. it is the onus of the developer to make provisions to be compliant with future revisions. and it is the onus of the OS to honor backwards compatability.

go compile some fink programs and watch how the configure runs and tests for how the app should be compiled. it'll give you an idea of how complex yet flexible the underlying architecture is.

and then there are the myriad user hardware configurations. and myriad user software configuations. and the myriad crazy speculations. find the pattern, whittle it down, and most times you'll find an embarrassed developer.

AKcrab
08-01-2002, 04:08 AM
Originally posted by mervTormel
either an API changed and the developers didn't reflect change in their code, or the OS has a bug. either the app or the OS is out of spec, effectively breaking it in future OS releases.

who knows? i just said sloppy programming somewhere.
Agreed. Is it August 24 yet?

am3
12-22-2003, 11:34 PM
This may get us all closer to a fix for apps crashing in OSX.

I found that after installing X11
all of my browsers (beside Safari) crashed on startup.

Then I created a new User Account and all of the browsers worked (beside OmniWeb).

So I now know its something wrong with-inside my admin user account folder.

I'm still hacking away.

ilona
03-02-2004, 01:26 AM
Hi,

has anyone by chance heard of a fix for this one yet?

I'm using InDesign when it 'quits unexpectedly', on OSX 10.2.6 - randomly and out of the blue.

I found in the system profiler log that I've had this error and the other one - KERN_PROTECTION_FAILURE - when various apps quit, Illustrator, Photoshop, Dreamweaver, Entourage, MWord, Safari, Suitcase and the OSX dock, over the last few months.

thanks

PopupToaster
03-02-2004, 08:49 AM
I'm having this problem too, running OSX 10.2.8. For me it mostly happens when I try to open certain folders, e.g. the Utilities Folder in the OS9 applications folder, the installation folder for Adobe Reader 6.

However, I've started a new user account and that account seems to work fine (I can even use it to install stuff that my regular account couldn't read -- and my regular account can then use the installed software). This suggests, as was mentioned before I think, that the fault is caused by something in the ~/Library/Preferences folder. I've tried deleting various things and it hasn't helped yet.

I'm planning to move my stuff over from my current account to a the one, but I'm sorry for all my preferences (*.plist) files which I'll probably have to sacrifice.

Michael

tu11ym0n
03-23-2004, 01:17 PM
same here even after a clean install of Panther.

lots of EXC_BAD_ACCESS and EXC_BAD_INSTRUCTION.

this is pretty much every app, even Apple apps like Safari, iTunes, etc.

I've done a clean install on a new partition. worked fine for a few hours then wham same problem.

repaired permissions (from both the boot drive and from the Panther install CD). ran Diskwarrior 3.01. ran Disk Utility from the Panther install CD.

created a new user and logged in as that new user.

all have not alleviated the problem.

does anyone have a clue?

i was about to buy a G5 but now i'm wondering if I should get a Dell (dude!).

thanks in advance.

daxpd28
04-27-2004, 09:00 PM
I'm having the same problems on a G5 thats 3 months old.
invalid_Kern_address , Kern_protection_failure. etc.

I've experienced the most problems in Illustrator CS, while using the hand tool to move around on the art board. In the worst cases, the entire system will freeze.. If Itunes is playing in the background, it will sit there and skip. I've also ran into this in Photoshop CS as well. Its been such a random happening that I can't narrow down the problem.

I thought the problem was related to font problems/problems with Extensis Suitcase, so I completely whiped out Extensis, cleaned all caches with cocktail as well as resetting all permissions to their default. Loaded font sets one by one, scanning for corrupt fonts and manageing duplicates along the way.

Next day, the entire system crashed while working on a small illustrator file with few fonts open. It really made no sense to me.

Is there any way to narrow this problem down? It seems to be happening on a range of systems. I'm thinking its a hardware issue, because I'm on a G4 Powerbook at home with an incredibly messed up font library in extensis, and I've never had an entire system crash. The G5 goes down almost daily.

hayne
04-27-2004, 09:08 PM
You no doubt have seen (in the searches that you did before posting) that a lot of these sorts of problems are attributable to bad RAM. This seems to have been particularly a problem with the G5's. So you should test your RAM (e.g. with memtester) and/or try removing some of it to isolate the problem.

tu11ym0n
04-27-2004, 10:20 PM
sorry to hear about your G5 troubles. i've decided not to get the G5 until the next revision comes out (and the coast is clear).

as for the constant crashes I wound up doing yet another clean install and used a different username when I set things up. I also made sure to disconnect any 3rd party peripherals when doing a reinstall. If possible, disconnect everything but your Apple Keyboard and Apple Mouse (yes, it's good for something).

I also decided to copy over as few prefs from my previous system as possible. so far so good. other than wasting a week of my life that is, when all the hours are added up.

i keep seeing this "bad RAM" response thrown around as the answer to all OS X woes. Frankly I don't buy it. I've had 3 G4 systems to deal with in regards to OS X and kernel panics and not one of them had RAM problems. and yes the RAM was tested.

fact is, OS X isn't the reliable OS it's hyped to be. Jaguar and now Panther still have these bizarre kernel panics with obfuscated error messages.

when it works it's great, but when it doesn't - it's friggin' HELL.

good luck!

hayne
04-28-2004, 01:37 AM
I've had 3 G4 systems to deal with in regards to OS X and kernel panics and not one of them had RAM problems. and yes the RAM was tested

So what was causng your kernel panics ?

daxpd28
04-28-2004, 08:06 AM
Could anyone direct me to the software I should use for testing my RAM.
I heard that the utility included with the OS software isn't very detailed when It comes to testing RAM. Is that true? Is memtester what I should use?

Thanks.
p.

pez
05-04-2004, 07:08 PM
Please correct me if I'm misunderstanding. I've just read this entire thread, starting with 2002 postings about the unexpexted quit problem.

It sounds like the bottom line is that OS X isn't perfect, and we're not going to find a fix. Does that sum it up?

I appreciate everyone's posting experiences, suggestions, and results. I'll keep watching for the day when someone can say "this fix solved it!"

In the meantime, I'm setting Auto Save to 2 minutes.

Pez

hayne
05-04-2004, 08:28 PM
It sounds like the bottom line is that OS X isn't perfect, and we're not going to find a fix. Does that sum it up?
Of course OS X isn't perfect.
But there are solutions for almost all the problems that people have experienced. But there is no one-size-fits-all solution. You need to do a fair bit of troubleshooting detective work to figure out what the problem is.
There have been lots of threads and articles on the main macosxhints site about what steps to take when troubleshooting.

boy_blunder
05-14-2004, 12:22 AM
I've gotten the same errors for some time now. Used to use Jaguar and had the problem. Now using Panther and have the problem from time to time. Sent the Powerbook in once to Apple, but they "couldn't find anything" even though I pointed them to the numerous crash log files in the Library folder that all repeat the same "KERN_INVALID_ADDRESS". I followed their advice to reformat the drive, reinstall only the basics, blah blah blah... all with the same results... Apps still crashing. In one of my many phone calls to Apple, I got one guy to admit that it might be memory related. It sounded right, but of course, the diagnostic disk that came with the computer didn't find anything, and neither does tech tools or disk warrior (except for a few permission issues, no big deals though).

Thought it might be the hard drive, but wouldn't a reformat take care of that? Or wouldn't disk warrior or the on board SMART catch problems?

I'm puzzled... and upset.

Clark

yellow
05-14-2004, 07:23 AM
"KERN_INVALID_ADDRESS" This is not the 'important' part of a crash log.. the rest of it is. At least, the rest of it gives far more clues to the cause of the crashes then "KERN_INVALID_ADDRESS" does.. But really you should start a new thread with your problem, as it may be slightly different then the OP's.

boy_blunder
07-07-2004, 04:18 AM
recently updated to the latest iPhoto. when it requested to "upgrade the thumbnails" it crashed... very a-la-micro$oft...

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0xffffffc0

Thread 0 Crashed:
0 <<00000000>> 0xffff8bbc __memcpy + 0x41c
1 com.apple.Foundation 0x909f9238 _deserializeBytes + 0x54
2 com.apple.Foundation 0x909fbb34 _decodeCStringAtCursor + 0x64
3 com.apple.Foundation 0x90a1e9a0 -[NSUnarchiver initForReadingWithData:] + 0xc0
4 com.apple.iPhoto 0x000afb5c 0x1000 + 0xaeb5c
5 com.apple.iPhoto 0x000ad2b8 0x1000 + 0xac2b8
6 com.apple.iPhoto 0x0008ad58 0x1000 + 0x89d58
7 com.apple.iPhoto 0x000836f4 0x1000 + 0x826f4
8 com.apple.iPhoto 0x000837ec 0x1000 + 0x827ec
9 com.apple.iPhoto 0x0007b5d8 0x1000 + 0x7a5d8
10 com.apple.iPhoto 0x0005bb78 0x1000 + 0x5ab78
11 com.apple.iPhoto 0x0005db0c 0x1000 + 0x5cb0c
12 com.apple.iPhoto 0x00044280 0x1000 + 0x43280
13 com.apple.Foundation 0x909f7184 _nsnote_callback + 0xb0
14 com.apple.CoreFoundation 0x901aa650 __CFXNotificationPost + 0x1b4
15 com.apple.CoreFoundation 0x901af060 _CFXNotificationPostNotification + 0x340
16 com.apple.Foundation 0x909f4fd0 -[NSNotificationCenter postNotificationName:object:userInfo:] + 0x74
17 com.apple.AppKit 0x92ee37b8 -[NSApplication _postDidFinishNotification] + 0x70
18 com.apple.AppKit 0x92ee36a4 -[NSApplication _sendFinishLaunchingNotification] + 0x5c
19 com.apple.AppKit 0x92ee38d4 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 0x78
20 com.apple.Foundation 0x90a4a544 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 0x164
21 com.apple.Foundation 0x90a50c6c _NSAppleEventManagerGenericHandler + 0x78
22 com.apple.AE 0x91674a68 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, unsigned char*) + 0xd0
23 com.apple.AE 0x916778b0 dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 0x2c
24 com.apple.AE 0x91674ca8 aeProcessAppleEvent + 0x11c
25 com.apple.HIToolbox 0x928c47f4 AEProcessAppleEvent + 0x3c
26 com.apple.AppKit 0x92dd2c0c _DPSNextEvent + 0x358
27 com.apple.AppKit 0x92de93b0 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 0x74
28 com.apple.AppKit 0x92dfd718 -[NSApplication run] + 0x21c
29 com.apple.AppKit 0x92eb9b80 NSApplicationMain + 0x1d0
30 com.apple.iPhoto 0x0011c374 0x1000 + 0x11b374
31 com.apple.iPhoto 0x00004460 0x1000 + 0x3460
32 dyld 0x8fe1a558 _dyld_start + 0x64