PDA

View Full Version : Application Unexpectedly Quit > KERN_PROTECTION_FAILURE


bluehz
06-16-2002, 10:56 PM
Starting last night - I have been getting several "Application Unexpectedly Quit" errors. Not one app in particular, but as one does it, you can be guaranteed many more will follow.

I perused the crash logs and they all have the same listing:

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000


Anyone know whats going on here?

dave@mmu
06-18-2002, 04:53 AM
i think maybe you might have a memory problem as the error is occuring at what appears to be the beginning of the memory..try swapping out any recently installed dimms..
Dave

bluehz
06-18-2002, 08:32 AM
No new memory installed in over a year. Never had the problem until about two days ago....I doubt the memory "went bad".

dave@mmu
06-18-2002, 08:35 AM
yeah you're probably right, oh well..
You've not had any electrical problems there have you? Maybe a current surge popped something?

Rod76
06-19-2002, 12:35 AM
Originally posted by bluehz
Starting last night - I have been getting several "Application Unexpectedly Quit" errors. Not one app in particular, but as one does it, you can be guaranteed many more will follow.

I perused the crash logs and they all have the same listing:

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000


Anyone know whats going on here?

I've been experiencing some of the same activity. The problem starts in Limewire and then subsequent other apps follow.... Where do I go to check the crash logs? I'd like to see if I can confirm your results. I wonder if this could be 10.1.5 related?

bluehz
06-19-2002, 12:44 AM
Look in the Library folder in your user folder and you will see a "logs" folder. The crash logs are located there.

cd ~/Library/Logs

I am highly suspicious of 10.1.5 - I have been running OS X for over a year solid now and have had NO PROBLEMS until about two days ago. I installed OS X 10.1.15 last week, but had to go out of town over the weekend, so I did not start really putting it through its paces until this week - when the problems started.

Rod76
06-19-2002, 01:46 AM
I think MacJanitor beat me too it...

I'm sure the problem will presist so I'll have another chance at it... If it is 10.1.5 more people will speak up...

mervTormel
06-19-2002, 02:21 AM
rod76, the majority of the items in ~/Library/Logs/ are application crash logs,
if you have crash logging enabled from the console.app preference. i
suspect you don't have app crash logging enabled, else your log dir would have
entries, like so, for crashed apps:

$ ll -ton ~/Library/Logs/
total 116k
-rw-r--r-- 1 501 12k Jun 18 23:38 Internet Explorer.crash.log
-rw-r--r-- 1 501 24k Jun 18 15:27 locate.crash.log
-rw-r--r-- 1 501 4.7k Jun 18 07:08 lookupd.crash.log
-rw-r--r-- 1 501 1.4k Jun 15 13:27 ditto.crash.log
-rw-r--r-- 1 501 2.1k Jun 9 21:06 PrintJobMgr.crash.log
-rw-r--r-- 1 501 5.0k Jun 8 03:42 Flash MX.crash.log
-rw-r--r-- 1 501 3.7k Jun 7 16:47 Mozilla.crash.log
-rw-r--r-- 1 501 3.8k Jun 5 21:03 DesktopConsole.crash.log
...


neither manjanitor, nor any stock maintenance script, cleans up ~/Library/Logs/

logo
06-19-2002, 02:24 AM
Hi out there!

I'm actually glad that I'm not the only one who is facing these problems. I could not find a reason so far why this is happening. (I guess we could merge the two threads http://forums.macosxhints.com/showthread.php?s=&threadid=3567). Every now and then I get these errors and the Console opens with yet another Crash log. (BTW: who knows why the console is opening all by itself. I know there is smth like CrashReporter running on my machine, but I don't know who enabled this and how to disable it)

I'm afraid to say though - that as far as I remember - this already happened before 10.1.5 . It's a couple of weeks old already...

I was thinking at a time that it was related to some of the utilities that I have installed on my machine... They are all disabled now and the problem is not that frequent as it used to be, but still it's happening...


So great that bluehz has started this thread

Peter :confused:

mervTormel
06-19-2002, 02:32 AM
you can disable app crashes opening a crash log by the console.app pref pane

/crashes\

[ ] Automatically display crash logs

bluehz
06-19-2002, 06:47 AM
What's making me angry is that I have had such a stable machine now for over a year and all of the sudden in one week I have dropped back to "OS 9" days. While I was just proclaiming the joys of OS X and why my OS 9 friends should switch - just last week - I am not sure I can do that this week.

Especially since this developed problem appears to be SO mysterious and the diagnosis and solution is SO elusive. I have posted this info on several boards and the diagnosis runs from "your machine is fried" to "you have a bad font". That's quite a large range to narrow down! At least now I know that it is PROBABLY not sepcific to my machine, there are several people experiencing this exact same problem.

....but that doesn't solve the problem....

logo
06-19-2002, 07:16 AM
Well let's think about it...

did we change some permissions in /Library or /System?
I did at least in /Library... :eek:
one thing I havent tried (as crashes don't happen so many times for me), but that as was suggested for troubleshooting in a couple of forums, is to use a new user with virgin settings for a while. Somewhat hard to take on, but maybe worth it. After a while you can start to merge your most needed Preferences one by one until the problems come back!

Peter

BTW: no RAM added or moved...

Rod76
06-19-2002, 11:33 PM
It happened agian and here is a segment of the crash log

Command: Fire
PID: 374

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0xcccccccc

Oh and MervTormel you where right I didn't have crash logging enabled in the console... Thanks for the heads up...

Sysoj
06-20-2002, 03:26 AM
Had the crashes several times for MS WordX, some browsers and clicking modem icon in menu bar. Got this in logs (do not understand anything):

2002-06-14 22:08:31.438 SystemUIServer[336] RKAlias: Making an FSRef from the path failed
2002-06-14 22:08:31.464 SystemUIServer[336] RKAlias: Making an FSRef from the path failed
...
...
Jun 14 22:08:48 localhost WindowServer[321]: CGXDisableUpdate: Updates disabled by connection 0x4607 for over 1.000000 seconds
...
...
2002-06-14 22:09:31.287 loginwindow[322] Can't connect to pbs object "RulebookServer"
2002-06-14 22:09:31.287 loginwindow[322] Can't connect to pbs object "RulebookServer"
...
...
Date/Time:
2002-06-08 01:39:01 +0200 OS Version: 10.1.5 (Build 5S60) Host: localhost Command: SystemUIServer PID: 392 Exception: EXC_BAD_ACCESS (0x0001) Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

mdale7
07-03-2002, 04:56 PM
I've been having a similar problem to everyone who has posted before. I was working on a friend's iMac trying to get the printcenter to work and experienced and unexpected crash. On my iMac quicken is acting this way. On my TiBook, excelX is now having the same problem.

HELP!!!

here's my crashlog
Date/Time: 2002-07-03 14:43:15 -0700
OS Version: 10.1.5 (Build 5S66)
Host: localhost

Command: Microsoft Excel
PID: 661

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
#0 0x00f7aae8 in 0xf7aae8
#1 0x0051f3c4 in 0x51f3c4
#2 0x0051efe4 in 0x51efe4
#3 0x0051ed74 in 0x51ed74
#4 0x0051dec8 in 0x51dec8

PPC Thread State:
srr0: 0x00f7aae8 srr1: 0x0000f030 vrsave: 0x00000000
xer: 0x00000018 lr: 0x0051f458 ctr: 0x00fc9c70 mq: 0x00000000
r0: 0x00000000 r1: 0xbffff4f0 r2: 0x017fa000 r3: 0x00000000
r4: 0x00000000 r5: 0x017fa304 r6: 0x00000000 r7: 0x74204578
r8: 0x00000013 r9: 0x004311a0 r10: 0x00431010 r11: 0x00000790
r12: 0x017f4da4 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
r16: 0x00000000 r17: 0x00000000 r18: 0x00000000 r19: 0x00000000
r20: 0x00000000 r21: 0x00000000 r22: 0x017a2864 r23: 0x017a1a1c
r24: 0x017a2ab0 r25: 0x017a99ac r26: 0x017a2868 r27: 0x017a2638
r28: 0x017a98a4 r29: 0x0179f584 r30: 0x00000001 r31: 0x00000000

**********

xTina
07-03-2002, 05:43 PM
I've also experienced lots of crashes since 10.5./Network Update/Airport Update/Fruit Menu Installation. Since I did all of those installs pretty much during the same time, I have no real idea whose fault it is. Almost all of the crashes occur directly after waking from sleep and clicking on an application icon of an already running application. Luckily it is this way ... I ususally save all work before putting the iBook to sleep, so it's not much of a problem (except for the bad "image" Apple gets when I'm opening my iBook to show something to a non-Mac user and the first thing an app does is crashing).

The Network Update was supposed to fix some sleep issues, so I kind of suspect it is causing the problems.

logo
07-04-2002, 09:30 AM
from
http://forums.macosxhints.com/showthread.php?s=&threadid=3567

as I see this thread is read the most!!!

Originally posted by logo
Hi!

Not to keep people away from this thread ;) , but yet as a cross reference:
Apple Discussions: Applications Unexpectedly Quitting (http://discussions.info.apple.com/WebX?13@162.HyNFaMkncgC^7@.3bb7e23d/2)

and

Apple Discussions: makequeues bug in 10.1.5 ??? (http://discussions.info.apple.com/WebX?7@162.HyNFaMkncgC^13@.2cd8ac62/1)

HTH

Peter

jbmelby
07-05-2002, 11:00 AM
I'm getting the same thing with Toast Titanium 5.1.4 (see http://forums.macosxhints.com/showthread.php?s=&threadid=3896). Version 5.1.3 runs just fine.

markwindt
12-31-2003, 06:03 PM
I started getting these about 1 month ago. I thought it was Retrospect because it would always crash during or after backups. After testing memory and many other things I called Apple. The tech believes its my Adaptec 29160 driver and Adaptec has just released update 1.2 for the driver. I installed today and will test to see if this is the problem. It is very frustrating. Especially on a server. What are you running?

markwindt
12-31-2003, 06:09 PM
I forgot to mention Im running 10.2.8 on a Dual Mirrored G4 with adaptec 29160 Controller and two 36GB drives. I also have an external LTO tape drive. So its not just 10.1.5 having problems.

Facade3
11-07-2004, 10:57 AM
It seems many of you have had problems with unexpected crashes. It seems that all of my browswers crash as of late for no apparent reason giving this error:

EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

I'm currently using OS X 10.3.5...it seems the the glitch (bug?) is happening also to the latest versions.

I have to resort to going back to OS 9 to use a browser.
Can anyone help as to why this is happening. I've visited several message boards and have seen the same thing and no one knows how to fix it :(

hayne
11-07-2004, 12:31 PM
Going back to OS 9 is quite a drastic step.
You would do better to troubleshoot the problem in OS X by following the suggestions of these documents:
http://www.macosxhints.com/article.php?story=2004011205473937
http://forums.osxfaq.com/viewtopic.php?t=7269

And if you show us the rest of the crash log (the interesting part is the 20 or so lines starting with "Thread n crashed" (where n is some number)), we could help zero in on the problem.

katzanne
01-14-2005, 12:10 PM
Hopefully by now you have fixed your problem; but if not, I hope this helps. I recently got a brand new G5 with added memory and my apps were quitting all over the place :eek: ran the Apple Hardware Test and memory passed with flying colors, but when I spoke with an Apple Tech in India, he told me that the Hardware test only samples the memory and that I needed to put the test on a loop.

Hold down the CONTROL key and the "L" key when you hit extended test start button and the words "Looping . . ." should appear in the bottom right window. That's how I found out that it was a memory problem after all. It may have to loop several times before showing up.

We removed that bad memory and it removed my quitting problems. I am happy again.

logo
01-15-2005, 02:26 AM
Where do I find the Apple Hardware Test program?

I didn't have the problem since 10.2 I think, but who knows...

hayne
01-15-2005, 02:48 AM
The Apple Hardware Test is usually on a separate CD that came with your computer.

But note that for the purpose of testing RAM, most people recommend using the (free) 3rd-party utility 'memtest':
http://www.memtestosx.org/

kev.b
03-14-2008, 04:39 PM
Consistently have this - but only on ONE site - can anyone help???
Is it a safari problem
all the best
Kev b

Date/Time: 2008-03-14 21:29:08 +0000
OS Version: 10.3.9 (Build 7W98)
Report Version: 2

Command: Safari
Path: /Applic?<ns/Safari.app/Contents/MacOS/Safari
Version: 1.3.2 (312.6)
PID: 513
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0 com.apple.JavaScriptCore 0x961d1bf8 compile_regex + 0x1ec
1 com.apple.JavaScriptCore 0x961d189c kjs_pcre_compile + 0x8c8
2 com.apple.JavaScriptCore 0x961e7fa4 _ZN3KJS6RegExpC4ERKNS_7UStringEi + 0xa4
3 com.apple.JavaScriptCore 0x961e7e24 _ZN3KJS15RegExpObjectImp9constructEPNS_9ExecStateERKNS_4ListE + 0x4c8
4 com.apple.JavaScriptCore 0x961c3270 _ZN3KJS11NewExprNode8evaluateEPNS_9ExecStateE + 0x2cc
5 com.apple.JavaScriptCore 0x961c9804 _ZN3KJS14AssignExprNode8evaluateEPNS_9ExecStateE + 0x28
6 com.apple.JavaScriptCore 0x961c00d4 _ZN3KJS11VarDeclNode8evaluateEPNS_9ExecStateE + 0x7c
7 com.apple.JavaScriptCore 0x961c4f28 _ZN3KJS15VarDeclListNode8evaluateEPNS_9ExecStateE + 0x44
8 com.apple.JavaScriptCore 0x961c2ec0 _ZN3KJS16VarStatementNode7executeEPNS_9ExecStateE + 0x80
9 com.apple.JavaScriptCore 0x961b9890 _ZN3KJS18SourceElementsNode7executeEPNS_9ExecStateE + 0x1f4
10 com.apple.JavaScriptCore 0x961c44d0 _ZN3KJS9BlockNode7executeEPNS_9ExecStateE + 0x88
11 com.apple.JavaScriptCore 0x961c08dc _ZN3KJS19DeclaredFunctionImp7executeEPNS_9ExecStateE + 0x2c
12 com.apple.JavaScriptCore 0x961bc620 _ZN3KJS11FunctionImp4callEPNS_9ExecStateERNS_6ObjectERKNS_4ListE + 0x1ac
13 com.apple.JavaScriptCore 0x961e5bd8 _ZN3KJS6Object4callEPNS_9ExecStateERS0_RKNS_4ListE + 0xac
14 com.apple.JavaScriptCore 0x961b7564 _ZN3KJS16FunctionCallNode8evaluateEPNS_9ExecStateE + 0x3a4
15 com.apple.JavaScriptCore 0x961ba840 _ZN3KJS17ExprStatementNode7executeEPNS_9ExecStateE + 0x80
16 com.apple.JavaScriptCore 0x961b9774 _ZN3KJS18SourceElementsNode7executeEPNS_9ExecStateE + 0xd8
17 com.apple.JavaScriptCore 0x961c44d0 _ZN3KJS9BlockNode7executeEPNS_9ExecStateE + 0x88
18 com.apple.JavaScriptCore 0x961dd228 _ZN3KJS14InterpreterImp8evaluateERKNS_7UStringERKNS_5ValueES3_i + 0x4e8
19 com.apple.JavaScriptCore 0x961ddc50 _ZN3KJS11Interpreter8evaluateERKNS_7UStringEiS3_RKNS_5ValueE + 0x40
20 com.apple.WebCore 0x9494b298 _ZN12KJSProxyImpl8evaluateE7QStringiRKS0_RKN3DOM4NodeE + 0xb8
21 com.apple.WebCore 0x9495d6ec _ZN9KHTMLPart13executeScriptE7QStringiRKN3DOM4NodeERKS0_ + 0x90
22 com.apple.WebCore 0x94a80134 _ZN5khtml13HTMLTokenizer15scriptExecutionERK7QStringS1_i + 0x1c0
23 com.apple.WebCore 0x94a84898 _ZN5khtml13HTMLTokenizer14notifyFinishedEPNS_12CachedObjectE + 0x138
24 com.apple.WebCore 0x9499b6a4 _ZN5khtml12CachedScript11checkNotifyEv + 0x5c
25 com.apple.WebCore 0x9499b614 _ZN5khtml12CachedScript4dataER7QBufferb + 0x154
26 com.apple.WebCore 0x94a863cc _ZN5khtml6Loader12slotFinishedEPN3KIO3JobEP6NSData + 0x1ac
27 com.apple.WebCore 0x94ac2948 _ZNK9KWQSignal4callEPN3KIO3JobEP6NSData + 0x90
28 com.apple.WebCore 0x94ac8584 -[KWQResourceLoader finishJobAndHandle:] + 0x3c
29 com.apple.WebKit 0x95015a00 -[WebSubresourceClient didFinishLoading] + 0x48
30 com.apple.WebKit 0x94fe8324 -[WebBaseResourceHandleDelegate connectionDidFinishLoading:] + 0x34
31 com.apple.Foundation 0x90a6dd2c -[NSURLConnection(NSURLConnectionInternal) _sendDidFinishLoadingCallback] + 0x4c
32 com.apple.Foundation 0x90a3d1dc -[NSURLConnection(NSURLConnectionInternal) _sendCallbacks] + 0x1f8
33 com.apple.Foundation 0x90a27864 -[NSArray makeObjectsPerformSelector:withObject:] + 0x108
34 com.apple.Foundation 0x90a51a04 _sendCallbacks + 0xd4
35 com.apple.CoreFoundation 0x901c4800 __CFRunLoopDoSources0 + 0x1fc
36 com.apple.CoreFoundation 0x901c20b8 __CFRunLoopRun + 0x1b0
37 com.apple.CoreFoundation 0x901c69e4 CFRunLoopRunSpecific + 0x148
38 com.apple.HIToolbox 0x92886e10 RunCurrentEventLoopInMode + 0xac
39 com.apple.HIToolbox 0x9288d53c ReceiveNextEventCommon + 0x17c
40 com.apple.HIToolbox 0x928af638 BlockUntilNextEventMatchingListInMode + 0x60
41 com.apple.AppKit 0x971ef248 _DPSNextEvent + 0x180
42 com.apple.AppKit 0x97205cc8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 0x74
43 com.apple.Safari 0x0000bda0 0x1000 + 0xada0
44 com.apple.AppKit 0x9721a048 -[NSApplication run] + 0x21c
45 com.apple.AppKit 0x972d6764 NSApplicationMain + 0x1d0
46 com.apple.Safari 0x00007fc4 0x1000 + 0x6fc4
47 com.apple.Safari 0x00054944 0x1000 + 0x53944