PDA

View Full Version : Cannot unmount disk -50


ronnie3636
01-15-2005, 03:11 AM
Hi,

OSX newbie calling.
Two problems which may be related.
I have LaCie external HD
I couldn't copy to it from a g3 oS9.2 machine getting error -51
I have migrated to a g5 10.3.7 machine copying all data and system folder
(Then archived on DVD)
I want to take all the old data and apps off the g5 and put onto the LC HD
I got error -51 again when I tried to copy.
I ran Disk Utlity and got damged message, and repaired.
I tried to erase using Disk Utility got message -50 "cannot unmount disc"
I searched your forum and found that the problem might be that the some app might be using a file so making the disk "busy" to UNIX
I quit all apps.
Still -51

The HD is showing that "launcher" from my old system is still there.
I cannot get rid of it as it is locked.
I also cannot get rid of it from my g5 HD.
Is this the problem?

How do I solve both problems?

(Not comfortable with CLI.)

Thanks in anticipation.

Ronnie

hayne
01-15-2005, 03:35 AM
I'm finding it a bit hard to understand what your situation is.
I think I've understood that you want to erase your external drive (using Disk Utility) but that this isn't working.
Please start off by restarting your Mac, then try again to run Disk Utility and tell us exactly what you did and the error messages you get (not the error numbers).

And note that many firewire drives needed an update in their firmware to work properly with recent versions of OS X, so you should check with the drive vendor's site to get the latest firmware.

As to your problem with Launcher being locked, please see the instructions about deleting files here:
http://www.thexlab.com/faqs/trash.html

Raven
01-17-2005, 09:28 AM
Also, if you simply want tot forcibly unmount your HD, you can do the following in Terminal:

cd /Volumes
then do an ls to list your volumes
then type umount -f your external volume's name

This will forcibly unmount the drive and willl not stop because of processes... A way to get unstuck without ahving to restart, but to be done as a last resort...

ronnie3636
01-18-2005, 08:05 AM
Hi,
I have trashed all I can see on La Cie HD, thanks.
I have quit all apps for all users, logged out and back in, restarted, (with HD put away then unplugged and reconnected.
I still get message Disk Erase failed with the error
Could not unmount disk

I am nervous about CLI stuff so haven't tried Raven's suggestion.

Disk is showing only about 50% available but no visible files.

Best

Ronnie

Raven
01-18-2005, 09:18 AM
If you've erased everything on the disk, try booting form your Panther CD and run disk utility from there on the LaCie disk to see if you can format it in HFS format...

By the way... if no info is on the disk, trying the command lines that I suggested cannot do any harm to your drive.

ronnie3636
01-19-2005, 10:13 AM
Raven

I get this:
Last login: Wed Jan 19 15:59:14 on ttyp1
Welcome to Darwin!
cpc1-kirk1-5-0-cust152:~ ronniesomerville$ cd /Volumes
cpc1-kirk1-5-0-cust152:/Volumes ronniesomerville$ ls
LaCieBackUpDrive Macintosh HD
cpc1-kirk1-5-0-cust152:/Volumes ronniesomerville$ cd /Volumes
cpc1-kirk1-5-0-cust152:/Volumes ronniesomerville$ ls
LaCieBackUpDrive Macintosh HD
cpc1-kirk1-5-0-cust152:/Volumes ronniesomerville$ umount -fLaCieBackUpDrive
umount: illegal option -- L
usage: umount [-fv] [-t fstypelist] special | node
umount -a[fv] [-h host] [-t fstypelist]
cpc1-kirk1-5-0-cust152:/Volumes ronniesomerville$

Raven
01-19-2005, 10:28 AM
Try putting a space in between the umount -f and the Volume name... What I suggest is that you type in the command part (umount -f) and then make a space and start typing the volume name while respecting lettre case, and then tab to make it auto-complete the name... Then hit enter.

Did you also try running from the OS cd and checking it in Disk Utility yet ?