PDA

View Full Version : G5 wont boot off CD, old drive, or new drive !!!


bex
01-14-2005, 11:20 PM
This has GOT to be the worst crash I have ever seen.

I have a dual 2.0 GHz G5 that crashed, and the drive looked MAJORLY corrupted. Since all the important stuff was backed up, I decided to boot from a CD, wipe the drive, reinstall the OS, and start over.

No go. IT WOULDNT BOOT OFF OF THE CD. Neither the recovery CD, nor a 10.3 CD. I just get the grey apple logo, and the spinning grey wheel for HOURS.

How wierd... I thought the drive was the problem, and somehow breaking the ability to boot off of a CD. So I got a brand new drive, plugged it in, and tried again.

No go. Still wouldn't boot off of the CD. Same grey apple.

So, I took it one step further. I booted it in Firewire Transfer mode, hooked it to a second computer, and forcefully installed the OS onto the G5 from the second computer. That's a nifty trick that I used to get OS 9 on the G5 a bit originally...

STILL no go. It still wont boot off of the CD or the new hard drive with a newly installed OS! What the #$%#%^#*&?!?

I flashed the PRAM. No go. I booted into Open Firmware and did "reset-nvram" and "set-defaults". No go. I even pushed that crazy little 'reset' button on the motherboard. STILL no go... although now I get the flashing question mark / OS 9 icon when booting off of disk. Haven't seen that in a while...

Interestingly, it would sometimes boot into single user mode... and it will also boot off of a GenToo Linux CD for the Mac. So it CAN boot off of some things... just not the recovery disk, the 10.3 CD, or either hard drive.

What can I do here? Is this a hardware issue and Im just screwed? Will I have to turn my pretty pretty G5 into a Linux server?

hayne
01-15-2005, 12:38 AM
I'm a bit confused about what your current situation is.
If I have understood you properly, you have installed a new internal hard drive in your G5, then used target disk mode to install Panther on that internal disk. And now it won't boot from the hard disk and it won't boot from the Panther Install CD.

First off, you are holding down the C key when you try to boot from the CD - right?

And I'm assuming when you say the "recovery CD" you mean the one that came with your G5 - right? Because these CDs are specific for the model they shipped with.

Maybe your CD drive is (slightly) broken. Or maybe your keyboard is (slightly) broken - so that the C key isn't being seen?

Are you sure that you've got the (new) internal hard drive installed correctly?

See this Apple doc on startup problems:
http://docs.info.apple.com/article.html?artnum=106464

I would recommend starting off by booting into single-user mode and doing a filesystem repair following the instructions of this Apple doc:
http://docs.info.apple.com/article.html?artnum=106214

Las_Vegas
01-15-2005, 03:12 AM
It sounds to me like you've installed OS 10.3.0 into your G5. I don't believe this will boot since G5 specific drivers are missing from 10.3. If you have the original restore CD that came with your G5, put it in the CD drive and boot with the Option key down. Your CD should appear for selection.

bex
01-16-2005, 09:32 AM
Thanks for the extra info and links!

Im going to do some reading, and run some more tests, and get back to you guys with the results. Hopefully something will work.

Ive been googling quite a bit, and haven't seen the info you guys showed me anywhere. Maybe my google skills are rusty...

bex
01-17-2005, 01:19 AM
Thanks for the suggestions, but nothing seems to be working.

Vegas: you were correct that the CDs I had were 10.3.0. So I downloaded the 10.3.7 update, mounted the G5 in transfer mode, and updated the OS to 10.3.7.

On my G4 I can see the OS as a startup disk as version 10.3.7, so I know it was installed (mostly) properly. And when I boot up the G5 with the option key down, I can see the system there as well. When I click on it and boot, I get a brief grey apple icon, the sound of disk access, then the grey circle with the slash through it denoting no valid system.

There is the possibility that when I installed the OS, certain G5 specific drivers did not get installed, because it thought the system was a G4. The only way I can think of to go from here is to forcibly install the drivers from the command line in single user more or something... but I cant find any info about that anywhere.

any more suggestions?