PDA

View Full Version : How can I "ping" a specific port?


insolution
04-24-2004, 07:09 AM
Something has "broken" Remote Desktop between my home and work. I can't see my work computers from home as I could last week. Any suggestions for isolating the cause?

My home network/firewall/router has not changed. My work network/firewall/router has not changed (for a fact). RD works fine on both network locally, so there is a block on that port on the network between the two locations, right?

How can I ping a specific UDP port on the remote network to see if the packets are getting through, or how can I further diagnose this? Adlephia claims they are not filtering on that port and my work ISP isn't (we have multiple T1 lines with them, they're small and I have a good relationship with their NOC, so I'm sure it's not them).

I'm stumped (not that hard to do :-)

Scott

yellow
04-24-2004, 07:42 AM
Got fink installed? Install nmap.
No fink installation? Install fink, then install nmap.

Once installed, it'd be something like:
sudo nmap -sU -p# -v x.x.x.x
Where # = the port you want to check out, and x.x.x.x is the IP address.


Or, if the command line is not your cup of joe, try this (old) GUIfied version (http://www.versiontracker.com/dyn/moreinfo/macosx/15728).

insolution
04-24-2004, 11:01 AM
I tried to install nmap, but I get the following error:

Can't exec "make": No such file or directory at /sw/lib/perl5/Fink/Services.pm line 398.
### execution of make failed, exit code -1
Failed: compiling fink-0.19.2-1 failed

Any ideas? I'm not very unix-literate :-(

Scott

hayne
04-24-2004, 11:09 AM
Did you install the Apple Developer Tools (XCode) ?
It is necessary to have them installed if you want to "install from source" in fink. That was a step that yellow omitted.
But isn't there a "binary" version of 'nmap' available from fink?

insolution
04-24-2004, 11:09 AM
OK< I ran nmap via the GUI tool and got:

running nmap -sU -p 3283 -R -vv 216.242.83.17


Starting nmap V. 3.00 ( www.insecure.org/nmap/ )
Host host17.nasfm.org (216.242.83.17) appears to be up ... good.
Initiating UDP Scan against host17.nasfm.org (216.242.83.17)
The UDP Scan took 1 second to scan 1 ports.
Adding open port 3283/udp
Interesting ports on host17.nasfm.org (216.242.83.17):
Port State Service
3283/udp open unknown

Nmap run completed -- 1 IP address (1 host up) scanned in 2 seconds

So now I know that the port is open on the other end, but RD still doesn't see that computer (or any on that network). It's not RD as I tried from both my G4 and my TiBook.

Is there a way to send a UDP packet on port 3283 and see if it gets received? Any idea how to go about troubleshooting this?

Scott

hayne
04-24-2004, 11:23 AM
The standard way to troubleshoot networking problems is to use Ethereal to look at the packets sent & received. But understanding this might require some knowledge of the RD protocol. Try looking at it from a location where RD is working, then maybe you can recognize what is not working when you do it from your location.