PDA

View Full Version : Excel Spreadsheet showing (not calculating) formulas


Irene
02-20-2004, 04:12 PM
Recently I was creating a new spreadsheet and for some mysterious reason it displayed rather than calculated formulas. If E12 was 763 and E13 was 34 and E15 was =E12+E13 it displayed that and not 776 in cell E15.

I did all the things I could think of to make it calculate, but to no avail.

Then I coped all my data and pasted it into a spread sheet and voila -- it calculated.

I've trashed the "defective" spreadsheet, but it occurs to me that it might be a handy tool sometimes. So, the question is what makes it display rather than calculate?

mervTormel
02-20-2004, 04:32 PM
perhaps the cell format was text only?

Irene
02-20-2004, 04:40 PM
No. In fact I tried general, number, currency.....

nkuvu
02-20-2004, 04:49 PM
I don't have Excel for OS X, but I do use it at work on Win2K.

Anyway, in the options there's a place to check (or uncheck) what to show in a window. One of those options is 'Formulas'.

If you have a strong tolerance for Windows graphics ( :) ) you can see what I mean (http://nkuvu.homeip.net/images/misc/excel_options.png).

Irene
02-20-2004, 05:25 PM
Interesting, but I could not find something similar in the Mac vversion.

I tried the automatic calculation that i usually use I tried the calculate now command, the insert function (sum) command....

nkuvu
02-20-2004, 05:44 PM
I'd be surprised if MS didn't have the same setting somewhere. What you described is exactly what that little check box does. Of course the difference in versions could make all the difference in being able to find said option...

CoolHand
02-20-2004, 05:56 PM
The formula was probably entered when the cell was in Text mode.

Change the cell to General in Format-Cells, then delete the formula and re-enter it.

Nice job, Bill.

CaptainK
05-22-2004, 09:56 PM
You need to open Excel and open a new spreadsheet.
Then go to the Excel menu---> Preferences--->View.
Uncheck Formula in the windows options and that should
resolve your issue. :)