PDA

View Full Version : Can't copy certain MP3 files


paulzoom
03-27-2002, 09:24 AM
This is a strange one. I am using Sputnix to download MP3s. The problem is that I can't copy them to my external firewire drive. I keep getting a "Sorry, but this operation cannot be complete, error -37". However I can copy them to my second internal drive and I can delete them. I checked the permissions and made sure the folders and drives for everything said read and write but that didn't help. I also tried changing the folder that the files are donwloaded to and still no luck.

The weird thing is that certain MP3 files I can copy but most I can't. This doesn't seem to effect any other files, only the MPs' I download from Sputnix. Also, it won't let me download straight to the external drive like Limewire did; it goes to the Sputnix cache file instead. I finally had to reboot in OS9 and copy the files that way. Does anyone have any suggestions? I bought my external drive for MP3s and don't want to fill up my internal drives.

mervTormel
03-27-2002, 02:50 PM
what version of sputnix?

yep. sputnix downloads to its cache dir first, then moves them to your designated mp3 download dir when they have completed.

could you isolate some rogue mp3 files and show us the results of:

% /bin/ls -lo /pathto/rogue_mp3files

i use sputnix and have not seen this behavior.

paulzoom
03-27-2002, 02:59 PM
I dowloaded it last week so I am sure it is the newest version.

Forgive my ignorance, but I am not sure what you mean by isolating the rogue files. I'm a newbie but if you could explain it to me I will try and do it.

Also, is seems that when I try and point the downloads to the external drive they just sit in the cache file and never get transferred. This doesn't seem to be a problem when I point it to my second internal drive.

mervTormel
03-27-2002, 03:14 PM
okay, paul, let's tackle one problem at a time. let's eliminate the problem of downloading to your external drive for the moment, and concentrate on what works okay? that is, your internal drive(s). let's pretend your external firewire drive isn't there; so set up sputnix so that it's cache dir and your designated download dir are somewhere vanilla, on your present drives. let's eliminate as many unknowns from the equation as we can. grok?

now, you said certain mp3 files, meaning the ones sputnix creates, can't be copied to your external drive. so, i am assuming the mp3 files you create from CDs, etc, copy okay.

isolate some ten or so of the rouge sputnix mp3s into a test dir and issue that 'ls' command on them.

why isolate? we're trying to whittle the task down to a managable size. i don't want to see your 2,000 mp3 files that are fine; just the questionable ones. then we'll go from there. kapish?

paulzoom
03-27-2002, 03:21 PM
Thanks for your patience.

I will attempt to do what you advise; I am at work right now and won't be able to get to my mac until tonight; I'll try and post the results tonight. What's weird is that there are a few Sputnix MP3s that I can copy to the firewire drive. I'm not sure why some work and some don't but I wlll give it a shot.

I'm a little shakey on going into root and doing the ls command but maybe I can get one of my Unix buddies to do if for me.

Thanks again for the advice. I'll let you know what I come up with.

mervTormel
03-27-2002, 03:37 PM
you're welcome.

you shouldn't be root at the command line. you should just be your login user. it'll be okay.
there are a few Sputnix MP3s that I can copy to the firewire drive. I'm not sure why some work and some don't.
that's what we're going to try and determine. what is the difference between these files and their environment?

as for UNIX buddies, be sure that you are comfortable with them and they are responsible at the helm. i don't think any waivers need to be signed, but i wouldn't let my mother drive my rig without some UNIX certification and a few courses in ethics.

paulzoom
03-29-2002, 08:36 AM
I reformatted the drive and now everything seems to work as it should.