PDA

View Full Version : Normal.dotm not saving in Word 2011


ronniebellie
11-03-2010, 08:50 AM
I'm not able to save the Normal.dotm in Word 2011. My 2004 Normal file has all my macros, shortcuts and autotext that I've built up for my business over the last 10 years. This Normal file is essential to me. I can open it in 2011 and see the macros, shortcuts and autotext and use them, but when I close Word 2011, it asks me to save Normal as Normal.dotm, but when I click Save, it keeps going back to the Save dialogue box and it is not saving it.

I called MS support and it's an advanced thing and would cost me $249 for support.

Any ideas?

porkpie
11-03-2010, 09:27 AM
save as?

Then replace and rename.

ronniebellie
11-03-2010, 09:45 AM
That doesn't work because when I quit Word 2011, I get this. Here's a screen shot.

http://homepage.mac.com/belisles/template.png

When I click save, it just keeps going back to this same screen. Or when I try to change the name, it still keeps popping back to the same save screen.

Any ideas?

porkpie
11-03-2010, 09:49 AM
Have you tried saving in a different location?

ronniebellie
11-03-2010, 09:57 AM
Yes, I've tried saving into a different location and it keeps popping back to the save dialogue in the screen shot. I'm afraid I might have to redo all my macros, short cuts, autotext entries, 10 years worth of work for my business.

porkpie
11-03-2010, 09:59 AM
Can you navigate in the finder to the location of the already saved Normal.dotm and copy that file. You won't be able to move it as it is in use, but you should be able to duplicate it. Then you will just lose whatever additions you have made in this session.

ronniebellie
11-03-2010, 10:38 AM
Yes, I can go to the folder. Do you mean do a desktop copy like in this screen shot?

http://homepage.mac.com/belisles/template2.png

Then what do I do?

porkpie
11-03-2010, 10:43 AM
OK, well if you move that copy to your desktop then it's backed up.

You can then do whatever you need to do to exit word/restart and then if the template doesn't load up by default then you have a backup.

But you will still lose any changes you have made since it was saved. But I don't see why you should lose 10 years of things.

ronniebellie
11-04-2010, 11:39 AM
But even though I do that, when prompted to save the normal.dotm file upon quitting Word, it still pops back to the same save dialogue box. Something is not allowing it to save.

dianeross
11-05-2010, 04:42 PM
I've seen reports where saving a font preference wasn't sticking too. Have you run Repair Permissions? If you do a Get Info, is the file locked?

ronniebellie
11-05-2010, 04:58 PM
I've heard this too and I've explored it. Here's a link talking about it.

http://www.officeformac.com/ms/ProductForums/Word/11738

I've repaired permission 2-3 times, but what I don't understand is how to use Font Book to get rid of potentially bad fonts.

ronniebellie
11-06-2010, 03:16 PM
I just figured out how to resolve duplicate fonts in Font Book. Did it to about 20 or more and then did Repair Permissions. Still not working.

dianeross
11-07-2010, 05:13 PM
Have you tested in a new User? Go to System Preferences --> Create a New User in Accounts. Switch to the New User by logging out/in or use Fast User Switching. Test Office there.

ronniebellie
11-07-2010, 05:52 PM
Yes, I've tested a new user and recorded some new macros and everything seems normal when I quit. New macros are saved as expected.

DeltaMac
11-07-2010, 06:03 PM
Where did that new user save the normal template for Word 2011?
And, is that the same (relative to the user folder) location for your important normal template?

ronniebellie
11-07-2010, 06:17 PM
In the new account, it's saving it in the default location here.


/Users/test/Library/Application Support/Microsoft/Office/User Templates/My Templates/Normal.dotm

However, in my regular account, when I open that folder, there's nothing in there. Strange.

When I open Word 2011, my old Normal is loading from Word 2004, and the old location was here.

/Users/ronnie/Documents/Microsoft User Data/My Templates

But when I quit Word 2011, it won't save as I mentioned above.

dianeross
11-08-2010, 03:38 PM
Download the latest Apple combo updater and run it. Something this will cure strange issues.

Leopard
Mac OS X 10.5.8 Combo Update (For both PowerPC- and Intel-based Macs )

http://support.apple.com/downloads/Mac_OS_X_10_5_8_Combo_Update

Snow Leopard
Mac OS X v10.6.4 Update (Combo)

http://support.apple.com/kb/DL1048
(http://support.apple.com/kb/DL1048)

dianeross
11-08-2010, 07:17 PM
Ok, this should do the trick....

Open Word, then go to Preferences>File Locations and read the entry in "User Templates". That's where it *is*

Looks like the new default location is here:

~/Library/Application Support/Microsoft/Office

ronniebellie
11-08-2010, 08:15 PM
I installed the Mac OS X v10.6.4 Update (Combo) and that did not change the situation.

uptimejeff
11-08-2010, 09:58 PM
I'm in the same boat.

My user is stuck attempting to save Normal.dotm but it never saves and just loops.

Things I've tried:
- exhaustive verification of permissions. I made sure everything in the path where the template is stored is readable (I chowned the entire user directory)
- Removed duplicate fonts. Font Book returns all green arrows on font validation.
- alternate user on the computer does work, but my user doesn't work
- Cleared font caches with Onyx and Font Nuke (rebooting each time)
- changed the file locations pref in MS Office to store templates on another folder
- unmounted file server (older MS office has an issue with duplicate UIDs connected to the same sharepoint, so I disconnected the share to eliminate the possibility)
- watched with fs_usage and confirmed that MS Word was using the folder I designated for templates (it was)
- copied the Normal.dotm file from another machine which didn't have the issue (reset owner via chown)

Obviously it's something within the user folder... I'll start narrowing that down tomorrow. Ugh, what a pain.

If anyone else has ideas.... I'm all ears.

Jeff

hayne
11-08-2010, 10:23 PM
Jeff:
Since you seem to be comfortable with the command-line, I'd suggest using some of the 'dtrace' facilities to look at what is happening when the save is failing. Start with 'man -k dtrace'
Note: you forgot to mention what versions of OS X and Word you have.

ronniebellie
11-09-2010, 07:42 AM
Jeff,

When and if you get it figured out, please let me know. I've tried everything too. I was able to transfer the autotext entries via Tools menu >> Templates and Add-Ins... by clicking on Organizer and transferring the autotext entries of Normal to the Normal (global template). But I could not figure out how to transfer keyboard shortcuts and macros. Starting all over with these seem daunting as I have 10 years of accumulation.

hayne
11-09-2010, 09:00 AM
But I could not figure out how to transfer keyboard shortcuts and macros. Starting all over with these seem daunting as I have 10 years of accumulation.

I'm still not understanding why you would lose 10 years of anything since you do have the file on your hard disk. (And you should make a backup of that file by the way.)

Perhaps you mean that you are trying to reproduce the content of that file in some other file. Not sure. Maybe we could get a recap of your current situation.

schwartze
11-09-2010, 10:27 AM
Take a look at this thread and see if anything can help you.

http://hintsforums.macworld.com/showthread.php?t=90701

uptimejeff
11-09-2010, 03:29 PM
Hayne

The machine with the issue is 10.6.4
Thanks for the recommendation to try dtrace...(haven't had time to try it yet)

Here's what I've discovered so far:

- I created a new user (test1) and copied the ~/Library folder of the 'user with trouble' over to the test1 user. The test1 user inherited the problem with the ~/Library folder. So it's something within the ~/Library folder causing this.

- Next I tried deleting the com.microsoft.office.plist on test1 user, this made no difference.

- I then created created another new user (test2) without copying the bad Library folder, this user did not have the problem.

- What I noticed different between test1 and test2 is that test1 had the MS First Run file
/Users/username//Library/Preferences/Microsoft/Office 11 First Run
So I deleted this file.
I also copied the entire folder:
/Users/test2/Library/Preferences/Microsoft/Office 2011
from test2 (working) to test1 (bad)

After this last step, I had to give the machine back to the user for a while... I was surprised with a call from the user that the problem is resolved.

I haven't had a chance to confirm it myself... so I can't report a confirmed fix. Perhaps someone else can try some or all of these steps.

Note- all copying from user to user included correcting permissions...

Jeff

ronniebellie
11-12-2010, 01:00 PM
The latest for me is that Word 2011 is opening with all my old 2004 macros, autotext, menus, etc. but when I quit Word 2011, it will not save this template file as Normal.dotm and I get the loop that Jeff described above. Thus new additions to the Normal file are not saving for me.

ronniebellie
11-18-2010, 09:08 AM
Somehow this got fixed and I'm not sure how. I uninstalled everything based on this page.

http://support.microsoft.com/kb/2398768

Then I fiddled around with Tools >>> Templates and Add-ins >>> Organizer

It's working now, but not I don't understand why.

cruiserboy
09-10-2012, 09:21 PM
I know this is an old thread, but here's another solution:

I've been having the same problem with MS Word 2011 always trying (and getting stuck) to save a normal.dotm file when i try to quit.

I managed to fix the problem by removing an old Normal template that was hiding here: Username/Documents/Microsoft User Data

iansnail
11-22-2012, 11:21 PM
<I managed to fix the problem by removing an old Normal template that was hiding here: Username/Documents/Microsoft User Data >

Thanks cruiserboy, that worked perfectly - I've also been searching for a fix for quite a while.

alesol
12-01-2012, 07:29 AM
What I did.
Open word (2011)
Make changes you want. I set font to "Ariel" and size to "14". For my tired, old eyes.
In the ribbon go to "Styles" 1st icon is "normal" right click on icon, and then left click on "modify"
Select " New docs based on this template" and click on "OK"
Close word and then open it. My changes open up as default.
I also modified some of the other styles to suit myself.

pearlyvictoria
05-31-2013, 08:27 PM
I just tried this suggestion. Maybe someone here posted it or I found it somewhere else...
Go to:
Username (your name)
documents
Microsoft User Data
Delete "Normal.dot"
Delete "BAckup of Normal.dot"
Close out Word
Restart Computer

To test I opened three documents in Word and then closed them without saving. Then I closed Word with a problem. Before this, Word had been unable to close for three weeks. Just kept looping within the "save normal" circuit.