PDA

View Full Version : X11 losing focus on a MacBook Pro


PhilMassey
09-02-2009, 11:48 PM
I have a new MacBook Pro, and love it, but have a problem that I don't have on my Mac Pro tower or iMacs. Every 10 seconds or so X11 loses focus. By this I mean that if I'm even typing in an xterm window, after 10 seconds I have to reclick in the window. Sometimes I get the spinning ball and the
focus then comes back by itself. It acts as if something is happening every 10 seconds. I tried replacing the standard X11 with XQuartz 2.4.0, and it made no difference. (I'm running the latest version of Leopard, 10.5.8. The only slightly unusual thing about my MacBook Pro is that it has one of the solid state disks, but I haven't noticed any weird behavior in non-X terminal windows. Any thoughts?
thanks,

PhilMassey
09-05-2009, 03:01 PM
One additional point: I did an OSX installation, hoping this would solve the problem. No such luck. Every 10 seconds in an X11 window I get the spinning ball for about 3 seconds or so, and then focus returns.

PhilMassey
09-09-2009, 11:26 PM
This issue is now resolved. By using the Activity Monitor, I found that something called SymUIAgent was appearing at the top of the CPU whenever the focus got lost. A little googling revealed this was some Norton's thing. I don't have Norton's running on my MacBook Pro (at least, I thought I didn't!) but I had copied over a lot of things from my old laptop and apparently this one came along for the ride. I deleted the relevant subdirectories in /Library, SymUIAgent no longer shows up in the monitor, and X11 holds its focus just fine. Problem solved.